3ds max 2010 zoom issue?

Questions and answers about 3Dconnexion devices on Windows

Moderator: Moderators

3ds max 2010 zoom issue?

Postby RICH055 » Mon Mar 01, 2010 5:02 pm

Sometimes with SpacePilot (win64x) i cant zoom in very close, it becomes a wresting match to zoom in. is there an issue the the device and max? is there some setting in max that is holding me back from zooming in? thanks
RICH055
 
Posts: 11
Joined: Wed Aug 19, 2009 3:44 pm

Zooming close-in is impossible (3dsmax 2010 x64)

Postby deleyt » Wed Mar 24, 2010 8:56 am

I'm having the same issue. When zooming in with my SpaceNavigator in 3dsmax 2010 x64, it starts zooming in to a certain point, then it just stops zooming in, although it is trying to do so as I can see the geometry being redrawn.

I'm a new user of the SpaceNavigator and are still adapting so could well be that it's a setting that I missed. If so, sorry about that, but some help would be greatly appreciated.

Thanks.
deleyt
 
Posts: 7
Joined: Wed Mar 24, 2010 8:40 am
Location: The Netherlands

Postby Fred » Thu Mar 25, 2010 4:55 am

Are you using a target camera?
We need a little more descriptive information.

" USING 3DxStudio
------------------

On this version, you can move and rotate objects. You can move or rotate one or more objects.
First you select the object(s) , and then the moves are applied on the object(s).
You can move and rotate the selected object(s) either with respect to the Screen
reference coordinates, or with respect to your preferred coordinate system (depending
on the currents settings of 3ds max).

You can select the Viewport checkbox in order to move the viewports : either user
or perspective viewports, or camera viewports . All the moves in the viewports are
in regards of the screen reference coordinate.
When using a TARGET CAMERA, the moves are "limited" because of limitation of the
target. The camera always looks at the target, even if you try to rotate.

When moving viewports, you can select to move them as a camera view, or you can
select to move the scene as you do when you move objects."
Fred
Moderator
Moderator
 
Posts: 997
Joined: Wed Dec 06, 2006 7:15 am
Location: Rochester, NY

Postby deleyt » Thu Mar 25, 2010 12:11 pm

Fred wrote:Are you using a target camera?
We need a little more descriptive information.

Thanks for replying.
I am not using any camera. There aren't any camera's in my scene yet.
I am using the standard Perspective viewport (one of the four viewports within 3dsm), which switches to 3DxStudio Perspective as soon as I use the SpaceNavigator. The viewport is maximized.

The 3Dx Control Panel is set to:
Camera/View Movement: Move scene.
Center of Rotation: Scene/Object.
Disable Rolling is checked.
All other options are OFF.

While zooming in by pulling the SpaceNavigator knob it starts zooming in, until it gradually slows down and not zoom in at all anymore. To come out of the zoom I either have to push the knob long enough and the scene gradually comes back in view again.
It almost feels as if the SpaceNavigator is restricted to zoom in a certain amount and not further.

Hope this helps in understanding the problem.
deleyt
 
Posts: 7
Joined: Wed Mar 24, 2010 8:40 am
Location: The Netherlands

Postby deleyt » Thu Mar 25, 2010 12:54 pm

ADD:
I'm noticing that the zooming-restriction apparantly only kicks in when NO object is selected. As soon as an object is selected it zooms in quite well on the object.
So my remark only applies to when no object in the scene is selected and one tries to zoom in within the scene.
deleyt
 
Posts: 7
Joined: Wed Mar 24, 2010 8:40 am
Location: The Netherlands

Postby deleyt » Thu Mar 25, 2010 1:04 pm

ADD: (sorry...I can't edit my own posts, so Ill be adding replies :roll: )
When I zoom in with no object selected, it stops at a certain point. Then, when I select an object, I can zoom in further. When I deselect the object (so no object is selected anymore) I can only zoom out a certain extend. So the reverse for zooming in is true for zooming out aswell.
Very strange.... :?:
deleyt
 
Posts: 7
Joined: Wed Mar 24, 2010 8:40 am
Location: The Netherlands

Postby Fred » Fri Mar 26, 2010 5:15 am

Thank you for the additional input.
I'll pass this thread up to the programmers to see if they can give some input. The restriction may have been placed their on purpose due to restriction in place in 3DSmax.
Fred
Moderator
Moderator
 
Posts: 997
Joined: Wed Dec 06, 2006 7:15 am
Location: Rochester, NY

Postby deleyt » Tue Apr 20, 2010 5:47 am

Bump!
It's been 3 weeks since a last reply.

I'm still having problems with my SpaceNavigator regarding zooming in and out being restricted in 3DSMax 2010, Win7 x64.

See above posts.
deleyt
 
Posts: 7
Joined: Wed Mar 24, 2010 8:40 am
Location: The Netherlands

Postby pasoawe » Thu May 06, 2010 3:42 am

This is a good discussion.It is helpfull to me.
pasoawe
 
Posts: 1
Joined: Thu May 06, 2010 1:56 am
Location: United States

Postby Bumper » Wed Nov 02, 2011 6:41 pm

And almost 6 months later; I too am having this issue. Any word?
Bumper
 
Posts: 38
Joined: Sat Sep 19, 2009 6:38 pm
Location: Boston, Massachusetts

Postby Bumper » Wed Nov 02, 2011 6:48 pm

When I go to camera mode it's not an issue. I'm only experiencing this is object or camera_target mode.

Perhaps this is a feature?

I'd really love to be able to target an object AND have the non-slowing "zoom" like in camera mode.
Bumper
 
Posts: 38
Joined: Sat Sep 19, 2009 6:38 pm
Location: Boston, Massachusetts

Postby Loki » Mon Jan 02, 2012 1:12 am

3ds Max uses a progressive zoom system in the perspective view. The further you zoom in, the finer the increments become. This gives the appearance that zooming has come to a halt. Imagine trying to travel one mile by only moving half that distance, then half of that distance, then half of that ad infinitum. You'll never reach your destination and at some point you'll appear to be not moving at all, even though you technically are.

I find it happens most often when using mouse wheel navigation. Try pressing the zoom extents button (or hotkey), then switch to the zoom tool in the lower right and zoom in with it. The mouse wheel should work the way you expect it to after that. Another option is to switch to an orthographic view and work in there instead of perspective. Hope that helps.
Loki
 
Posts: 26
Joined: Mon Jan 02, 2012 12:30 am


Return to Windows Discussion Forum

Who is online

Users browsing this forum: Google [Bot] and 6 guests