CATIAV4 does not react

Questions and answers about 3Dconnexion devices on UNIX and Linux.

Moderator: Moderators

Post Reply
knight2003
Posts: 5
Joined: Wed Sep 03, 2014 8:53 pm

CATIAV4 does not react

Post by knight2003 » Wed Sep 03, 2014 10:26 pm

I have the following environment.
・SpaceExplorer-USB
・IBM Power750
・AIX5.3TL12

# lsdev -C|grep mouse
mouse0 Available 1.1 USB mouse
mouse1 Available 0.2 USB 3D mouse

I installed "3dxware-aix5-v1-6-0.tar.gz".
(->/etc/inittab
3d:234:respawn:/etc/3DxWare/daemon/3dxsrv -d usb -debug -E </dev/null >/dev/null 2>&1 )

It seems that the daemon process is runninng.

# ps -ef|grep 3dx|grep -v grep
usr4241 471116 1 0 05:07:13 - 0:00 /etc/3DxWare/daemon/3dxsrv

However, even if it starts CATIA(V4Relase2.4Refresh1), it does not react to SpaceExplorer.

Why is it?
Please let me know a checking point.


-------------------------< /tmp/3DxWare.log >-------------------------
3DxWareUNIX V1.6.0 ID 7205 log file
Process ID: 458896
Time: 2014-09-05 05:17:38
Machineinfo 1: Systemname=AIX, Nodename=ret069, Release=3
Machineinfo 2: Version=5, Machine=00F61F8A4C00
Runlevel-Info: . run-level 2 Sep 05 04:52 2 0 S
-----------------------------------
[2014-09-05 05:17:38] uddev.c, 783: UdDevInit() 20021588
[2014-09-05 05:17:38] 3dxsrv.c,806: displayname = $DISPLAY set to :0
[2014-09-05 05:17:38] 3dxsrv.c,811: putenv() was successful
[2014-09-05 05:17:38] 3dxsrv.c,813: displayname is now :0
[2014-09-05 05:17:39] auth.c :: authGetUser(), FOUND: user = usr4241, id = dt, line = vty0, pid = 168154, host = ,type = 7
[2014-09-05 05:17:39] auth.c :: authGetUser(), FOUND: user home = "/home/usr4241"
[2014-09-05 05:17:39] 3dxsrv.c :: startupInittab(), authGetUser(), user=usr4241
[2014-09-05 05:17:39] UdDev: Opening USB device on USB port /dev/mouse1
[2014-09-05 05:17:39] UdDev: Opening SpaceExplorer on USB port /dev/mouse1
[2014-09-05 05:17:39] sexplorer_usb.c, 351: UdDevRezero(): Rezeroing the device
[2014-09-05 05:17:39] sexplorer_usb.c :: UdDevSetDeadband(): Setting deadband to 26
[2014-09-05 05:17:39] 3dxsrv.c,831: UdDevOpen() was successful [SpaceExplorer]
----------------------------------------------------------------------

Barbara
Moderator
Moderator
Posts: 534
Joined: Fri May 14, 2010 11:11 am

Re: CATIAV4 does not react

Post by Barbara » Thu Sep 04, 2014 6:16 pm

Hello knight2003 -

Your log shows 3dxsrv running but you should also have the 3Dconnexion Control Panel window and be able to open the xcube and xvalue demos - /tmp/xcube and /tmp/xvalue .

The installation needs to be run as root. You can disable the start from /etc/inittab and launch it from the command line with

/etc/3DxWare/daemon/3dxsrv -d usb

When the driver starts the 3Dconnexion Control Panel should open - usually minimized on the task bar. The xcube and xvalue demos need to be started from the same $DISPLAY. Once the Space Explorer responds in the demos you can open Catia and it should recognize the Space Explorer is available.
----------------
Barbara

knight2003
Posts: 5
Joined: Wed Sep 03, 2014 8:53 pm

Re: CATIAV4 does not react

Post by knight2003 » Thu Sep 04, 2014 7:24 pm

Hello Barbara

I tried doing it as of your instructions.
(disable the start from /etc/inittab)

Then, I tried to run the command, but "the 3Dconnexion Control Panel" does not appear. (It does not start even 3dxsrv process)

(1st TRY)
# /etc/3DxWare/daemon/3dxsrv -d usb -debug
[2014-09-06 01:42:47] uddev.c, 783: UdDevInit() 20021588
[2014-09-06 01:42:47] 3dxsrv.c,806: displayname = :0.0
[2014-09-06 01:42:47] auth.c :: authGetUser(), FOUND: user = root, id = dt, line = vty0, pid = 176286, host = , type = 7
[2014-09-06 01:42:47] auth.c :: authGetUser(), FOUND: user home = "/"
[2014-09-06 01:42:47] 3dxsrv.c :: startupCommandLine(), authGetUser(), user=root
[2014-09-06 01:42:47] UdDev: Opening USB device on USB port /dev/mouse1
[2014-09-06 01:42:47] UdDev: Opening SpaceExplorer on USB port /dev/mouse1
[2014-09-06 01:42:47] sexplorer_usb.c, 351: UdDevRezero(): Rezeroing the device
[2014-09-06 01:42:47] sexplorer_usb.c :: UdDevSetDeadband(): Setting deadband to 26
[2014-09-06 01:42:47] 3dxsrv.c,831: UdDevOpen() was successful [SpaceExplorer]
[2014-09-06 01:42:47] 3dxsrv.c,842: authorizeWithX11() was successful
[2014-09-06 01:42:47] 3dxsrv.c :: startupCommandLine(), XOpenDisplay called with display name=:0.0, display = 20027ef8
[2014-09-06 01:42:47] 3dxsrv.c :: startupCommandLine(), SUCCESS!

3DxWareUNIX = V1.6.0
Device = SpaceExplorer
Firmware = V3.18
[2014-09-06 01:42:47] Home directory: /
[2014-09-06 01:42:47] UiSb: Directory "/etc/3DxWare" opened for configs.
[2014-09-06 01:42:47] UiSb: Directory "//.3dxcfg" not found
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 53 (X_CreatePixmap)
Value in failed request: 0x18
Serial number of failed request: 243
Current serial number in output stream: 245

(Second TRY)
# echo $DISPLAY
:0.0
# export DISPLAY=ret069:0.0
#
# /etc/3DxWare/daemon/3dxsrv -d usb -debug
[2014-09-06 01:45:34] uddev.c, 783: UdDevInit() 20021588
[2014-09-06 01:45:34] 3dxsrv.c,806: displayname = ret069:0.0
[2014-09-06 01:45:34] auth.c :: authGetUser(), FOUND: user = root, id = dt, line = vty0, pid = 176286, host = , type = 7
[2014-09-06 01:45:34] auth.c :: authGetUser(), FOUND: user home = "/"
[2014-09-06 01:45:34] 3dxsrv.c :: startupCommandLine(), authGetUser(), user=root
[2014-09-06 01:45:34] UdDev: Opening USB device on USB port /dev/mouse1
[2014-09-06 01:45:34] UdDev: Opening SpaceExplorer on USB port /dev/mouse1
[2014-09-06 01:45:34] sexplorer_usb.c, 351: UdDevRezero(): Rezeroing the device
[2014-09-06 01:45:34] sexplorer_usb.c :: UdDevSetDeadband(): Setting deadband to 26
[2014-09-06 01:45:34] 3dxsrv.c,831: UdDevOpen() was successful [SpaceExplorer]
[2014-09-06 01:45:35] 3dxsrv.c,842: authorizeWithX11() was successful
[2014-09-06 01:45:35] 3dxsrv.c :: startupCommandLine(), XOpenDisplay called with display name=ret069:0.0, display = 20027ef8
[2014-09-06 01:45:35] 3dxsrv.c :: startupCommandLine(), SUCCESS!

3DxWareUNIX = V1.6.0
Device = SpaceExplorer
Firmware = V3.18
[2014-09-06 01:45:35] Home directory: /
[2014-09-06 01:45:35] UiSb: Directory "/etc/3DxWare" opened for configs.
[2014-09-06 01:45:35] UiSb: Directory "//.3dxcfg" not found
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 53 (X_CreatePixmap)
Value in failed request: 0x18
Serial number of failed request: 244
Current serial number in output stream: 246
#

----------
knight2003

Barbara
Moderator
Moderator
Posts: 534
Joined: Fri May 14, 2010 11:11 am

Re: CATIAV4 does not react

Post by Barbara » Sat Sep 06, 2014 8:38 am

Hello knight2003 -

Try using "xhost + localhost" at the command line before starting the driver then once 3dxsrv is running open /tmp/xcube.

This thread has an instance where 3dxsrv is running but not opening a window as you are seeing. The OS in that case is SUSE but the xhost behavior should be similar.
-------------
Barbara

knight2003
Posts: 5
Joined: Wed Sep 03, 2014 8:53 pm

Re: CATIAV4 does not react

Post by knight2003 » Mon Sep 08, 2014 2:55 am

Hello Barbara -

I also run the xhost command, the results did not change.

"X Error of failed request" occurs, 3dxsrv daemon does not start.

Code: Select all

#xhost +
access control disabled, clients can connect from any host
# /etc/3DxWare/daemon/3dxsrv -d usb -debug
[2014-09-09 09:31:34] uddev.c, 783: UdDevInit() 20021588
[2014-09-09 09:31:34] 3dxsrv.c,806: displayname = :0.0
[2014-09-09 09:31:34] auth.c :: authGetUser(), FOUND: user = root, id = dt, line = lft0, pid =   340148, host = , type = 7
[2014-09-09 09:31:34] auth.c :: authGetUser(), FOUND: user home = "/"
[2014-09-09 09:31:34] 3dxsrv.c :: startupCommandLine(), authGetUser(), user=root
[2014-09-09 09:31:34] UdDev: Opening USB device on USB port /dev/mouse1
[2014-09-09 09:31:34] UdDev: Opening SpaceExplorer on USB port /dev/mouse1
[2014-09-09 09:31:34] sexplorer_usb.c, 351: UdDevRezero(): Rezeroing the device
[2014-09-09 09:31:34] sexplorer_usb.c :: UdDevSetDeadband(): Setting deadband to 26
[2014-09-09 09:31:34] 3dxsrv.c,831: UdDevOpen() was successful [SpaceExplorer]
[2014-09-09 09:31:34] 3dxsrv.c,842: authorizeWithX11() was successful
[2014-09-09 09:31:34] 3dxsrv.c :: startupCommandLine(), XOpenDisplay called with
 display name=:0.0, display = 20027ef8
[2014-09-09 09:31:34] 3dxsrv.c :: startupCommandLine(), SUCCESS!

3DxWareUNIX = V1.6.0
Device      = SpaceExplorer
Firmware    = V3.18
[2014-09-09 09:31:34] Home directory: /
[2014-09-09 09:31:34] UiSb: Directory "/etc/3DxWare" opened for configs.
[2014-09-09 09:31:34] UiSb: Directory "//.3dxcfg" not found
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  53 (X_CreatePixmap)
  Value in failed request:  0x18
  Serial number of failed request:  248
  Current serial number in output stream:  250
# 
#xhost + localhost
localhost being added to access control list
# /etc/3DxWare/daemon/3dxsrv -d usb -debug
[2014-09-09 09:32:04] uddev.c, 783: UdDevInit() 20021588
[2014-09-09 09:32:04] 3dxsrv.c,806: displayname = :0.0
[2014-09-09 09:32:04] auth.c :: authGetUser(), FOUND: user = root, id = dt, line = lft0, pid =   340148, host = , type = 7
[2014-09-09 09:32:04] auth.c :: authGetUser(), FOUND: user home = "/"
[2014-09-09 09:32:04] 3dxsrv.c :: startupCommandLine(), authGetUser(), user=root
[2014-09-09 09:32:04] UdDev: Opening USB device on USB port /dev/mouse1
[2014-09-09 09:32:04] UdDev: Opening SpaceExplorer on USB port /dev/mouse1
[2014-09-09 09:32:04] sexplorer_usb.c, 351: UdDevRezero(): Rezeroing the device
[2014-09-09 09:32:04] sexplorer_usb.c :: UdDevSetDeadband(): Setting deadband to 26
[2014-09-09 09:32:04] 3dxsrv.c,831: UdDevOpen() was successful [SpaceExplorer]
[2014-09-09 09:32:04] 3dxsrv.c,842: authorizeWithX11() was successful
[2014-09-09 09:32:04] 3dxsrv.c :: startupCommandLine(), XOpenDisplay called with display name=:0.0, display = 20027ef8
[2014-09-09 09:32:04] 3dxsrv.c :: startupCommandLine(), SUCCESS!

3DxWareUNIX = V1.6.0
Device      = SpaceExplorer
Firmware    = V3.18
[2014-09-09 09:32:04] Home directory: /
[2014-09-09 09:32:04] UiSb: Directory "/etc/3DxWare" opened for configs.
[2014-09-09 09:32:04] UiSb: Directory "//.3dxcfg" not found
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  53 (X_CreatePixmap)
  Value in failed request:  0x18
  Serial number of failed request:  242
  Current serial number in output stream:  244
# 
----------
knight2003

knight2003
Posts: 5
Joined: Wed Sep 03, 2014 8:53 pm

Re: CATIAV4 does not react

Post by knight2003 » Mon Sep 08, 2014 6:13 pm

Hello Barbara -

I have solved this problem.

Start-up of the X11, to xserverrc I've added the "-d 24" extension.

By doing so, "3DxWare1.6.0" panel also, now appear, SpaceMouse will now react even CATIAV4.

Thank you for your support.

----------
knight2003
Attachments
3DxWare1.6.0.gif
3DxWare1.6.0.gif (100.98 KiB) Viewed 26815 times

Barbara
Moderator
Moderator
Posts: 534
Joined: Fri May 14, 2010 11:11 am

Re: CATIAV4 does not react

Post by Barbara » Wed Sep 10, 2014 7:03 pm

Hi knight2003 -

Excellent. Thank you for letting us know what worked.
-------------------
Barbara

Post Reply