SpaceMouse Pro - Zoom & Pan problems in AutoCAD 2020

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
Martin.Callahan|CACI
Posts: 2
Joined: Tue Jun 11, 2019 12:29 pm

SpaceMouse Pro - Zoom & Pan problems in AutoCAD 2020

Post by Martin.Callahan|CACI » Tue Jun 11, 2019 1:54 pm

I'm using a 12 month old SpaceMouse Pro running the latest (6/3/19) Windows 10 64bit driver. The SpaceMouse functions properly with AutoCAD 2019. Yesterday I installed AutoCAD 2020 and lost some SpaceMouse functionality. In 2020 model space, it functions properly (Fit, Zoom & Pan). In any 2020 paper space layout the Fit button works, but I don't have zoom or pan functionality. I relaunched AutoCAD 2019 and confirmed it still works properly in both model space AND paper space, just not in 2020.

Anyone know of a particular Settings Panel or such in AutoCAD I can check, or is this a bigger issue? Any ideas of how to fix this? Working on drawings without Pan or Zoom is no fun. If I can't find a solution, I'll have to revert to using AutoCAD 2019.

aalsalihi
Posts: 24
Joined: Mon Apr 15, 2019 9:14 am

Re: SpaceMouse Pro - Zoom & Pan problems in AutoCAD 2020

Post by aalsalihi » Fri Jun 14, 2019 6:44 am

Hi Martin,

It looks like the driver was already installed when you upgraded to AutoCad 2020. In order for the 3Dmouse to work with the new version then you need to uninstall the 3Dconnexion driver then install it back again with restarting your machine in between.

Will be waiting for some update on your end.

Regards,
Abdul. A

Martin.Callahan|CACI
Posts: 2
Joined: Tue Jun 11, 2019 12:29 pm

Re: SpaceMouse Pro - Zoom & Pan problems in AutoCAD 2020

Post by Martin.Callahan|CACI » Mon Jun 17, 2019 2:46 am

After posting my initial post I did further research and found the solution. I posted it to the AutoCAD Users Forum, and for those it might benefit, am posting it again here as well...

After upgrading to AutoCAD 2020 from 2019 I lost [Pan/Zoom] control using my 3Dconnexion Space Mouse Pro while in 2D Paper Space layout. The fix wasn't entirely obvious to me, so I thought I'd share what I learned in case anyone else hits this pothole...

First, ensure you're running the latest device driver. Download if necessary from the 3Dconnexion website: www.3dconnexion.com/service/drivers.html. While in [AutoCAD Paper Space], follow this path: [NAVBAR > flyout arrow under the 2D Mode icon > 3Dconnexion Settings...] The [3Dconnexion Settings] window opens. Ensure the [Keep Scene Upright] is UNCHECKED, and [Pan/Zoom] IS checked. ([Tilt/Spin/Roll] is only available in [Model Space]). Do NOT click [Restore Defaults]. Click [OK].

[Pan/Zoom] functionality should now be restored. Yay.

Post Reply