Left mouse button gone haywire. Support are not helping.

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
Kiarian
Posts: 4
Joined: Fri May 22, 2015 3:10 am

Left mouse button gone haywire. Support are not helping.

Post by Kiarian » Mon Jan 29, 2018 8:35 am

I submitted a technical report about my CAD Mouse. The left button is missing clicks, adding clicks, just going haywire. I have updated the firmware to v1.5. When I eventually received a reply from 3Dconnexion regarding my technical support, I was just asked one question: 'What is your full address?'.

?!? This isn't a banking/credit card transaction. Can you just help me with my problem?

UtaSH
Moderator
Moderator
Posts: 2941
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Left mouse button gone haywire. Support are not helping.

Post by UtaSH » Thu Feb 01, 2018 6:47 am

Hi Kiarian,

I apologize for the confusion. My colleague should have been a little bit more specific. We have some reports that the buttons of the early CadMouse models might trigger double clicks even the user did a single click. Or clicks with the mouse are not sent to the operating system. We have reviewed the production process and have replaced the parts that cause the problems. My colleague was asking for your shipping address to start the RMA process for you. (He should have explained that. ;) )

I will follow up with my colleagues and I recommend you send them your shipping address.

Kiarian
Posts: 4
Joined: Fri May 22, 2015 3:10 am

Re: Left mouse button gone haywire. Support are not helping.

Post by Kiarian » Thu Feb 01, 2018 9:04 am

Hi,

Many thanks for your help. Apologies from my end. Bad timing, as I had just been given the runaround by Adobe on their awful customer support online chat.

I didn't realise your colleague simply wanted my address for the RMA process. A rep from 3dconnexion just phoned, spoke to me and was very helpful. I will cut the cord on my faulty CAD Mouse and send you the image. Once again, thanks for taking the time to help.

NicoVB
Posts: 6
Joined: Tue Nov 28, 2017 4:06 pm

Re: Left mouse button gone haywire. Support are not helping.

Post by NicoVB » Fri Mar 16, 2018 7:28 pm

Had the same thing with my Wireless Cadmouse.
I contacted the support and they engaged the whole RMA process with was very professional and very quick.
(Although I live in Belgium, and that's basically just a stone throw away from the Munich headquarters :wink: )
Product replaced within a few days and I received a phone call with a follow up to ensure that everything when smooth.
Now, that's a great service 3dcx!
If only all firms had the same customer support...

The problem is gone and I felt a real difference in the actual mouse click, a bit hard to explain, but the click feels much sturdier.
More secure and profound in a certain way.
No more unwanted small micro lines in my CAD program when drawing, yay :D
I'm a happy customer.

Kiarian
Posts: 4
Joined: Fri May 22, 2015 3:10 am

Re: Left mouse button gone haywire. Support are not helping.

Post by Kiarian » Sat Mar 17, 2018 5:04 am

I'm now getting the same problem again. 3Dconnexion, can you please release an update for the firmware for the CAD Mouse. Currently it's 1.0. The left mouse button keeps double clicking again. This is not a fault of the mouse as it's new. But it's starting to drive me crazy as I use the mouse sometimes in Affinity Designer when drawing vector curves. Getting to the point where I'm half thinking of using my crusty old mouse which has been locked away for the past couple of years.

UtaSH
Moderator
Moderator
Posts: 2941
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Left mouse button gone haywire. Support are not helping.

Post by UtaSH » Mon Mar 19, 2018 3:25 am

NicoVB wrote:
Fri Mar 16, 2018 7:28 pm
Had the same thing with my Wireless Cadmouse.
I contacted the support and they engaged the whole RMA process with was very professional and very quick.
(Although I live in Belgium, and that's basically just a stone throw away from the Munich headquarters :wink: )
Product replaced within a few days and I received a phone call with a follow up to ensure that everything when smooth.
Now, that's a great service 3dcx!
If only all firms had the same customer support...

The problem is gone and I felt a real difference in the actual mouse click, a bit hard to explain, but the click feels much sturdier.
More secure and profound in a certain way.
No more unwanted small micro lines in my CAD program when drawing, yay :D
I'm a happy customer.
Hi NicoVB,

many thanks for your nice words. We are happy to hear that things work out for you.

UtaSH
Moderator
Moderator
Posts: 2941
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Left mouse button gone haywire. Support are not helping.

Post by UtaSH » Mon Mar 19, 2018 3:31 am

Kiarian wrote:
Sat Mar 17, 2018 5:04 am
I'm now getting the same problem again. 3Dconnexion, can you please release an update for the firmware for the CAD Mouse. Currently it's 1.0. The left mouse button keeps double clicking again. This is not a fault of the mouse as it's new. But it's starting to drive me crazy as I use the mouse sometimes in Affinity Designer when drawing vector curves. Getting to the point where I'm half thinking of using my crusty old mouse which has been locked away for the past couple of years.
Hello Kiarian,

I apologize that you encounter problems again. I can see in our database that you received a replacement device in February. This device should definitely be one of the new charge where there should not be any problems with the button clicks. I will contact you directly to troubleshoot the issue.

Kiarian
Posts: 4
Joined: Fri May 22, 2015 3:10 am

Re: Left mouse button gone haywire. Support are not helping.

Post by Kiarian » Mon Mar 19, 2018 10:19 am

Hi Uta,

Updated to driver version 1.05 for the CAD Mouse. Should all be fine now hopefully. Thanks for the help.

Regards

Kiarian

Post Reply