3dConnection Enterprise random drifting in every axis

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

ultek
Posts: 14
Joined: Fri Jul 14, 2017 1:06 am

3dConnection Enterprise random drifting in every axis

Post by ultek » Fri Oct 11, 2019 1:22 pm

My SpaceMouse Enterprise bought on may 2016 started drifting in every axis. Behavior is very strange and random. Sometimes it's drifting without touching, sometimes aggressively jumping around scene without smooth movement. Device become completely useless without any issues until today.

Tried on 2 different machines with 10.6.3 and 10.5.15 drivers.
Tried to calibrate (which completes without warnings).

Nothing helps.

Any advice how to fix this after the warranty period? :cry:

luping
Posts: 140
Joined: Wed Mar 20, 2019 5:54 pm

Re: 3dConnection Enterprise random drifting in every axis

Post by luping » Fri Oct 11, 2019 7:28 pm

Have you registered your device within 90 days after your purchase? If so, it's 3+1=4 years of warranty.

2019-10-12_10h26_03.png
2019-10-12_10h26_03.png (237.16 KiB) Viewed 932 times
3+1 warranty (three years as standard plus additional one year with product registration):
https://www.3dconnexion.com/products/sp ... prise.html

luping
Posts: 140
Joined: Wed Mar 20, 2019 5:54 pm

Re: 3dConnection Enterprise random drifting in every axis

Post by luping » Fri Oct 11, 2019 7:49 pm

Otherwise, time to invest on a new 3D mouse.

ultek
Posts: 14
Joined: Fri Jul 14, 2017 1:06 am

Re: 3dConnection Enterprise random drifting in every axis

Post by ultek » Sat Oct 12, 2019 11:01 am

Unfortunately I didn't registered my spaceMouse within 90 days :(

And it's extremely disappointing that device for 400 bucks is unusable after 3 and a half year even though I look after it so much. :(

I'm waiting for official response from 3Dconnection by mail.

ultek
Posts: 14
Joined: Fri Jul 14, 2017 1:06 am

Re: 3dConnection Enterprise random drifting in every axis

Post by ultek » Sat Oct 12, 2019 12:26 pm

What I don't understand is the inconsistent drift which can't be "calibrated".

This is clip without touching joystick. Sometimes i'm just pressing "Fit" but this should be obvious when that happens.

https://streamable.com/nfelu

luping
Posts: 140
Joined: Wed Mar 20, 2019 5:54 pm

Re: 3dConnection Enterprise random drifting in every axis

Post by luping » Sat Oct 12, 2019 11:51 pm

ultek wrote:
Sat Oct 12, 2019 12:26 pm
What I don't understand is the inconsistent drift which can't be "calibrated".

This is clip without touching joystick. Sometimes i'm just pressing "Fit" but this should be obvious when that happens.

https://streamable.com/nfelu
If you bought the SpaceMouse Enterprise back in year 2016, the intinal price is roughly $359 before tax in USA, 3Dconnexion has since raised the price.

By the way, you can still try to register your SpaceMouse Enterprise device on 3dconnexion.com and see if the automatically assigned warranty expire date can be extended to 3+1=4 years. Just give it a try.

ultek
Posts: 14
Joined: Fri Jul 14, 2017 1:06 am

Re: 3dConnection Enterprise random drifting in every axis

Post by ultek » Sun Oct 13, 2019 11:03 am

I didn't registered my Enterprise back in year 2016. I am unable to register now because small label attached to end of the cable felt off long ago. Serial number should be printed on the main body of the device, not on the cable!

I bought it in Germany on may 2016 in PLN currency

luping
Posts: 140
Joined: Wed Mar 20, 2019 5:54 pm

Re: 3dConnection Enterprise random drifting in every axis

Post by luping » Sun Oct 13, 2019 4:34 pm

ultek wrote:
Sun Oct 13, 2019 11:03 am
I didn't registered my Enterprise back in year 2016. I am unable to register now because small label attached to end of the cable felt off long ago. Serial number should be printed on the main body of the device, not on the cable!

I bought it in Germany on may 2016 in PLN currency
Look at the screenshots below. You can find the PID of your SME on the 3DxWare driver's Menu, hit the MENU button on your spacemouse enterprise device, and click 'more >', and click 'About', your device's PID should be displayed there. Now try to register your device, and try to find your device purchase receipt/invoice or screenshot of online purchase record to justify that you're the real end buyer of your device.
2019-10-14_07h23_02.png
2019-10-14_07h23_02.png (63.77 KiB) Viewed 888 times
2019-10-14_07h26_31.png
2019-10-14_07h26_31.png (48.84 KiB) Viewed 888 times

ultek
Posts: 14
Joined: Fri Jul 14, 2017 1:06 am

Re: 3dConnection Enterprise random drifting in every axis

Post by ultek » Mon Oct 14, 2019 1:54 am

Oh wow, that's awesome. :)

This should be on F.A.Q :)

I'll check everything at the evening when I get back home.

Thanks!

luping
Posts: 140
Joined: Wed Mar 20, 2019 5:54 pm

Re: 3dConnection Enterprise random drifting in every axis

Post by luping » Mon Oct 14, 2019 6:25 am

ultek wrote:
Mon Oct 14, 2019 1:54 am
Oh wow, that's awesome. :)

This should be on F.A.Q :)

I'll check everything at the evening when I get back home.

Thanks!
Tell me the final result.

ultek
Posts: 14
Joined: Fri Jul 14, 2017 1:06 am

Re: 3dConnection Enterprise random drifting in every axis

Post by ultek » Mon Oct 14, 2019 10:49 am

I've managed to register product successfully but it looks like it's 5 months after warranty. :(

I'm kind of kicking myself because of not registering device withing 90 days after purchase.

Looks like it's now good will from 3dconnexion but I don't expect anything...

Still waiting for official response from Polish Office.

luping
Posts: 140
Joined: Wed Mar 20, 2019 5:54 pm

Re: 3dConnection Enterprise random drifting in every axis

Post by luping » Tue Oct 15, 2019 12:35 am

ultek wrote:
Mon Oct 14, 2019 10:49 am
I've managed to register product successfully but it looks like it's 5 months after warranty. :(

I'm kind of kicking myself because of not registering device withing 90 days after purchase.

Looks like it's now good will from 3dconnexion but I don't expect anything...

Still waiting for official response from Polish Office.
It can't be a better chance for you to continue to invest on 3D mouse to reap the health benefit and productivity gain the 3D mouse offers.

ultek
Posts: 14
Joined: Fri Jul 14, 2017 1:06 am

Re: 3dConnection Enterprise random drifting in every axis

Post by ultek » Mon Oct 21, 2019 5:13 am

Heh, email support is terrible.

10 October (-11 days to this day): I sent first mail about device failure. Got the automatic response with case number [CASE:104576]
15 October (-6): I sent second mail with case number and additional info like serial number.
16 October (-5): Yay! Someone replied!.... "Did you try to calibrate? Did you try to unplug and plug it back in?".... :shock:
16 October (-5): I sent third mail. With additional explanations about hardware failure, controller behaviors, driver versions, system, etc.

No additional response. :(

luping
Posts: 140
Joined: Wed Mar 20, 2019 5:54 pm

Re: 3dConnection Enterprise random drifting in every axis

Post by luping » Thu Oct 24, 2019 7:50 pm

ultek wrote:
Mon Oct 21, 2019 5:13 am
Heh, email support is terrible.

10 October (-11 days to this day): I sent first mail about device failure. Got the automatic response with case number [CASE:104576]
15 October (-6): I sent second mail with case number and additional info like serial number.
16 October (-5): Yay! Someone replied!.... "Did you try to calibrate? Did you try to unplug and plug it back in?".... :shock:
16 October (-5): I sent third mail. With additional explanations about hardware failure, controller behaviors, driver versions, system, etc.

No additional response. :(
It's out of warranty, you need to invest on new 3Dconnexion device to receive warranty entitlement.

jwick
Moderator
Moderator
Posts: 2563
Joined: Wed Dec 20, 2006 2:25 pm
Location: USA
Contact:

Re: 3dConnection Enterprise random drifting in every axis

Post by jwick » Fri Oct 25, 2019 1:12 pm

We ship a program called "3DxTest" in the 3DxWinCore installation directory. Run that and tell me what you see. You should see values from the 6 axes. Is one of the more active than the others.

Then, as tech support suggested, you can calibrate it using the shortcut in the 3Dx systray icon. That should settle down the values printed in 3DxTest to all zeros when you release the cap.

Does the device rattle when you shake it or other obvious physical problem?

Post Reply