Space Mouse Pro wireless stopped working, wireless, works normal when USB connected

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

Post Reply
menos
Posts: 5
Joined: Wed Aug 03, 2016 9:37 pm

Space Mouse Pro wireless stopped working, wireless, works normal when USB connected

Post by menos » Sat Mar 23, 2019 12:19 am

I am using a Space Mouse Pro Wireless for some time but recently the mouse stopped working properly when in use without USB cable attached.

With the cable attached the mouse works properly with the proper functions and profile I have mapped when I bought it new.

Now when using it wireless, the mouse still seems to function but none of the functions are mapped properly (I made sure the exact same profile is loaded).

What could be the cause of the issue?
This is driving me mad.

UtaSH
Moderator
Moderator
Posts: 3285
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Space Mouse Pro wireless stopped working, wireless, works normal when USB connected

Post by UtaSH » Mon Mar 25, 2019 6:03 am

Hello menos,

what kind of functions are not working correctly? Do you mean functions from the button mapping?

Which application are you using?
Which driver version is installed?

menos
Posts: 5
Joined: Wed Aug 03, 2016 9:37 pm

Re: Space Mouse Pro wireless stopped working, wireless, works normal when USB connected

Post by menos » Wed Mar 27, 2019 7:05 am

Hello Uta,

The mapping of all functions for the app were not working any longer.

The SpaceMouse behaved as if a completely wrong profile was loaded.

This issue appeared without any changes to the Spacemouse or the installed driver from one day to the next :-(

The good news is I could solve the problem in the mean time.
I reinstalled the latest driver software and now every thing works as expected.

I am using Rhino 5 for Mac.
Attached is the specs of the installed driver.
Attachments
Screen Shot 2019-03-27 at 22.05.23 .jpg
Screen Shot 2019-03-27 at 22.05.23 .jpg (145.65 KiB) Viewed 11299 times

marcarch
Posts: 23
Joined: Mon Oct 22, 2018 9:41 am

Re: Space Mouse Pro wireless stopped working, wireless, works normal when USB connected

Post by marcarch » Fri Apr 05, 2019 3:10 am

UtaSH wrote:
Mon Mar 25, 2019 6:03 am
Hello menos,

what kind of functions are not working correctly? Do you mean functions from the button mapping?

Which application are you using?
Which driver version is installed?
We all are still waiting, and waiting, and waiting for a fix for Universal Reveiver with Mac OS Mojave. We are waiting since October more or less.
It sounds like 3Dconnexion doesn't care about bugs or doesn't care about Mac users, or, worst, 3dconnexion doesn't have developer working on this, you know, October is 6 months ago, half a year, while we are waiting and living with this annoying bug.

marcarch
Posts: 23
Joined: Mon Oct 22, 2018 9:41 am

Re: Space Mouse Pro wireless stopped working, wireless, works normal when USB connected

Post by marcarch » Fri Apr 05, 2019 3:13 am

menos wrote:
Sat Mar 23, 2019 12:19 am
I am using a Space Mouse Pro Wireless for some time but recently the mouse stopped working properly when in use without USB cable attached.

With the cable attached the mouse works properly with the proper functions and profile I have mapped when I bought it new.

Now when using it wireless, the mouse still seems to function but none of the functions are mapped properly (I made sure the exact same profile is loaded).

What could be the cause of the issue?
This is driving me mad.
It's an annoying and unfixed bug of the Universal Receiver with macOS Mojave.
The workaround is to unplug and plug again the Universal Receiver in the USB port after macOS is switched on. You'll need to to this every time you switch on your Mac.

menos
Posts: 5
Joined: Wed Aug 03, 2016 9:37 pm

Re: Space Mouse Pro wireless stopped working, wireless, works normal when USB connected

Post by menos » Tue Apr 23, 2019 6:42 am

I hav enow due to a hardware failure in my last MacBook Pro upgraded to a new MacBook Pro (current fully specced version of the 2015 MBP with all upgrades on the latest Mac OS built).

To my astonishment my Spacemouse is now COMPLETELY DISFUNCTIONAL - not even the driver internal demo works any longer.

I am unable to use the space mouse at all - not wireless, not directly connected.

Could someone from support please advice how to get this Spacemouse back into working condition?

None of the buttons are responsive.
Only twisting the space mouse moves the actual mouse cursor on the screen.
No other functions on the Spacemouse work.
Switching profiles, rebooting, disconnecting, reconnecting directly or wireless works.

The Spacemouse is completely dysfunctional.

UtaSH
Moderator
Moderator
Posts: 3285
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Space Mouse Pro wireless stopped working, wireless, works normal when USB connected

Post by UtaSH » Tue Apr 23, 2019 8:35 am

Hi menos,

pleaqse follow the instructions in our FAQ #1141. If this doesn't solve the problem I strongly recommend that you contact our Technical Support Team.

menos
Posts: 5
Joined: Wed Aug 03, 2016 9:37 pm

Re: Space Mouse Pro wireless stopped working, wireless, works normal when USB connected

Post by menos » Tue Apr 23, 2019 11:22 am

Hello Uta,

Maybe I am overlooking this vital bit of info in the FAQ.

I am stuck at this point:
"2. Installation
If the installation happens on a fresh macOS 10.14 installation, meaning no 3DxWareMac was previously installed and also the following settings haven't been made before, the user will be prompted the warning dialogs as shown."

How does one proceed if a driver HAS been installed before? This seems not to be mentioned in the FAQ unfortunately?

I have migrated from my old machine and all relevant drivers and apps have been installed coming from that machine.
I also have tried to reinstall the latest driver version again.

No such pop up menus have popped up :-(

The driver is installed but no hardware is recognized - the hardware is shown as connected in the system too but not recognized by the driver.
Screen Shot 2019-04-24 at 02.18.38 .jpg
Screen Shot 2019-04-24 at 02.18.38 .jpg (129.91 KiB) Viewed 8388 times
Screen Shot 2019-04-24 at 02.18.38 .jpg
Screen Shot 2019-04-24 at 02.18.38 .jpg (129.91 KiB) Viewed 8388 times
Attachments
Screen Shot 2019-04-24 at 02.21.24 .jpg
Screen Shot 2019-04-24 at 02.21.24 .jpg (254.5 KiB) Viewed 8388 times

menos
Posts: 5
Joined: Wed Aug 03, 2016 9:37 pm

Re: Space Mouse Pro wireless stopped working, wireless, works normal when USB connected

Post by menos » Wed Apr 24, 2019 12:43 am

I could fix the issue that the Spacemouse is not recognized at all by uninstalling the existing driver and reinstalling the driver.

The issue as described above though that the Wireless Spacemouse is not recognized after each reboot is NOT SOLVED.

Is there a fix for this issue? As It is currently It defeats the purpose of having a wireless input device when every time you boot the machine you have to fiddle with the USB wires and driver settings to wake up the device and have It recognized again :-(

marcarch
Posts: 23
Joined: Mon Oct 22, 2018 9:41 am

Re: Space Mouse Pro wireless stopped working, wireless, works normal when USB connected

Post by marcarch » Thu Apr 25, 2019 2:35 am

menos wrote:
Wed Apr 24, 2019 12:43 am
Is there a fix for this issue?
The only fix is don't buy 3Dconnexion anymore if you use Mac. Simple.

UtaSH
Moderator
Moderator
Posts: 3285
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Space Mouse Pro wireless stopped working, wireless, works normal when USB connected

Post by UtaSH » Thu Apr 25, 2019 7:57 am

Hi menos,

the issue you encounter is a problem with the USB ports. We have reports that this might happen on Windows machines as well with any of the devices. And we see this happen on our lab machine as well with other USB devices than our 3D mouse or CadMouse (or Universal Receiver). It is not 3Dconnexion specific and at this time we still have to investigate what the reason could be. (Our internal bug number for this issue is MAC-48).

Post Reply