El Capitan and 3Dxware 10.2.4 r2077 Issues

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

Post Reply
Aeromorphology
Posts: 5
Joined: Sun Nov 08, 2015 8:25 am

El Capitan and 3Dxware 10.2.4 r2077 Issues

Post by Aeromorphology » Sun Nov 08, 2015 9:32 am

I have upgraded my 2015 Macbook Pro 15" to El Capitan. I had previously installed v10.2.3 r2014 drivers so I updated to 10.2.4, r 2077. Prior to updating to El Capitan, functionality with my Spacemouse was not an issue.

After updating to El Capitan, the 3Dconnexion Properties utility quit functioning. None of the preferences that I sent for a specific application were being applied. I cannot Add Application to the configurations and the Remove Application option was greyed out. So, I upgraded to the 10.2.4 r2077 drivers to see if that would fix the issue.

Unfortunately, that did not work. The tutorial/demo's work great but Properties application in System Preferences does not work. I've tried changing my preferences for Sketchup to remap the in/out and up/down menus plus add some radial menu functionality.

I've uninstalled/reinstalled every version since v10.2.1 r1861 and nothing has changed. The interesting part is the custom configurations for radial menus and remappings remain between installations/uninstallations of the various versions.

Does anyone have any suggestions for can someone provide some help?

Thanks in advance.

UtaSH
Moderator
Moderator
Posts: 3276
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: El Capitan and 3Dxware 10.2.4 r2077 Issues

Post by UtaSH » Mon Nov 09, 2015 9:23 am

Hi Aeromorphology,

it may be - for some strange reasons - that the com.3dconnexion.mappings.plist file is messed up.
So please try remove it (you may want to have it backed up before!) from ~/Library/Preferences/. (Please note: Before removal, close the System Preferences and thus the 3Dconnexion prefs.) If you now reopen the 3dconnexion prefs, a new/clean com.3dconnexion.mappings.plist is created.

To completely uninstall the driver please follow this process:
  1. Run Uninstaller from Driver Package, with a Restart upon completion.
  2. Remove the following files from User/Preferences/

    Code: Select all

    com.3dconnexion.3DMouseHome.plist
    com.3dconnexion.driver.helper.plist
    com.3dconnexion.mappings.plist
    com.3dconnexion.VirtualNumPad.plist
  3. Remove the following items from User/Library/Saved Application States/

    Code: Select all

    com.3dconnexion.3DMouseHome.savedState
    com.3dconnexion.3DxDemo.savedState
    com.3dconnexion.3DxDemos.savedState
    com.3Dconnexion.3DxMacWare Updater (SE).savedState
    com.3Dconnexion.3DxMacWare Updater.savedState
    com.3Dconnexion.3DxTrainingWizard.savedState
    com.3dconnexion.driver.uninstaller.savedState
    com.3dconnexion.SpaceMousePairing.savedState
  4. Restart
  5. Run 3DxWareMac_v10-2-4_r2077.dmg driver installer.

Let me know if this helps.

Aeromorphology
Posts: 5
Joined: Sun Nov 08, 2015 8:25 am

Re: El Capitan and 3Dxware 10.2.4 r2077 Issues

Post by Aeromorphology » Tue Nov 10, 2015 6:23 am

Thank you for the response. I don't have any of the directories or files that you referenced after uninstalling driver 10.2.4.

Attached is a screenshot of my root directory.
Screen-Shot-2015-11-10-at-1.10.04-PM.png
Screen-Shot-2015-11-10-at-1.10.04-PM.png (235.55 KiB) Viewed 9213 times
Any other suggestions?

Thanks in advance.

Barbara
Moderator
Moderator
Posts: 534
Joined: Fri May 14, 2010 11:11 am

Re: El Capitan and 3Dxware 10.2.4 r2077 Issues

Post by Barbara » Wed Nov 11, 2015 6:27 pm

Hello Aeromorphology -

Your screenshot has the Library folder. Open that and you should find ~/Library/Preferences/.
[The [~] is for Home so that you are in your ~ /Library/Preferences - rather than in the system's /Library/Preferences folder]

In ~/Library/Preferences you should see the filenames starting with 'com.3dconnexion' and ending with '.plist' from Uta's post.
Then open the /Saved Application States folder for the listed files there beginning with 'com.3Dconnexion'.
-----------------
Barbara

Aeromorphology
Posts: 5
Joined: Sun Nov 08, 2015 8:25 am

Re: El Capitan and 3Dxware 10.2.4 r2077 Issues

Post by Aeromorphology » Thu Nov 12, 2015 4:25 am

Screen-Shot-2015-11-12-at-10.34.37-AM.jpg
Screen-Shot-2015-11-12-at-10.34.37-AM.jpg (248.29 KiB) Viewed 9186 times
Hello Barbara,

I've looked in the ~/Library/Preferences folder and there are no 3dconnexion files in that folder.
Screen-Shot-2015-11-12-at-10.54.35-AM.jpg
Screen-Shot-2015-11-12-at-10.54.35-AM.jpg (159.84 KiB) Viewed 9186 times
Also searched the entire file system and there are no .plist files associated with 3dconnexion.

Suggestions?

Thanks,
Duane

UtaSH
Moderator
Moderator
Posts: 3276
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: El Capitan and 3Dxware 10.2.4 r2077 Issues

Post by UtaSH » Fri Nov 13, 2015 1:39 am

Hello Duane,

can you describe more in details the problems you have with the 3Dconnexion pref pane? What happens if you want to add an application? Do you get an error?

Which model of the 3D mouse do you have? Do you have our CadMouse as well?

Thanks,

Aeromorphology
Posts: 5
Joined: Sun Nov 08, 2015 8:25 am

Re: El Capitan and 3Dxware 10.2.4 r2077 Issues

Post by Aeromorphology » Fri Nov 13, 2015 5:25 am

I have the 'plain' SpaceNavigator.

When i try to add an application, the pull down menu immediately switches back to "Any Application".

Here's my machine details if needed.
Screen Shot 2015-11-13 at 12.17.38 PM.png
Screen Shot 2015-11-13 at 12.17.38 PM.png (46.92 KiB) Viewed 9168 times
My MacPro at the home office does NOT have this issue. Both my Macbook and MacPro are running El Capitan.

Thanks again,
Duane

UtaSH
Moderator
Moderator
Posts: 3276
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: El Capitan and 3Dxware 10.2.4 r2077 Issues

Post by UtaSH » Mon Nov 16, 2015 3:21 am

Hi Duane,

this is a very special situation. I am contacting you via email.

Post Reply