Autocad Mechanical 2007 Flashing

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
tck
Posts: 7
Joined: Tue Dec 05, 2006 11:48 am

Autocad Mechanical 2007 Flashing

Post by tck » Tue Dec 05, 2006 11:55 am

I just got the SpaceNavigator, and it works great in Inventor 11.
It works in Acad 2007, but there is a lot of flashing while panning and zooming, and the drawing regenerates at end of move.
I can pan and zoom with the wheel mouse without regens, why not with the SpaceNavigator.
Is there a way to prevent this?

Thanks,

tck
Posts: 7
Joined: Tue Dec 05, 2006 11:48 am

Post by tck » Tue Dec 05, 2006 12:00 pm

I should add, that this in 2d model space.

agoenczi
User
User
Posts: 668
Joined: Mon Dec 04, 2006 6:17 am
Location: EU

Post by agoenczi » Wed Dec 13, 2006 12:50 am

Could you specify the configuration you use?

tck
Posts: 7
Joined: Tue Dec 05, 2006 11:48 am

Post by tck » Tue Dec 19, 2006 12:43 pm

Autocad 2007 Mechanical Desktop updated service packs
SpaceNavigator with updated driver
Windows XP Proffessional
IBM Intellistation Mpro
Pentium 4 3.6ghz
2 MB Ram
80 GB SATA 7200rpm Drive
Nvidia Quadro FX1400
Dual Acer AL1917 Monitors on Dual View

Is this what you are looking for?

Thanks,

tck
Posts: 7
Joined: Tue Dec 05, 2006 11:48 am

Post by tck » Tue Dec 19, 2006 2:03 pm

I stole this from Tim in another post.

"Looking at my screen, AutoCAD may not actually be doing a "regen". What I think is that whenever I touch the Space Navigator, AutoCAD is switching from the 2D wireframe visual style to the 3D wireframe style and back to 2D. I'm basing this on the tell-tale change in the UCS icon. This really makes the Space Navigator useless compared to the mouse, as there is a 2-3 second lag there that does not exist with the mouse pan/zoom. I was hoping for improved workflow here. "

This is exactly my problem, except my lag is only a 1/2 sec.
But the screen goes blank then the lines come back, this is very distracting.

falcon-engineers
Posts: 6
Joined: Wed Dec 20, 2006 12:17 am

Post by falcon-engineers » Wed Dec 20, 2006 12:19 am

Hi,

I have the exact same problem. I have a space pilot with the latest drivers and Autocad 2007.

The screen keeps flikkering black/grey, like switching form 2D to 3D mode.

mbonk
Moderator
Moderator
Posts: 160
Joined: Mon Dec 04, 2006 4:06 am

Post by mbonk » Wed Dec 20, 2006 2:01 am

Hi,
falcon-engineers wrote: The screen keeps flikkering black/grey, like switching form 2D to 3D mode.
Am I correct in assuming that it only flickers when the device is released? I.e when the movement is initiated the view turns grey, stays grey and turns black when the cap is released which is when the flickering occurs?

Markus

tck
Posts: 7
Joined: Tue Dec 05, 2006 11:48 am

Post by tck » Wed Dec 20, 2006 8:21 am

Yes, it turns to grey while moving the cap.
Then regens and turn back to black when the cap is released.

I have fixed the problem of turning to grey.
If you go into the options/ display / colors and change the drawing window colors from grey to black for the 3D parallel projection and
3d perspective. Then the display window will remain black while moving the cap.

But I can't seem the eliminate the flash of all line disapearing then reapearing whine the cap is released.

falcon-engineers
Posts: 6
Joined: Wed Dec 20, 2006 12:17 am

Post by falcon-engineers » Thu Dec 21, 2006 4:18 am

I think this is the solution:

=>tools=>options=>3D modeling

uncheck "display in 3D parallel....."
uncheck "display in 3D perspective....."

mbonk
Moderator
Moderator
Posts: 160
Joined: Mon Dec 04, 2006 4:06 am

Post by mbonk » Thu Dec 21, 2006 9:01 am

We created a new incident report(no. 4244) to track this issue. We have been able to greatly reduce the regens and believe that that will resolve the issue. We will verify the fix and we plan to include it in our next release (early January).
Thank you for your input.

mbonk
Moderator
Moderator
Posts: 160
Joined: Mon Dec 04, 2006 4:06 am

Post by mbonk » Fri Dec 22, 2006 12:48 am

falcon-engineers wrote:I think this is the solution:

=>tools=>options=>3D modeling

uncheck "display in 3D parallel....."
uncheck "display in 3D perspective....."
Has any tried this suggestion? Is there a performance increase if the UCS icon is not displayed?

wvbesien
Posts: 13
Joined: Mon Dec 18, 2006 6:20 pm
Location: Gent (Belgium)
Contact:

Post by wvbesien » Sat Dec 23, 2006 6:50 am

For me (Autodesk Architectural Desktop 2007) this is no solution. Autocad still switches from 2D wireframe view to 3D view when navigating: the background becomes grey and autocad regenerates before and after navigating.

tck
Posts: 7
Joined: Tue Dec 05, 2006 11:48 am

Post by tck » Tue Jan 23, 2007 11:27 am

I just down loaded the new driver and now the SpaceNavigator is not functional in MDT2007 (Autodesk Mechanical Desktop). It still works in Inventor and Google Earth.

3DxWare Version 6.0.16
Firmware 3.17

Does anyone know how to roll back to the previous driver?
Thanks,

ngomes
Moderator
Moderator
Posts: 1953
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Post by ngomes » Tue Jan 23, 2007 11:51 am

Hi tck,
tck wrote:Does anyone know how to roll back to the previous driver?
Make sure you terminate all applications. Go to the Add or Remove Programs panel and uninstall all 3Dconnexion software you see listed in there. Then install the version you need.
Our AutoCAD 2007 (and MDT) plug-in was updated for the upcoming 3.1 release (currently in beta testing). If you like, you can download and try it.
If that does not help, you should try our plug-in for earlier versions of AutoCAD which is also available form the same location, "archive" category.

Post Reply