Space Pilot with NX 4

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

syork
Posts: 5
Joined: Tue May 01, 2007 1:29 pm

Space Pilot with NX 4

Post by syork » Mon May 07, 2007 8:22 am

We upgraded from NX 3 to NX 4 this weekend and now some users are complaining the behavior of their Space Pilot is different. The user who is running 3Dxware 2.6 (5.0.24) is not having the problem. But users who are running version 3-1-8 are now saying the behavior of the Sketcher module in NX 4 is defaulting to 2D. This causes extra steps in their normal work.

agoenczi
User
User
Posts: 668
Joined: Mon Dec 04, 2006 6:17 am
Location: EU

Space Pilot with NX 4

Post by agoenczi » Tue May 08, 2007 6:25 am

Hi syork

Please try the new release (3DxSoftware v3.3.2) available to download from our driver download page.
agoenczi

matrix
Posts: 21
Joined: Tue May 08, 2007 6:01 am

Post by matrix » Thu May 10, 2007 6:07 am

Just so you know It's not anything to do with the devices. At my company we've run every spaceball or 3D device they've come out with in NX4 and they all work fine.

agoenczi
User
User
Posts: 668
Joined: Mon Dec 04, 2006 6:17 am
Location: EU

Space Pilot with NX 4

Post by agoenczi » Thu May 10, 2007 6:34 am

Hi matrix

It can be that a previous installation had some settings which could cause problems in a newer installation. In that case I would recommand to completely remove 3DxSoftware, remove 2 folders ( ...\<username>\Application Data\3Dconnexion and that under %appdata%\3Dconnexion) and 2 registry folders (HKCU\Software\3Dconnexion and HKLM\Software\3Dconnexion). Finally install the most new release of the 3DxSoftware (now is the v3.3.2 available for download).
agoenczi

NX User
Posts: 4
Joined: Tue May 22, 2007 9:32 am

Post by NX User » Tue May 22, 2007 10:11 am

I am having the exact same problem as syork for the Space Navigator.

I enter Sketcher and it goes to 2D mode. I can go into Device Settings and turn the rotation setting on, but when I leave Sketcher and come back in again, the rotation setting is turned off. Other users in the company do not have the same problem. I haven't collected the information from those users about the version of NX4 and the version of the 3DxWare software.

I uninstalled the software and deleted the registry settings and files per agoenczi's suggestions. After installing 3.3.2, it still operates the same way. I have also tried to guess at registry settings without any luck. I believe that the changes are internal to the software, but I don't know how everything interoperates.

Basically, my goal is to turn the rotation on when in Sketcher and permanently save the settings. If the Space Navigator worked the same way in Sketcher as it does in Modeling, I would be happy.

Any help would be appreciated.

agoenczi
User
User
Posts: 668
Joined: Mon Dec 04, 2006 6:17 am
Location: EU

NX4

Post by agoenczi » Wed May 23, 2007 5:28 am

Hi NX User,

Which release of 3DxSoftware are you using?

I tried a SpacePilot and a SpaceNavigator with NX4, using 3DxSoftware v3.3.2 but NX kept the settings I have changed (I switched on the rotation). Next time I started drafting - the rotation was active. I tried also to finish NX4 and launch again afterwards using the drafting - the rotation was turned-on...

Could you describe a scenario how to reproduce the issue you posted?
agoenczi

NX User
Posts: 4
Joined: Tue May 22, 2007 9:32 am

Post by NX User » Wed May 23, 2007 7:46 am

I am using version 3.2.2.

I uninstalled the 3Dconnexion software and did a search to delete every reference to "3DxNX" and "connexion" that remained in my directories and my registry. After reinstalling the software again, the reults were the same.

It sounds like it is dependent upon my setup for whatever reason. My procedure is to:
-enter Sketcher
-click the Space Navigator button to open the contol panel
-Click the Device Settings button and turn on "roll"
-close the control panel (everything works).
-go into modeling (still works)
-enter Sketcher (it doesn't work).

I have also tried using the 3DConnexion icon in the toolbar. In this case I have to turn on Tilt, Spin, and Roll. If I change settings like zoom, these changes will be saved when I leave and re-enter Sketcher. If I shut down the driver, I can see that the values for r, u, and v are being written correctly in my profile (either ON or OFF). However, this profile is being ignored when entering Sketcher.

NX User
Posts: 4
Joined: Tue May 22, 2007 9:32 am

Post by NX User » Wed May 23, 2007 7:51 am

One correction -- I am using 3.3.2 and not 3.2.2.

agoenczi
User
User
Posts: 668
Joined: Mon Dec 04, 2006 6:17 am
Location: EU

NX4

Post by agoenczi » Wed May 23, 2007 11:59 pm

Hi NX User

I would recommend to set-up the rotation in a different way. You have done it using directly the driver GUI. It is a possibility, but this setting will be every time overwritten by the plug-in default settings.

You have 2 ways:

1. Removing the plug-in - this solution allows you to keep the settings of the driver, but you will be not any more allowed to map NX4 functions in the button mapping editor of the driver.

2. Open a drawing, model and allow the rotation in the plug-in calling the icon from the 3DxNX toolbar (which I already described). This way you can use all the functions from the button mapping editor of the plug-in in NX4.

Please keep in mind, the settings of the plug-in will be given to the driver and the driver will save those setting overwriting any settings previously valid. That's why 3Dconnexion recommends the use of the plug-in for setting button mappings and other values used by the driver.
agoenczi

murphthemog
Posts: 8
Joined: Mon May 21, 2007 2:02 am

Post by murphthemog » Thu May 24, 2007 1:38 am

This is exactly what is happening to me. I have not found a solution yet either.

murphthemog
Posts: 8
Joined: Mon May 21, 2007 2:02 am

Post by murphthemog » Thu May 24, 2007 1:48 am

Hi,

In the drafting mode, the rotation is ticked on, although it obviously can't spin, but this still does not enable rotation in sketch mode.

In sketch mode, the 3DxNX tool bar is greyed out, and hence settings can only be changed in this mode by using the 3D connections control panel. This does not remember settings in sketch mode.

NX user - are you getting anywhere with this?

agoenczi
User
User
Posts: 668
Joined: Mon Dec 04, 2006 6:17 am
Location: EU

NX4

Post by agoenczi » Thu May 24, 2007 2:58 am

Hi murphthemog,

In a 2D view the rotation is not possible. The navigation with 3D mice in NX is an implementation of UGS, therefore please ask UGS to implement rotation in 2D views as well.
agoenczi

murphthemog
Posts: 8
Joined: Mon May 21, 2007 2:02 am

Post by murphthemog » Thu May 24, 2007 3:11 am

Hi,
This is what i would have expected. I only tried to see if it could be turned on (it was already) because I thought that it might influence the settings in the sketch mode (if the sketch mode took its settings from the draft mode, which it obviously doesn't). It is not a feature I require in drafting, I only require it in the sketch mode.

We have 2 seperate computers here, both running NX4, and both with the same (latest) version of the 3d connexion software. For both computers, rotation in the sketch mode is a no using the space navigator.

murphthemog
Posts: 8
Joined: Mon May 21, 2007 2:02 am

Post by murphthemog » Thu May 24, 2007 3:23 am

In the sketch mode, I can still rotate using middle mouse button, but this seems a waste of an expensive navigator which is currently decorating my desk.

Why is the 3dxnx tool bar greyed out in sketch mode, such that the settings can only be changed in the 3d connection control panel, which is overruled by the tool bar settings upon exiting the sketch mode?

agoenczi
User
User
Posts: 668
Joined: Mon Dec 04, 2006 6:17 am
Location: EU

NX4

Post by agoenczi » Thu May 24, 2007 5:57 am

Hi murphthemog

I could reproduce the issue you mentioned. If I turn the Sketchier on the rotations are switched out. The next time I switch on Sketcher again the rotation will be turned out again. Recorded as a bug under 4493 (for your reference).
agoenczi

Post Reply