Problem with Cinema4D: How to disable rolling?

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
Bonewire
Posts: 4
Joined: Tue Apr 03, 2007 3:55 am

Problem with Cinema4D: How to disable rolling?

Post by Bonewire » Tue Apr 03, 2007 4:11 am

Dear 3D Connexion Team

I´m not shure why I can´t find a single guy complaining about this Problem but I can´t use Cinema 4D with my space navigator.

When I try Maya there is a function "disable rolling". When it´s active I can use the space navigator perfectly because the horizon does not tilt.

In Cinema 4D there is no such option do disable rolling and that makes the space navigator useless for working with C4D. I tried every option in the setup of the Space Navigator and in the "Space Mouse" dialog of C4D but nothing prevents the horizon from tilting. Is it just my stupidity or does it not work?

Without that "disable rolling" function that is implemented in Maya it is not possible to work. The horizon tilts and after a few seconds everything is upside down and it´s hard to tell where you are.

Hope I could get the problem across since my english is not the best ;)

Thanks for helping.
Glenn

P.S. I use C4D R10.1 and I know that Maxon needs to implement that function but I thought it is already implemented in C4D and I´m just too stupid to find out how it works.

ghannigan
Posts: 35
Joined: Mon Dec 18, 2006 11:31 am

Post by ghannigan » Tue Apr 03, 2007 5:22 am

Try this in the C4D Space Mouse settings:

Navigate Tab
Translation - turn off Y
Rotation - select H (Heading), turn off P(Pitch) & B(Bank), Select Axis from drop down.

George

Bonewire
Posts: 4
Joined: Tue Apr 03, 2007 3:55 am

sorry, does not help

Post by Bonewire » Tue Apr 03, 2007 6:11 am

Thanks George but that does not help. Indeed this settings prevents the horizon from tilting but you also can not tilt/pitch around the object so you can look whats on top and bottom of the object. You have to have the ability to rotate around the object to view it from all sites (bottom and top also) without the horizon to tilt from left to right (if you know what I mean).

isn´t there any other way or do i have to wait until maxon implements it into Cinema 4D? Why isn´t anyone komplaining about this? Is it only me having this problem?

Thanks again George for helping

Glenn

agoenczi
User
User
Posts: 668
Joined: Mon Dec 04, 2006 6:17 am
Location: EU

Problem with Cinema4D: How to disable rolling?

Post by agoenczi » Tue Apr 03, 2007 7:17 am

Hi Bonewire

If you don't have the result you expected, you can start the "3dconnexion Control Panel" and you can disable the rolling (or any movement, you want to).

By the way: what version of 3DxSoftware do you have installed?
agoenczi

Bonewire
Posts: 4
Joined: Tue Apr 03, 2007 3:55 am

Post by Bonewire » Tue Apr 03, 2007 7:53 am

Hello Agoenczi

I already tried that. It makes no differennce. If I disable rolling in the 3Dconnexion control panel it still tilts from right to left which it don´t when I try it in Maya. In Maya the horizon stays horizontal.

I really tried every function (enable or disable) and it enables or disables a lot of movements but no matter what I disable the horizon still tilts to the left and right.

If you have the chance try Maya and Cinema4D one by one. Maya works fine and if you model a head for example in Cinema4D in a few seconds the head is upside down and you have no chance (no matter what you do with your Space Navigator) to get back to a view that shows the face in an accurate position/rotation.

do you have any other suggestions?

Thank you very much

Glenn

agoenczi
User
User
Posts: 668
Joined: Mon Dec 04, 2006 6:17 am
Location: EU

Post by agoenczi » Tue Apr 03, 2007 8:03 am

Hi Glen

Actually I tried Cinema 4D. In the add-in I disabled the rolling, thie setting having not the effect which I was waiting for. But with the "3dconnexion Control Panel" there was a difference: the rolling was much slower.

You could try to check the "Dominant" tag. After disabling the rolling and setting the "Dominant" tag I couldn't roll the model any more.
agoenczi

Bonewire
Posts: 4
Joined: Tue Apr 03, 2007 3:55 am

hmmm....

Post by Bonewire » Tue Apr 03, 2007 8:52 am

...after disabling rolling and activating the "dominant" tag the horizont did not tilt anymore but I also can not rotate around the model anymore. I just can zoom in and out ans strafe but no rotation around the model.

did i do anything wrong?

thanks
Glenn

ghannigan
Posts: 35
Joined: Mon Dec 18, 2006 11:31 am

Post by ghannigan » Tue Apr 03, 2007 10:04 am

Glenn,
I don't have Maya, so I can't see how it differs from C4D. Is the horizon you refer to the grid formed on the XZ plane? Wouldn't the action you describe change the orientation/position of the model relative to this plane rather than just your view of it? I understand the grid to be a visual reference of the "ground plane" and I find its movement with the model helpful in visualizing my view.
George

dmiko
Posts: 3
Joined: Thu Nov 14, 2019 2:39 am

Re: Problem with Cinema4D: How to disable rolling?

Post by dmiko » Thu Nov 14, 2019 2:53 am

In 2019 the problem unfortunately still persists, changing roll left/right in the 3Dconnexion app has no affect in cinema 4D. One remedy is however to use a camera for viewport navigation and apply protection tag to it. In the protection tag you can lock Bank rotation. This way you can lock horizon within camera.
Screenshot 2019-11-1.jpg
Screenshot 2019-11-1.jpg (70.53 KiB) Viewed 1596 times

aalsalihi
Posts: 46
Joined: Mon Apr 15, 2019 9:14 am

Re: Problem with Cinema4D: How to disable rolling?

Post by aalsalihi » Thu Nov 14, 2019 7:01 am

Hi Dmiko,

Thanks for your post. I was testing Cinema 4D version R21.026 and was able to disable the rolling functionality by simply going to the 3Dconnexion property panel and disabling the rolling functionality. It seems like you were trying to disable the function from Cinema 4D which is something they implemented on their end and might have some issues. You could test this on your end then let us know:
- Open 3Dconnexion Home
- Click on Settings
- Make sure the correct device is selected
- Make sure the application name is showing on the top (If the application name is not showing then please click inside Cinema 4D then click back again on our setting window)
- Click on Advanced Setting
- Uncheck the 5th icon for rolling while making sure the rest of them are checked
- Test the rolling in Cinema 4D

Note: Make sure Under View/3Dconnexion/3D Mouse Dialog that the navigation is enabled for translation and rotation for all then test it

Regards,
Abdul. A

Post Reply