3Dconnexion and Windows 7

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

permats
Posts: 8
Joined: Fri Oct 30, 2009 1:40 pm

Post by permats » Tue Nov 03, 2009 5:27 am

Forgot to mention that Ihave tried the SpaceNavigatorDriver (SpaceNavigatorHIDCapture.dll) and the mouse demo found on Sourceforge and it runs successfully making my SpaceNavigator act as a mouse device... and the leds lit up too... so I am excluding hardware error...

UtaSH
Moderator
Moderator
Posts: 2865
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Post by UtaSH » Tue Nov 03, 2009 5:39 am

Ok. Did you remove this SpaceNavigatorHIDCapture.dll? Maybe it interferes?

Please try as well if it works when you disable your firewall and the antivirus software?

amelia
Posts: 14
Joined: Tue May 05, 2009 2:27 am

Post by amelia » Tue Nov 03, 2009 12:23 pm

OS: Windows 7
DRIVER: 3.8.1 - 6.8.1 - 4.04
DEVICE: Space Navigator PE
APP: 3ds Max 2010

All goes OK but the ROLL function, when enabled, works like the SPIN function.

amelia

permats
Posts: 8
Joined: Fri Oct 30, 2009 1:40 pm

Post by permats » Tue Nov 03, 2009 1:00 pm

SpaceNavigatorHIDCapture.dll was downloaded and tried just recently so it can not be the problem. But removed it anyhow.

Tried with ZoneAlarm shutdown and Bitdifender disabled. No Change.

Any luck finding the meaning of the error code 0x1e7 ?

UtaSH
Moderator
Moderator
Posts: 2865
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Post by UtaSH » Wed Nov 04, 2009 3:01 am

permats wrote:Any luck finding the meaning of the error code 0x1e7 ?
The error points to a problem while loading a library. To find out the cause of this problem we need your help. I will send you another HIDDev.dll for testing. Please try it and let us know if this fixes the problem.

UtaSH
Moderator
Moderator
Posts: 2865
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Post by UtaSH » Wed Nov 04, 2009 3:12 am

amelia wrote:OS: Windows 7
DRIVER: 3.8.1 - 6.8.1 - 4.04
DEVICE: Space Navigator PE
APP: 3ds Max 2010

All goes OK but the ROLL function, when enabled, works like the SPIN function.

amelia
Hi amelia,

please check your settings in the 3Dconnexion control panel. The tab "Advanced Settings" shows each single axis. Here you can activate all and see if they might be reversed. Please let me know if checking the settings clarified the problem.

permats
Posts: 8
Joined: Fri Oct 30, 2009 1:40 pm

Post by permats » Wed Nov 04, 2009 4:07 am

You can e-mail the DLL to "********" (at and dot where customary) when ready.

Many thanks for your efforts!

[Edit (moderator): remove e-mail address from public view.]

UtaSH
Moderator
Moderator
Posts: 2865
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Post by UtaSH » Wed Nov 04, 2009 4:21 am

Thanks for the email address. This is not necessary; moderators can see your email address. I will send the DLL right now. 8)

permats
Posts: 8
Joined: Fri Oct 30, 2009 1:40 pm

Post by permats » Wed Nov 04, 2009 5:23 am

Hi again,

I tried the new DLL you mailed and it definitely seems you are on the right track!

It loaded but complained with 3 message boxes saying
Could not load transport DLL kbdtrans.dll
Could not load transport DLL mwmtrans.dll
Could not load transport DLL pxytrans.dll
respectively

Leds lit up (actually second time I started driver) but buttons work right away. For instance right button opened control panel.

However neither Solid Edge nor GoogleEarth responds to any SN activities.

Log indicates same error for these other three DLL:s as with HIDDev.dll
  • 13:14:8.146: 3DxWare driver startup: 11/4/2009 13:14:8
    13:14:8.147: 3DxWare Driver Version 6.8.1 : September 25, 2009
    13:14:8.149: -quiet -- disabled
    13:14:8.150: -shutdown -- disabled
    13:14:8.152: -protocol -- none given. All protocols enabled.
    13:14:8.154: -com -- Disabled, using spcware.ini file settings.
    13:14:8.155: -dev -- Disabled, using spcware.ini settings.
    13:14:8.157: -eps disabled sending each event.
    13:14:8.158: -log enabled
    13:14:8.160: -logLevel ffffffff
    13:14:8.161: -logFile C:\Users\Anders\AppData\Roaming\3Dconnexion\3DxWare\3DxWare.log
    13:14:8.163: -searchWarnDlg not enabled
    13:14:8.164: -showGUI not enabled
    13:14:8.166: -hideGUI not enabled
    13:14:8.167: UdCtl: Attempting to find (ID=1053) 'Swedish' locale in SV_SW
    13:14:8.169: UdCtl: Found resource DLL in C:\Program Files\3Dconnexion\3Dconnexion 3DxSoftware\3DxWare\en_us\3dxsrv.dll
    13:14:8.175: UdCtl: initialization successful.
    13:14:8.176: UdCtl: Attempting to open Any Device (-1) on USB.
    13:14:8.178: UdCtl: Attempting to load device DLL: C:\Program Files\3Dconnexion\3Dconnexion 3DxSoftware\3DxWare\UdDev\HIDDev.dll
    13:14:8.186: UdDev: Attempting to open 3Dx-supported HID device on USB
    13:14:8.198: UdDev: Beeping the device
    13:14:8.200: UdDev: SpaceNavigator opened
    13:14:8.202: UdCtl: Using device layer Any Supported 3Dconnexion USB Device supporting 0xffffffff
    13:14:8.203: UdCtl: Device 0 (Any Device(-1) on USB) -- enabled.
    13:14:8.205: Device Type: 6
    Num Buttons: 2
    Num DOF: 6
    CanBeep: 1
    Device Name: SpaceNavigator
    Port Name: USB
    Firmware: HID Firmware Version 3.18
    Version 3.18
    Orientation 0
    13:14:8.208: UdCtl: Attempting to load UI DLL: C:\Program Files\3Dconnexion\3Dconnexion 3DxSoftware\3DxWare\UdUi\udui.dll
    13:14:8.215: UdUi->InitDLL: UI DLL Initializing
    13:14:8.407: UdUi->SetOrientation: About to create windows.
    13:14:8.520: SetOrientation: B4 ResetAppNameBox call
    13:14:8.522: 13:14:8.527: SetOrientation: After ResetAppNameBox call
    13:14:9.761: UdUi->SetOrientation: Windows Created.
    13:14:9.766: UdCtl: UI (3DxWare UI v3.0) initialized.
    13:14:9.772: UdCtl: Attempting to load transport DLL C:\Program Files\3Dconnexion\3Dconnexion 3DxSoftware\3DxWare\UdTrans\kbdtrans.dll.
    13:14:11.856: UdCtl: Could not load transport DLL: kbdtrans.dll. Error=0x1e7
    13:14:11.862: UdCtl: Attempting to load transport DLL C:\Program Files\3Dconnexion\3Dconnexion 3DxSoftware\3DxWare\UdTrans\mwmtrans.dll.
    13:14:12.453: UdCtl: Could not load transport DLL: mwmtrans.dll. Error=0x1e7
    13:14:12.467: UdCtl: Attempting to load transport DLL C:\Program Files\3Dconnexion\3Dconnexion 3DxSoftware\3DxWare\UdTrans\pxytrans.dll.
    13:14:13.113: UdCtl: Could not load transport DLL: pxytrans.dll. Error=0x1e7
    13:14:13.125: UdCtl: Attempting to load transport DLL C:\Program Files\3Dconnexion\3Dconnexion 3DxSoftware\3DxWare\UdTrans\s80trans.dll.
    13:14:13.131: s80trans: SpaceWare 8.0 transport layer initialization
    13:14:13.133: s80trans: Function table load successful
    13:14:13.145: s80trans: Memory map loaded successfully
    13:14:13.147: UdCtl: Transport DLL: s80trans.dll -- enabled
    13:14:13.148: Name: SpaceWare 8.0
    13:14:13.150: Protocol ID: 30
    13:14:13.151: Event Mask: 0x76
    13:14:13.153: UdCtl: numWaitHdls: 2 numTransHdls: 1 numDevHdls: 1
    13:14:13.156: UdCtl: udfenNT.dll loaded sucessfully
I guess applying the same fix to theses three dll:s would do the trick...

Many thanks again!

UtaSH
Moderator
Moderator
Posts: 2865
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Post by UtaSH » Wed Nov 04, 2009 7:31 am

permats wrote:I guess applying the same fix to theses three dll:s would do the trick...
We can try that. I'll send you the files.

When was the last time you did a reboot?

permats
Posts: 8
Joined: Fri Oct 30, 2009 1:40 pm

Post by permats » Wed Nov 04, 2009 2:53 pm

Hi again,

Thanks for all the files. Works much better now! Only the pxytrans.dll was missing.

I rebooted yesterday when I was asked to disable anti virus and firewall. The ZoneAlarm you can exit while running but BitDefender 2009 Free is only possible to disable anti virus scanner. However the BitDefender services is still started in windows and it is not possible to Stop or Disable it in windows Services.

So here is what I did and what happened:

I replaced the dll:s you sent me. Started the driver and, not surprisingly, it complained only on this pxytrans.dll that I did not get (same error code). But SpaceNavigator works in all the respects I could think of trying. Both Solid Edge and Google Earth worked fine in all axes despite the complaint about pxytrans.dll.

As you mentioned in your mail that BitDefender might be the culprit I actually uninstalled it (and rebooted of course) and lo and behold there where no complaint about pxytrans.dll anymore. ZoneAlarm was still running.

I actually switched to BitDefender 2009 Free (latest version downloaded on the 22nd Oct. (always kept updated)) edition a few months ago because it was advertised as an "on demand" scanner only and not real-time scanning which I really despise because they always cause so much trouble and computer slowdown... how ironic... so if anybody here knows about any better anti virus that is NOT loaded/running when I don't want it to scan I'll be happy to hear about it....
...anyway wrong topic...

Here is the log of the successful load of the driver:
  • 22:9:52.022: 3DxWare driver startup: 11/4/2009 22:9:52
    22:9:52.022: 3DxWare Driver Version 6.8.1 : September 25, 2009
    22:9:52.022: -quiet -- disabled
    22:9:52.022: -shutdown -- disabled
    22:9:52.022: -protocol -- none given. All protocols enabled.
    22:9:52.022: -com -- Disabled, using spcware.ini file settings.
    22:9:52.022: -dev -- Disabled, using spcware.ini settings.
    22:9:52.022: -eps disabled sending each event.
    22:9:52.022: -log enabled
    22:9:52.022: -logLevel ffffffff
    22:9:52.022: -logFile C:\Users\Anders\AppData\Roaming\3Dconnexion\3DxWare\3DxWare.log
    22:9:52.022: -searchWarnDlg not enabled
    22:9:52.022: -showGUI not enabled
    22:9:52.022: -hideGUI not enabled
    22:9:52.022: UdCtl: Attempting to find (ID=1053) 'Swedish' locale in SV_SW
    22:9:52.022: UdCtl: Found resource DLL in C:\Program Files\3Dconnexion\3Dconnexion 3DxSoftware\3DxWare\en_us\3dxsrv.dll
    22:9:52.037: UdCtl: initialization successful.
    22:9:52.037: UdCtl: Attempting to open Any Device (-1) on USB.
    22:9:52.037: UdCtl: Attempting to load device DLL: C:\Program Files\3Dconnexion\3Dconnexion 3DxSoftware\3DxWare\UdDev\HIDDev.dll
    22:9:52.037: UdDev: Attempting to open 3Dx-supported HID device on USB
    22:9:52.053: UdDev: Beeping the device
    22:9:52.053: UdDev: SpaceNavigator opened
    22:9:52.053: UdCtl: Using device layer Any Supported 3Dconnexion USB Device supporting 0xffffffff
    22:9:52.053: UdCtl: Device 0 (Any Device(-1) on USB) -- enabled.
    22:9:52.053: Device Type: 6
    Num Buttons: 2
    Num DOF: 6
    CanBeep: 1
    Device Name: SpaceNavigator
    Port Name: USB
    Firmware: HID Firmware Version 3.18
    Version 3.18
    Orientation 0
    22:9:52.053: UdCtl: Attempting to load UI DLL: C:\Program Files\3Dconnexion\3Dconnexion 3DxSoftware\3DxWare\UdUi\udui.dll
    22:9:52.053: UdUi->InitDLL: UI DLL Initializing
    22:9:52.146: UdUi->SetOrientation: About to create windows.
    22:9:52.240: SetOrientation: B4 ResetAppNameBox call
    22:9:52.240: 22:9:52.240: SetOrientation: After ResetAppNameBox call
    22:9:53.082: UdUi->SetOrientation: Windows Created.
    22:9:53.082: UdCtl: UI (3DxWare UI v3.0) initialized.
    22:9:53.082: UdCtl: Attempting to load transport DLL C:\Program Files\3Dconnexion\3Dconnexion 3DxSoftware\3DxWare\UdTrans\kbdtrans.dll.
    22:9:53.082: kbdtrans: Keyboard transport layer initialization
    22:9:53.082: kbdtrans: Function table load successful
    22:9:53.098: kbdtrans: Sendkey.dll successfully loaded.
    22:9:53.098: UdCtl: Transport DLL: kbdtrans.dll -- enabled
    22:9:53.098: Name: Window Keypress 1.0
    22:9:53.098: Protocol ID: 50
    22:9:53.098: Event Mask: 0x100
    22:9:53.098: UdCtl: Attempting to load transport DLL C:\Program Files\3Dconnexion\3Dconnexion 3DxSoftware\3DxWare\UdTrans\mwmtrans.dll.
    22:9:53.114: mwmtranslog - Messages were registered
    22:9:53.114: mwmtranslog - Opened hidden window
    22:9:53.114: Mwmtrans: Username: <deleted>
    22:9:53.114: mwmtrans.dll:UdTransInit: NOT Terminal Services Environment
    22:9:53.114: mwmtrans: MagellanRPCServerInterface: endpoint is Magellan3DController
    22:9:53.114: UdCtl: Transport DLL: mwmtrans.dll -- enabled
    22:9:53.114: Name: Windows Messaging
    22:9:53.114: Protocol ID: 10
    22:9:53.114: Event Mask: 0x76
    22:9:53.129: UdCtl: Attempting to load transport DLL C:\Program Files\3Dconnexion\3Dconnexion 3DxSoftware\3DxWare\UdTrans\pxytrans.dll.
    22:9:53.129: Loading Proxy DLLs
    22:9:53.129: UdCtl: Transport DLL: pxytrans.dll -- enabled
    22:9:53.129: Name: Proxy
    22:9:53.129: Protocol ID: 5
    22:9:53.129: Event Mask: 0x76
    22:9:53.129: UdCtl: Attempting to load transport DLL C:\Program Files\3Dconnexion\3Dconnexion 3DxSoftware\3DxWare\UdTrans\s80trans.dll.
    22:9:53.129: s80trans: SpaceWare 8.0 transport layer initialization
    22:9:53.129: s80trans: Function table load successful
    22:9:53.145: s80trans: Memory map loaded successfully
    22:9:53.145: UdCtl: Transport DLL: s80trans.dll -- enabled
    22:9:53.145: Name: SpaceWare 8.0
    22:9:53.145: Protocol ID: 30
    22:9:53.145: Event Mask: 0x76
    22:9:53.145: UdCtl: numWaitHdls: 2 numTransHdls: 1 numDevHdls: 1
    22:9:53.145: UdCtl: udfenNT.dll loaded sucessfully
I think I'll skip BitDefender 2009 for now... but I guess you guys wants to be compatible with them too... now when I guess you have figured it out somehow.

Thanks for great assistance!
It was a pleasure cooperating so smoothly with you.
It is nice to talk to people who knows what they are talking about and that can respond with new code in a matter of hours.
I know USB programming can be tricky sometimes and I am amazed that it actually works in so many cases considering the complexity compared to RS232 for instance... ;-)

ngomes
Moderator
Moderator
Posts: 1896
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Post by ngomes » Thu Nov 05, 2009 3:00 am

Hi permats,
I think I'll skip BitDefender 2009 for now... but I guess you guys wants to be compatible with them too... now when I guess you have figured it out somehow.
We figured out what BitDefender was interfering with. It meant removing a feature from our software that assists our developers in maintaining it. That's not exactly making it compatible.

I suggest that you restore the installation of your 3Dconnexion software (and resintall will work best) now that you are no longer using BitDefender 2009. One additional suggestion -- if you choose to use this security solution again -- is to set the antivirus scanning to "tolerant". Do let us know if that is enough to re-enable the use of our software.

This issue with BitDefender software is not specific to Windows 7.
Nuno Gomes

carlos
Posts: 3
Joined: Tue Sep 22, 2009 12:57 am

thanks permats :)

Post by carlos » Sun Nov 08, 2009 4:04 pm

Someone on bitdefender forum the found solution, "I did find a work-around. I turned off the Real-Time scanning and manually launched the process. Then I turned Real-Time scanning back on."
Now im very happy :)

amelia
Posts: 14
Joined: Tue May 05, 2009 2:27 am

Post by amelia » Mon Nov 09, 2009 8:48 am

ROLL like SPIN

In the Advanced Settings:
1- All Axis (Pan Right, Pan Up,Zoom,Tilt,Spin,Roll) selected;
2- All Reversed selected
3- Roll Reversed
no no no roll move
yes no like Spin CCW, CW
yes yes like Spin CW, CCW

amelia

amelia
Posts: 14
Joined: Tue May 05, 2009 2:27 am

Post by amelia » Mon Nov 09, 2009 8:53 am

amelia wrote:ROLL like SPIN

In the Advanced Settings:
1- All Axis (Pan Right, Pan Up,Zoom,Tilt,Spin,Roll) selected;
2- All Reversed selected
3-
Roll-no Reversed-no......no roll move
Roll-yes Reversed-no......like Spin CCW, CW
Roll-yes Reversed-yes.....like Spin CW, CCW

amelia

Post Reply