Ubuntu 8.04 64 + Blender 2.48(a) + SVN

Questions and answers about 3Dconnexion devices on UNIX and Linux.

Moderator: Moderators

Post Reply
Posts: 5
Joined: Sun Dec 07, 2008 8:12 pm

Ubuntu 8.04 64 + Blender 2.48(a) + SVN

Post by gritchie » Sun Dec 07, 2008 8:55 pm

I'd like to get my SpacePilot working with a recent release of Blender. More desirably, build from SVN checkouts... But I'll take what I can get.

I can launch 2.48a from Blender.org and the SpacPilot buttons seem to work. Unfortunately there's no navigation with the puck. Console reports:

Code: Select all

Compiled with Python version 2.5.2.
Checking for installed Python... got it!
3Dconnexion blender plug-in: loaded.
Same occurs with recently build SVN version of Blender.

I've studied the other threads suggesting to use other plugins but none of those have worked. Any assistance would be appreciated.

Here's some info:

Code: Select all

$ /etc/3DxWare/daemon/3dxsrv -d usb -debug -E 
3DxWareUNIX = V1.3.0
Device      = SpacePilot
Firmware    = V3.12

$lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 8.04.1
Release:	8.04
Codename:	hardy

$ uname -rm
2.6.24-21-generic x86_64

Posts: 5
Joined: Sun Dec 07, 2008 8:12 pm

Post by gritchie » Sun Dec 07, 2008 9:25 pm

It works now. I'm not sure what I did. Perhaps I mixed up the many 3DxNdofBlender.plug files I had.

I downloaded 2.45 from http://www.ingrid-wessels.de/~arne.schm ... 64.tar.bz2 and it worked. so I copied the plug to /home/gary/.blender/plugins/3DxNdofBlender.plug (mind you, I have uninstalled Blender 2.45 using synaptic) and it also worked in 2.48a and recent svn build.


Code: Select all

Compiled with Python version 2.5.2.
Checking for installed Python... got it!
3Dconnexion blender plug-in: loaded.
In hind site the following may have had something to do with it: Previously reset defaults in 3DxWare and tested but at the time navigation did not work.[/code]

Posts: 5
Joined: Sun Dec 07, 2008 8:12 pm

Post by gritchie » Sun Dec 07, 2008 10:00 pm

Spoke too soon :cry: . Stopped working and dmesg | tail says this:
$ dmesg | tail
[ 927.585180] usb 4-1: usbfs: process 21059 (3dxsrv) did not claim interface 0 before use

Posts: 5
Joined: Sun Dec 07, 2008 8:12 pm

Post by gritchie » Mon Dec 08, 2008 8:35 am

Last night, after more frustration I finally got it to work again by saving a new config in 3DxWare.

It's nice but I'll need to go back and reconfigure some buttons. Blender really likes your left hand on the keyboard so I'll need to map the most oft used keys.

Posts: 3193
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany

Post by UtaSH » Wed Dec 10, 2008 6:34 am

Hi gritchie,

I am glad you could figure it out by your own. 8)

The message from dmesg is a bit misleading because the driver does claim the interface. Sometimes this message appears in the logfile, no idea why.

When you prepare the configuration for an application (i.e. Blender) you have to make sure that the window you had in focus before you press the "Save" button is the Blender window. Because to this window all data will then be sent. For example if you have a terminal in focus before you switch to the driver window and then press "Save" the driver assumes that the configuration is for the terminal and will then send all data to the terminal. Thus Blender doesn't get anything. :(

The name of the window for that the configuration is saved is mentioned in the title of the "Save" window. You can as well then see it in the configuration file ($HOME/.3dxcfg/<yourname>.scg)

Uta Ludwig

Posts: 5
Joined: Fri Feb 06, 2009 7:32 pm
Location: greece

blender 2.48a with spacenavd 0.3.2 under fedora 8 - 80x64

Post by GPD » Fri Feb 06, 2009 8:18 pm

My distribution is Fedora 8 X86_64 running
I have blender 2.48a from the default repository of fedora
The proprietary drivers gave issues to me, so I used spacenavd-0.3.2 and
spnavcfg-0.2.1 of John Tsiombikas.

(download, extract, configure, make, make install and voila, then /etc/init.d/spacenavd start and the light goes on, /etc/init.d/spacenavd stop and the light goes off (and by the way the daemon starts/stops).

From the drivers of 3dconnexions I extracted the xcube file and ran it and verified that indeed it runs as it should. A library gave me an issue with xcube (libXm.so.3 was not in F8 which has libXm.so.6) and got it from another older rpm.

Then I downloaded file blender-ndof-2008-03-15-linux-glibc27-py25-x86_64
and got its 3DxNdofBlender.plug into .blender/plugins/
started blender from terminal and saw:
Compiled with Python version 2.5.1.
Checking for installed Python... got it!
3Dconnexion blender plug-in: loaded.

Then in the main gui of blender I just played with the controller and everything was OK. (Btw, the fly mode was the most useful, because it makes the axes behave naturally, the other modes seemed inversed to me).


A few comments - customer feedback:

hardware 11 out 10 - incredible feeling and perception of quality.
software ...-273°C out 10 :p

the full monty:

Got spacenav along with a wacom bamboo and I'm extremely happy with the comfort of doing my art work and navigation in presentations and their potential as input devices for mechatronic systems' control.

However, although the wacom support is INCREDIBLE, the instructions and the various files from here and there regarding the Linux support of the space navigator are chaotic to say the least and mainly third party.

John Chiombikas with "spacenavd" has done a very good job and I would like to thank him in public along with sending a private "thank you" email.

May I propose that 3dconnexion goes for his solution? It has the benefit that works on all linux distros and works well and first time.

Apart from these software adventures, (ate me an evening sorting it) the product is GREAT. I mean, really really GREAT and its price tag (about 50€) is very reasonable, unlike its launch price.

HOWEVER, having to spend a whole evening to sort it out after so much information scattered all over the internet and will trial and error is not my cup of tea of a happy customer experience.

Also, not having Google Earth work with space navigator is a party stopper. I mean, it gives me the blues. I guess it makes all the penguins slightly pissed off, because apparently it shouldn't be more than a few hours fixing it for Linux and we all now how linux and FL/OSS savvy are the ppl in google.

Finally, what about games?
Ok, we know Linux doesn't have many, but for the few it does (e.g. ETQW) being able to use this controller would make it a dream add-on every gamer would go for (e.g. flying the anansi in ETQW with this should be a very serious gaming advantage.)

my 2¢!

Post Reply