3Dconnexion/Blender Beta Feedback

If you have questions or comments concerning any non-support related 3Dconnexion topic, please use this forum.

Moderator: Moderators

Post Reply
feejo
Posts: 10
Joined: Fri Jan 23, 2009 4:48 pm

Post by feejo » Mon Jan 26, 2009 5:29 am

I have some suggestion: (after 2 years) why you don't change your website and write: since 2.46 the step #1 here http://www.3dconnexion.com/solutions/blender.php I play many houres trying to get the right build, but I have 2.48a and builds are not necessary anymore. I think the first post should be modified in consequence saying with 2.46 only the driver is required.

- I have a problem ****really frustrating****, I set the fly mode with the control pannel. But when I switch to turntable, the controls are reversed. I mean they can't be configured individualy: these are the settings for turntable, these are the settings for flymode. They are just all the same.

-Sometime I have to recalibrate often too, I don't know why.

Godfrey
Posts: 2
Joined: Thu Feb 12, 2009 6:35 am

Post by Godfrey » Thu Feb 12, 2009 7:20 am

I hope this thread is still looked at; this page says to post Blender questions here to be answered promptly. :wink:

I just got the SpaceNavigator yesterday - so far it seems like a pretty nice little piece of hardware, but I'm having a little trouble getting the response I want when twisting the knob in turntable mode.

My first issue was that, when I turned the knob clockwise, the scene would rotate counterclockwise around the Z axis, and vice-versa. I solved that by setting AXIS_MAP_HRZ_USER to "XYZRuV" in the .scg file for Blender, based on the information I found in this thread. (That then reverses the axis for fly and transform modes, but honestly I don't expect to use them much, if at all.)

But if I tilt the knob forwards or back so that I'm looking along the Z axis, twisting the knob has much less effect - and has NO effect if my view is exactly parallel to the Z axis; I have to tilt the knob left or right to spin the view on the Z axis. I've tried changing both AXIS_MAP_HRZ_USER and AXIS_MAP_VRT_USER, but nothing seems to alter that behavior.
  1. Is there a way to modify the configuration so that twisting the knob spins the scene on the Z axis regardless of its other orientation?
  2. What exactly is the difference between AXIS_MAP_HRZ_USER and AXIS_MAP_VRT_USER? Is the .scg file format documented anywhere other than the bits and pieces I've managed to find here in the forums?
Finally, if I toggle through the NDOF modes by pressing one of the buttons, when I return to turntable mode, I can no longer zoom the view in or out (but I can get it working again easily enough by pressing shift-C, so at least there's a quick workaround).

I'm running Blender 2.46 under Debian, if that matters.

feejo
Posts: 10
Joined: Fri Jan 23, 2009 4:48 pm

Post by feejo » Wed Mar 04, 2009 12:37 pm

Godfrey wrote:I hope this thread is still looked at; this page says to post Blender questions here to be answered promptly. :wink:

I just got the SpaceNavigator yesterday - so far it seems like a pretty nice little piece of hardware, but I'm having a little trouble getting the response I want when twisting the knob in turntable mode.

My first issue was that, when I turned the knob clockwise, the scene would rotate counterclockwise around the Z axis, and vice-versa. I solved that by setting AXIS_MAP_HRZ_USER to "XYZRuV" in the .scg file for Blender, based on the information I found in this thread. (That then reverses the axis for fly and transform modes, but honestly I don't expect to use them much, if at all.)

But if I tilt the knob forwards or back so that I'm looking along the Z axis, twisting the knob has much less effect - and has NO effect if my view is exactly parallel to the Z axis; I have to tilt the knob left or right to spin the view on the Z axis. I've tried changing both AXIS_MAP_HRZ_USER and AXIS_MAP_VRT_USER, but nothing seems to alter that behavior.
  1. Is there a way to modify the configuration so that twisting the knob spins the scene on the Z axis regardless of its other orientation?
  2. What exactly is the difference between AXIS_MAP_HRZ_USER and AXIS_MAP_VRT_USER? Is the .scg file format documented anywhere other than the bits and pieces I've managed to find here in the forums?
Finally, if I toggle through the NDOF modes by pressing one of the buttons, when I return to turntable mode, I can no longer zoom the view in or out (but I can get it working again easily enough by pressing shift-C, so at least there's a quick workaround).

I'm running Blender 2.46 under Debian, if that matters.
Same problem with me, nice you adjust turn table, but when you get back to the fly mode it is reversed. There should be adjustment for both. I just told my braid that left is right and since that is ok. lol.

Sometime that thing (3D con) get so wild I regret buying it.

flyhigh
Posts: 4
Joined: Mon Mar 30, 2009 4:07 am

Post by flyhigh » Thu Apr 02, 2009 12:39 am

Well, I do not know about linux, but in windows diriver from 3dconnexion, there are adjustments for every dimensions and rotations.
- directions can be changed
- sensitivity can be adjusted

In the driver, thre can be different parameter sets for each program (using spacenavigator).
STu
==========

flyhigh
Posts: 4
Joined: Mon Mar 30, 2009 4:07 am

Post by flyhigh » Thu Apr 02, 2009 12:52 am

This message was posted in other thread, and redirected here:

I have an irritating problem with my spacenavigator in Blender's Edit Mode. The turtable and rotation around selection are selected in the Blender's settings. When I select something in 3d-view (vertex, edge or face) and rotate the view with spacenavigator the rotation center is not in the selection center (where it should be). Instead, it is rotating around an unpredictable point and 3d-view loses preselected objects in sigth.
Rotating the same view with mouse works fine (rotation canter is in the selection center).
Everything works in Object Mode.

I´m running:
Blender 2.48a, Build 2008-10-22 21:29:17, Rev-1783M
Vista32 ultimate, SP1, 4GB ram
SpaceNavigator PE
3Dconnexion drivers: v3-6-11 (think it's latest)
3DxNdofBlender.plug dated 2008-10-22
Display adapter is Gforce 8800 GT

Is it some kind of bug in Ndof driver/blugin?

Has anybody had the same kind of experiences, or is it only my problem?
Is there other SpaceNavigator users running Blender under Vista. Coud you post information whether there are sme king of problems or not.

Thanks!
STu
==========

Jessy
Posts: 9
Joined: Tue Apr 28, 2009 7:25 am

Post by Jessy » Tue Apr 28, 2009 7:27 am

Why is it that the SpaceNavigator works magnificently when the view is parallel with the grid, but not at all when pointed perpendicular to it?

Jessy
Posts: 9
Joined: Tue Apr 28, 2009 7:25 am

Post by Jessy » Sun May 03, 2009 11:56 am

Also, the overall speed is much too slow, even with all possible settings at max.

And this forum needs an "edit" button for posts.

Andrei
Moderator
Moderator
Posts: 22
Joined: Thu Mar 20, 2008 1:58 pm

Post by Andrei » Wed May 06, 2009 1:40 pm

Sir,

The plugin is still in beta.
http://www.3dconnexion.com/solutions/blender.php

We are working to resolve bugs our plugins.
There is no release date at this time.

Andrei

aglef
Posts: 3
Joined: Thu May 21, 2009 2:36 pm
Location: Germany

6DOF not 5DOF and all axis at the same time

Post by aglef » Mon Jun 29, 2009 1:19 am

I hope the Blender plugin is in development. I like the SpaceNavigator but I don't like it in Blender. The demo program xcube has six degree of freedom (6DOF) but Blender only 5 in turntable mode. Ok, the name tell us 1 axis is fixed. But I prefer 6DOF. So we need a new mode.

And please, why I can only use one axis at the same time? It's much more faster and more intuitive to control all axis at the same time (like xcube).

Maybe I can extend the plugin, but I need a little bit help to find the relevant source files. Is anybody out there who know where the code for blender options is, and if only the plugin source code is relevant for the modifications.

Or is every thing done in Blender 2.5?

Aglef
SuSE 11.0,Linux 2.6.25 32bit;Blender 2.49a,3DxWareUNIX=V1.4.3,Device=SpaceNavigator
Firmware=V4.04

fastforward
Posts: 1
Joined: Thu Oct 29, 2009 9:48 pm

hi

Post by fastforward » Thu Oct 29, 2009 9:58 pm

Hello.
I am so much exited after reading the post that site has opened 3DxCollage , 3DxWorldWind, 3DxMagellanProxy. It will be great help and also fun for me and my friends. Thanking to the moderator for this creation and hope to continue our excitements and fun.
When there is a will there is a way.

Basilisk
Posts: 2
Joined: Tue Dec 08, 2009 5:44 pm

Post by Basilisk » Tue Dec 08, 2009 5:52 pm

Greetings-

Just purchased several SpaceNavigators for the studio. We use Blender and Studio Max, but moving exclusively to Blender 2.5 in 2010.

There doesn't seem to be any function support for this controller in Blender 2.49b. We purchased these controllers because your front page predominately displays the Blender logo as a supported app.

One of the links listed above to a "beta plug-in" results in a dead link: Error! Reason: Segment "solutions" was not a keyword for a postVarSet as expected!

Can I please have a representative respond to this post, or contact me via my email address in my profile. Thank you!

Basilisk
Posts: 2
Joined: Tue Dec 08, 2009 5:44 pm

Post by Basilisk » Tue Dec 08, 2009 6:49 pm

Edit: Just noticed we get some weird kind-of-support under 32-bit Blender. It feels nothing like Studio Max- it is awkwardly slow and missing an axis of rotation. Are we doing something wrong?

unkelben
Posts: 2
Joined: Thu Dec 10, 2009 4:24 pm

Post by unkelben » Thu Dec 10, 2009 4:30 pm

So where can we find the space navigator plugins? As stated above, the link is broken.

UtaSH
Moderator
Moderator
Posts: 3265
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Plugins on our download page

Post by UtaSH » Fri Dec 11, 2009 8:17 am

Hi unkelben,

please go to our download page and select your device in the list with the products. The select your operating system and press "Search". The blender plugin will be listed.

unkelben
Posts: 2
Joined: Thu Dec 10, 2009 4:24 pm

Post by unkelben » Fri Dec 11, 2009 8:32 am

Thanks.

There seems to be only the source in the archive, though. I haven't found the ".plug" file mentioned in the readme file.

Jonathan

Post Reply