Toggle Part Movement on Selection

If you have questions or comments concerning any non-support related 3Dconnexion topic, please use this forum.

Moderator: Moderators

breedatrad
Posts: 10
Joined: Tue May 01, 2007 6:55 am
Location: NW PA

Toggle Part Movement on Selection

Post by breedatrad » Wed Jun 10, 2015 1:54 pm

I'm using a SpaceMouse Pro. I'd like to be able to turn the "Move part on selection" on and off from the programmable buttons.

Is this possible?

Brian

UtaSH
Moderator
Moderator
Posts: 3480
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Toggle Part Movement on Selection

Post by UtaSH » Wed Jun 10, 2015 2:15 pm

Hi breedatrad,

what is the version of the driver that you have installed?
Which application do you work with?

breedatrad
Posts: 10
Joined: Tue May 01, 2007 6:55 am
Location: NW PA

Re: Toggle Part Movement on Selection

Post by breedatrad » Thu Jun 11, 2015 7:31 am

3DxWare 10 version 10.2.3
3DxWinCore version 17.2.3.11261
SpaceMouse Pro (firmware v. 4.35)

Used with SolidWorks

The checkbox to "Move Selected Objects" appears under "Advanced Settings/Other Options", and works fine. My problem is that I used to be able to easily turn this option on and off from a toolbar in SolidWorks. This option is no-longer available as the toolbar's been removed. I'd like to be able to assign this option to a button on the device.

Brian

UtaSH
Moderator
Moderator
Posts: 3480
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Toggle Part Movement on Selection

Post by UtaSH » Thu Jun 11, 2015 3:32 pm

Hi Brian,

this command is currently not available. I will forward your request to our product management.

jasonbeaudoin
Posts: 2
Joined: Fri Jul 10, 2015 10:06 am

Re: Toggle Part Movement on Selection

Post by jasonbeaudoin » Fri Jul 10, 2015 10:32 am

I just updated the drivers for my Spacemouse Pro (3DxWare64_v10-2-6_r1934) and the part move toggle disappeared from the toolbar in Solidworks. It was there yesterday and now it's gone and really impacts my workflow. Not to mention the time I've spent today trying to figure out what happened. Very frustrating.

Please add my voice to the above poster asking for this functionality to return. In the meantime, I've uninstalled the latest version and gone back to an earlier driver that hasn't been handicapped.

Thanks.

UtaSH
Moderator
Moderator
Posts: 3480
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Toggle Part Movement on Selection

Post by UtaSH » Tue Jul 14, 2015 5:16 am

Hi all,

we are tracking this with our internal bug number #6926.

UtaSH
Moderator
Moderator
Posts: 3480
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Toggle Part Movement on Selection

Post by UtaSH » Wed Jul 22, 2015 1:56 am

breedatrad wrote: The checkbox to "Move Selected Objects" appears under "Advanced Settings/Other Options", and works fine. My problem is that I used to be able to easily turn this option on and off from a toolbar in SolidWorks. This option is no-longer available as the toolbar's been removed. I'd like to be able to assign this option to a button on the device.

Brian
Hi Brian,

there is a function called "Toggle Sub-Part Movement" in the button mapping. That should do what you want. Have you tried that? Please let me know if this works as you expect.

Thanks,
Uta
Attachments
Toggle_Sub-Part_Movement.jpg
Toggle_Sub-Part_Movement.jpg (87.05 KiB) Viewed 20075 times

jasonbeaudoin
Posts: 2
Joined: Fri Jul 10, 2015 10:06 am

Re: Toggle Part Movement on Selection

Post by jasonbeaudoin » Tue Jul 28, 2015 2:57 pm

Thanks for pointing us to the Toggle Sub-Part Movement in the button mapping, Uta. It is helpful.

Is there a way to put the toggle button back in the toolbar? It really helped to have a visual clue for when sub-part movement mode is active or not. Right now it's a bit of a guess whether I'm turning it on or off without moving a part.

Thanks.

UtaSH
Moderator
Moderator
Posts: 3480
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Toggle Part Movement on Selection

Post by UtaSH » Wed Jul 29, 2015 2:57 am

Hi jasonbeaudoin,

I will forward your request to our Product Management.

thormach
Posts: 4
Joined: Fri Feb 12, 2016 5:48 am

Re: Toggle Part Movement on Selection

Post by thormach » Fri Feb 12, 2016 6:08 am

I know this is an old thread. The one button I used in the old toolbar was to toggle sub part movement in my assemblies, and I used it a lot. I've programmed a key in the button mapping panel. No matter what I do, it won't turn off the sub part movement. The only way it works is to turn it off in the SpacePilot options which of course is a hassle. Now I just leave it on because I really like to have control of individual components in an assembly, but when I use the measure tool or create mates without the use of the dialog box, I have to use the mouse to rotate the assembly. I'm just wondering if this problem is still being investigated.

UtaSH
Moderator
Moderator
Posts: 3480
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Toggle Part Movement on Selection

Post by UtaSH » Tue Feb 16, 2016 3:34 am

Hello thormach,

what version of SolidWorks do you have and which is the version of the installed 3Dconnexion driver? I wonder why the function on a button would not work for you ...

thormach
Posts: 4
Joined: Fri Feb 12, 2016 5:48 am

Re: Toggle Part Movement on Selection

Post by thormach » Tue Feb 16, 2016 7:43 am

We're using Solidworks premium 2015 x64 sp 4.0 and the driver I last installed is 3DxWare64_v10-3-0_r2161.

UtaSH
Moderator
Moderator
Posts: 3480
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Toggle Part Movement on Selection

Post by UtaSH » Tue Feb 16, 2016 8:36 am

I have the same setup as you and the command is working for me.

Verify if the configuration for the 3D mouse in SOLIDWORKS is messed up:
  • Stop SOLIDWORKS and stop the driver (Start -> All Programs -> 3Dconnexion -> Driver -> Stop Driver).
  • Go to your Appdata folder to 3Dconnexion\3DxWare\Cfg and move the file SolidWorks.xml to another place.
  • Start the driver (Start -> All Programs -> 3Dconnexion -> Driver -> Start Driver).
  • Start SOLIDWORKS.
  • Map the command "Toggle Sub-Part Movement" to one of the buttons of the 3D mouse.
  • Verify if it works now.
Please let me know what you find out.

thormach
Posts: 4
Joined: Fri Feb 12, 2016 5:48 am

Re: Toggle Part Movement on Selection

Post by thormach » Tue Feb 16, 2016 11:30 am

I followed your instructions and the problem still persists. One thing that is probably related somehow is that the old toolbar is still visible in Solidworks. There are no icons in it, it doesn't show up in the drop down menu, and I can't get rid of it. I've tried reinstalling the spacepilot and that didn't help either. The empty toolbar doesn't bother me if it's an unrelated problem, but I'd be very happy if the toggle would work. Thanks.

UtaSH
Moderator
Moderator
Posts: 3480
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Toggle Part Movement on Selection

Post by UtaSH » Thu Feb 18, 2016 7:08 am

Hello thormach,

would you please send me your SolidWorks.xml file from your folder %APPDATA%\3Dconnexion\3DxWare\Cfg? I will send you an email address to which you can reply with the file.

Post Reply