SpaceMouse Pro moves erratically in Solidworks

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Plastic1
Posts: 3
Joined: Mon Feb 23, 2015 10:24 am

Re: SpaceMouse Pro moves erratically in Solidworks

Post by Plastic1 » Mon Feb 23, 2015 10:30 am

Same here, I don't know what should I do, anyone can help?

jaylynmjr
Posts: 6
Joined: Thu Dec 11, 2014 9:38 am

Re: SpaceMouse Pro moves erratically in Solidworks

Post by jaylynmjr » Mon Mar 23, 2015 10:59 am

I think this problem, and a few other ones in the forums under a different name, is related to the way 3Dx is defining its center of rotation. When we are zoomed up on a large assembly it doesn't seem to know where to place the center of rotation. It's picking a point far away from what we are focusing on; probably a point we would consider as closer to our nose. When we rotate the model all the geometry is way far out there so it shoots off to the side. Depending on your model, it may help to uncheck Auto in the Advanced section under Rotation Center. It's a crappy workaround but at least it's predictable.

jaylynmjr
Posts: 6
Joined: Thu Dec 11, 2014 9:38 am

Re: SpaceMouse Pro moves erratically in Solidworks

Post by jaylynmjr » Fri Apr 24, 2015 10:28 am

I'm also finding that unplugging and replugging the USB cord (or dongle) straightens things up for a while.
Sure would be nice if 3Dx would fix this.

zazz
Posts: 67
Joined: Sat Sep 27, 2014 10:50 pm

Re: SpaceMouse Pro moves erratically in Solidworks

Post by zazz » Sun Aug 30, 2015 5:12 pm

I don't think it a center problem. While tesing this, im spining and moving the model, i keeps my eyes focused on the center point only, The model always spinning around it... it is the XYZ movements that are losing its controll. In the trainer it never happens. The drivers, system and device works PERFECT there. I think it has something to do with Solidworks unwillingness to support Connextion. And as they are powerless to do anything about it, they are blaming us to be novice using the device....

Z

zazz
Posts: 67
Joined: Sat Sep 27, 2014 10:50 pm

Re: SpaceMouse Pro moves erratically in Solidworks

Post by zazz » Sun Aug 30, 2015 6:04 pm

With trainer i meant the Viewer with the turbine engine, bicycle and the house... No problems at all to smoothly navigate there.

dvanscho
Posts: 2
Joined: Wed Mar 24, 2010 4:31 pm
Location: Garden Grove, Calif

Re: SpaceMouse Pro moves erratically in Solidworks

Post by dvanscho » Thu Sep 24, 2015 1:19 pm

Thought I would throw my 2 cents in. I am also having the issue of Solidworks 2014 parts/assemblies moving erratic at times, actually often. Not using perspective, no dominant setting, latest drive, speeds lower than center setting. Picking a standard view setting (front, top, isometric, etc) fixes problem for a short time. Any other suggestions other than ones already suggested?

Don

zazz
Posts: 67
Joined: Sat Sep 27, 2014 10:50 pm

Re: SpaceMouse Pro moves erratically in Solidworks

Post by zazz » Sun Sep 27, 2015 7:44 am

The new driver didn't solved it either.

Any other Solidwork users who have encountered the same problems? Please write about it

dmwxr9
Posts: 1
Joined: Wed Jan 27, 2016 2:52 pm

Re: SpaceMouse Pro moves erratically in Solidworks

Post by dmwxr9 » Wed Jan 27, 2016 2:55 pm

jaylynmjr wrote:It took some digging through the boards here but I found what seems to have been my primary problem. 3Dx simply does not like Perspective being turned on in assemblies. I didn't even know I had left it on after tinkering with it the other day for some screen shots. I turned it off, reloaded 10.2 and my new wireless Pro. All is well with the world. Obviously it is still a driver problem, one that 3Dx acknowledges but doesn't advertize. At least it's not new to 10.2.

As to the primary topic here; play around with the auto center on zoom settings and using the zoom extents button in SW.

Turning off perspective completely fixed my issues! I never would have clicked that button.

Benm
Posts: 3
Joined: Mon Apr 04, 2016 9:43 am

Re: SpaceMouse Pro moves erratically in Solidworks

Post by Benm » Mon Apr 04, 2016 11:26 am

zazz wrote:I don't think it a center problem. While tesing this, im spining and moving the model, i keeps my eyes focused on the center point only, The model always spinning around it... it is the XYZ movements that are losing its controll. In the trainer it never happens. The drivers, system and device works PERFECT there.
I am having the same issue with SolidWorks 2014 x64 SP5 with SpaceNavigoator - agree it seems to be a XYZ sudden motion. This is very frustrating as I have six years of Inventor experience using SpaceNavigator as an essential part of my workflow and am now transitioning to SolidWorks - when trying a new command and get this erratic behavior, its very tough to make progress. Resorting to shelfing the 3D mouse for now because I can not get it to work reliably. If cannot get it to work right soon, may have end up returning the product. I have contacted tech support.

throuble
Posts: 1
Joined: Mon Apr 18, 2016 11:16 am

Re: SpaceMouse Pro moves erratically in Solidworks

Post by throuble » Mon Apr 18, 2016 11:20 am

Turning off perspective view fixed the problem for me about 90%. It still happens, but very rarely, and is far less of a nuisance. (Not sure why perspective was turned on to begin with...)

huanxiang900
Posts: 9
Joined: Wed Apr 06, 2016 4:47 am

Re: SpaceMouse Pro moves erratically in Solidworks

Post by huanxiang900 » Thu Apr 21, 2016 1:41 am

it can only move one direction when I use my spacepilot pro to navigate things in Solidworks? I mean, the motion is not simultaneously,for example,if I want to pan and rotate at the same time,SW just Response on the command first being triggered. BUT,when using the NX8.0,I can use it what ever I want, all the move is just smooth and simultaneously.
So can you tell me what is going wrong? I am using Solidworks 2015 on a laptop.Is that because my computer not that good? or SW just dont support simultaneously motion?

Benm
Posts: 3
Joined: Mon Apr 04, 2016 9:43 am

Re: SpaceMouse Pro moves erratically in Solidworks

Post by Benm » Wed May 04, 2016 1:44 pm

Benm wrote: I am having the same issue with SolidWorks 2014 x64 SP5 with SpaceNavigoator - agree it seems to be a XYZ sudden motion. This is very frustrating as I have six years of Inventor experience using SpaceNavigator as an essential part of my workflow and am now transitioning to SolidWorks - when trying a new command and get this erratic behavior, its very tough to make progress. Resorting to shelfing the 3D mouse for now because I can not get it to work reliably. If cannot get it to work right soon, may have end up returning the product. I have contacted tech support.
I've worked through the issue with customer support and we've reached a resolution. A new driver came out at the end of April which improved performance (the response curve for Solidworks which controls the speed response to movement of the controller cap of the 3D mouse was updated.) Additionally, it was suggested from support that I enable the "always show" setting for rotation setting:
Customer Support wrote:I suspect that what is happening is that the center of rotation is not on the screen when you seeing this issue. You can try setting the rotation center to always be on in the advanced settings for SolidWorks, which will visualize where the COR is. If the blue dot is no where on screen, then the center of rotation is off the screen, so if you rotate in the slightest it could cause very unintuitive movement, especially if zoomed in on a model.
This made lot of sense to me. I had previously had the rotation center on “Show on Motion” but once I turned it onto “always show” I saw what is happening: this particular assembly is longer in one direction than the others (230”x80”x80”) so when I would go from zoomed into one side of the assembly to zooming into the other side of the assembly without releasing the 3D mouse, the rotation center stays centered at the previously zoomed into area which cause the erratic behavior when trying to rotate on the new zoomed in area.

So my understanding now is that the auto rotation center recalculates only once the 3D mouse is not in use for a moment, whereas my intuition wants it to recalculate whenever I pan. I believe this understanding will allow me to at least be able to continue utilizing the mouse effectively.

Benm
Posts: 3
Joined: Mon Apr 04, 2016 9:43 am

Re: SpaceMouse Pro moves erratically in Solidworks

Post by Benm » Wed May 04, 2016 1:46 pm

huanxiang900 wrote:it can only move one direction when I use my spacepilot pro to navigate things in Solidworks? I mean, the motion is not simultaneously,for example,if I want to pan and rotate at the same time,SW just Response on the command first being triggered. BUT,when using the NX8.0,I can use it what ever I want, all the move is just smooth and simultaneously.
So can you tell me what is going wrong? I am using Solidworks 2015 on a laptop.Is that because my computer not that good? or SW just dont support simultaneously motion?
This sort of response will happen if "Dominant" is selected under Navigation in Advanced Settings. Uncheck that box if it is selected and motion should be smooth.

astuntas
Posts: 14
Joined: Sun Mar 27, 2016 1:20 am

Re: SpaceMouse Pro moves erratically in Solidworks

Post by astuntas » Tue May 17, 2016 1:58 pm

I purchased SPR a couple of months ago, and I had the exact same issue: sometimes, maybe once per hour, a little touch to the manipulator took the model away very far. My hardware:
i7 + k600 quadro + simple old logitech mouse (with standard windows drivers, no special logitech software) + space pilot pro + win 8.1 + SW2015 SP5

After purchasing SPR I downloaded drivers 10.3.6, and at first I thought I have a hardware issue with the joystick

Later I noticed, that this would usually happen when working with difficult curvature models.
The situations of erratic movement with parts/assemblies where most faces were perpendicular to each other were much more rare
Anyhow, in all cases the good old rotation with regular mouse worked perfectly, so I guess there was something with Spacepilot driver ...

I was keeping perspective view OFF all the time, and the blue center of rotation for manipulator ON all the time. I did use Dominant at the beginning, but after a few days, when I started to "feel" the joystick, it became disturbing - so I turned it off. I think with Dominant ON I had no problems of erratic movement, or very little.

I couldn't find any solution to this behavior

A few days ago I have noticed there is a new driver and downloaded it 10.4.3 - I think it is much better. I mostly spent my last days in workshop, and not by my computer, but as much as I used solidworks with this new driver - I think it is now fixed. I will have more modelling work upcoming weeks, so I will put more attention to it and I will post the results here. God I hope it is fixed, it gave so much frustration during modeling work ...

astuntas
Posts: 14
Joined: Sun Mar 27, 2016 1:20 am

Re: SpaceMouse Pro moves erratically in Solidworks

Post by astuntas » Fri Jun 03, 2016 11:52 am

So there has been a couple of weeks when I was working on 10.4.3 with fairly easy parts and not big assemblies (mainly up to 100 parts) in SW
I haven't had one erratic jump off the screen, so 10.4.3 soft seems to solve it
I think this is now fixed. I will write here if I notice anything strange in the future

Post Reply