SpaceMouse Pro moves erratically in Solidworks

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

zazz
Posts: 67
Joined: Sat Sep 27, 2014 10:50 pm

SpaceMouse Pro moves erratically in Solidworks

Post by zazz » Sun Nov 02, 2014 12:17 am

Hi,

I have had the Space Mouse Pro for about 2 month now and i love it. It took me MANY years before i convinced my self to buy one.

But.... Sometimes it just don't follows my orders. It seems to works perfect with your demo, but less perfect in Solidworks part mode. But in Assembly mode it moves the object erratically. Same happens on both my laptop and my stationary workstation.

The issues:
1, I'm spinning an object around the blue center spot at the same time as i move it up/down/left/right with great control, suddenly it just shots of to left (or right/up/down), and i compensate it by pushing the control to the right, but that just accelerate the left movement. :shock:

2, Locking the spinning, but still twisting the control for an imaginary spin, the up/down/left/right movements are MUCH MORE accurate...

Also, after installing the SpaceMouse Pro driver 10.1.4, my regular mouse, a Corsair M95 started to ignore mouse button presses sometimes. It happens very rarely but anyway, It is SURLY linked to the 3DxWare installation as the same happened on my workstation back at my office after it got 3DxWare installed.

Thanks,
Z

zazz
Posts: 67
Joined: Sat Sep 27, 2014 10:50 pm

Re: SpaceMouse Pro moves erratically in Solidworks

Post by zazz » Sun Nov 02, 2014 1:48 am

I couldn't find any EDIT on the above post...

I have to say that the erradical movement comes suddenly. If changing the speed settings and then change it back again will fix the problem for while.

zazz
Posts: 67
Joined: Sat Sep 27, 2014 10:50 pm

Re: SpaceMouse Pro moves erratically in Solidworks

Post by zazz » Wed Nov 05, 2014 3:17 am

I just found out that changing the setting will not always solve it... I have now a situation where it shuts off up or downwards when rotate back and forwards.

So I turned off the up/down and the left/right controller at the Speed tab.
The zooms slider is at absolute left end at 0.02.
The ball is in the center of the assembly.....
The perspective mode is off.

ANYWAY, it shouts up REALLY FAST when i slightly rotate it backwards and shots down when rotating forwards.

If i turns of the zoom too, then the strange movement stops. But keeping at 0.02 will move it up/down :shock: with great speed

zazz
Posts: 67
Joined: Sat Sep 27, 2014 10:50 pm

Re: SpaceMouse Pro moves erratically in Solidworks

Post by zazz » Wed Nov 05, 2014 3:19 am

WHY no EDIT function??????

"The BLEU CENTER ball is in the center of the assembly..... "

UtaSH
Moderator
Moderator
Posts: 3289
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SpaceMouse Pro moves erratically in Solidworks

Post by UtaSH » Thu Nov 06, 2014 7:31 am

Hello zazz,

could the issue be related to a special file that you work with?

And for the problem with the Corsair M95 - I assume you installed the driver for the Corsair?

zazz
Posts: 67
Joined: Sat Sep 27, 2014 10:50 pm

Re: SpaceMouse Pro moves erratically in Solidworks

Post by zazz » Tue Nov 11, 2014 4:43 am

No, it can happen in any file, both parts and assy files, small as large ones.

It just suddenly appears and the issue stays till i close and opens the file again or sometimes it resolves by it self.

zazz
Posts: 67
Joined: Sat Sep 27, 2014 10:50 pm

Re: SpaceMouse Pro moves erratically in Solidworks

Post by zazz » Tue Nov 11, 2014 4:46 am

As for the M95, yes, i use their driver version 1.00.00.14

UtaSH
Moderator
Moderator
Posts: 3289
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SpaceMouse Pro moves erratically in Solidworks

Post by UtaSH » Tue Nov 11, 2014 6:33 am

Hello zazz,

please try the same without the driver for your standard mouse. I assume that the two drivers interfere.

Do you have the same behavior in our Viewer (3D Mouse Home -> Viewer)?

zazz
Posts: 67
Joined: Sat Sep 27, 2014 10:50 pm

Re: SpaceMouse Pro moves erratically in Solidworks

Post by zazz » Wed Nov 12, 2014 11:29 am

UtaSH wrote:Hello zazz,

please try the same without the driver for our standard mouse. I assume that the two drivers interfere.

Do you have the same behavior in our Viewer (3D Mouse Home -> Viewer)?
In your viewer, SMPro works flawless. I can't get the same crazy movement there... It happens fairly often in Solidworks though.

If the drivers interfere, would you not me able to measure that somehow? I will test with a standard mouse and see if the missing clicks issue remains.

zazz
Posts: 67
Joined: Sat Sep 27, 2014 10:50 pm

Re: SpaceMouse Pro moves erratically in Solidworks

Post by zazz » Mon Nov 17, 2014 4:04 am

It seems to happen more frequent when you zoom into an assembly where most of its parts are outside the view area or set as hidden... The blue center ball is in the center of the view area but shouts away from the viewing area from time to time... Very irritation. Have the same behavior on both my of computers, but with the same SMPro though.... This is ruining my otherwise good impression of this product. But honestly I find myself going back to use the mouse more and more for rotations and zoom cause of this. Please fix this....

zazz
Posts: 67
Joined: Sat Sep 27, 2014 10:50 pm

Re: SpaceMouse Pro moves erratically in Solidworks

Post by zazz » Sun Nov 30, 2014 12:09 am

Am I the only one who have this problem with Solidworks (2015 SP0)??? :shock:

jaylynmjr
Posts: 6
Joined: Thu Dec 11, 2014 9:38 am

Re: SpaceMouse Pro moves erratically in Solidworks

Post by jaylynmjr » Thu Dec 11, 2014 9:56 am

No, you're not the only one. I've had this problem with my SpacePilotPro and the 3 series drivers on and off for years. It gradually got better but every once in a while would rear its ugly head. Usually hitting the Zoom extents from the heads up tool bar in SolidWorks would bring it around. Sometimes playing with the settings in 3D Controller would fix it.
I just got a SpaceMouse wireless and loaded the new driver 10.2 and the problem is back with a vengeance. It’s horrible. Not only will the model fly off into never never land but the zoom action is completely broken. If I pull the knob towards me to zoom in the model simply moves to the left. Zoom out = move right. It’s much worse with a huge assembly but on a simple single part the problem is pretty much nonexistent. On the big assemblies no amount of zoom extents helps. Nothing helps. I think it’s a problem with the auto centering. Whatever it is, it’s obvious this new 10 series driver is nowhere near ready for prime time. The same problems exists with my SpacePilot on this new driver.
Right now I’m in the process of uninstalling the new driver so I can go back to 3.18 with my Pilot. Hopefully they figure this out. I really like the new mouse with its bigger, easy to push buttons and the wireless so I can easily use it with my laptop in meetings. I’m afraid for now though this new mouse will have to set on the shelf and gather dust. :cry:

jaylynmjr
Posts: 6
Joined: Thu Dec 11, 2014 9:38 am

Re: SpaceMouse Pro moves erratically in Solidworks

Post by jaylynmjr » Thu Dec 11, 2014 10:47 am

Well now I'm stumped. Back to 3.18 and SMP but all the problems remain.

jaylynmjr
Posts: 6
Joined: Thu Dec 11, 2014 9:38 am

Re: SpaceMouse Pro moves erratically in Solidworks

Post by jaylynmjr » Fri Dec 12, 2014 5:45 am

It took some digging through the boards here but I found what seems to have been my primary problem. 3Dx simply does not like Perspective being turned on in assemblies. I didn't even know I had left it on after tinkering with it the other day for some screen shots. I turned it off, reloaded 10.2 and my new wireless Pro. All is well with the world. Obviously it is still a driver problem, one that 3Dx acknowledges but doesn't advertize. At least it's not new to 10.2.

As to the primary topic here; play around with the auto center on zoom settings and using the zoom extents button in SW.

ajohnson
Posts: 4
Joined: Mon Nov 17, 2014 7:55 am

Re: SpaceMouse Pro moves erratically in Solidworks

Post by ajohnson » Wed Feb 18, 2015 8:25 am

I just want to jump in here and say that I have the exact same issue. After a while working in an assembly I start to lose control. The model moves around the screen pretty wildly at the slightest touch. The only workaround I have found is to 'Zoom to Fit' when I start to have issues and it will behave normally for a while.

Post Reply