Driver acts as a phantom joystick/gamepad

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Phil999
Posts: 395
Joined: Tue Jun 30, 2009 5:20 am

Re: Driver acts as a phantom joystick/gamepad

Post by Phil999 » Thu Apr 30, 2015 12:40 pm

deinstalling and reinstalling was also my method.
Space Navigator x2, Space Pilot, Space Pilot Pro, SpaceMouse Enterprise

terranaut
Posts: 7
Joined: Tue Jan 29, 2008 10:25 am

Re: Driver acts as a phantom joystick/gamepad

Post by terranaut » Sun May 24, 2015 4:55 pm

Is there yet a solution for this issue which has existed for an unnvervingly long time now?
I never want my 3dx devices to act as KMJ emulators, and I feel at least offer people the option upon installing the driver, not just dump it on them when they may never use it, and for those who use joystick devices or other kmj devices its causing issues in programs, not just games.
another option is a option somewhere in the main 3dx driver to enable/disable the kmj emulator driver.

it's taken lost time when i have multiple 3dx units, and with every new driver update, i have to manually go in and delete the kmj emulator files and clean the registry of their references.

luke.johnson
Posts: 9
Joined: Tue Aug 18, 2015 5:31 pm

Re: Driver acts as a phantom joystick/gamepad

Post by luke.johnson » Sun Oct 16, 2016 5:53 pm

I'm having this same problem with latest 3dxWare drivers, Windows 10, SpacePilot Pro, and Revizto.

The KMJ emulator shows up as a game controller in Windows, and I believe this confuses Revizto so that I can't use the gamepad. So we really need a way to disable or uninstall the KMJ emulator, it is a real pain at the moment.

luke.johnson
Posts: 9
Joined: Tue Aug 18, 2015 5:31 pm

Re: Driver acts as a phantom joystick/gamepad

Post by luke.johnson » Sun Oct 16, 2016 6:06 pm

I found the solution in another forum thread and I have posted the steps with screenshots at http://whatrevitwants.blogspot.com.au/2 ... lator.html

Anctus
Posts: 1
Joined: Thu Nov 10, 2016 12:53 pm

Re: Driver acts as a phantom joystick/gamepad

Post by Anctus » Thu Nov 10, 2016 12:55 pm

luke.johnson wrote:I found the solution in another forum thread and I have posted the steps with screenshots at http://whatrevitwants.blogspot.com.au/2 ... lator.html
I have been trying to figure this out for half an eternity, thank you!

Pepetrucci
Posts: 1
Joined: Fri Nov 18, 2016 3:04 pm

Re: Driver acts as a phantom joystick/gamepad

Post by Pepetrucci » Fri Nov 18, 2016 3:12 pm

luke.johnson wrote:I found the solution in another forum thread and I have posted the steps with screenshots at http://whatrevitwants.blogspot.com.au/2 ... lator.html
Thank you so much! this problem was driving me crazy, i registered only to say thank you and to express how happy i feel right now XDDDD

Aside from this solution i think this is an issue that should no longer be ignored like this by 3dconnexion, an easier way to turn off emulator is more than needed!

Magnvs
Posts: 7
Joined: Mon Nov 14, 2016 4:09 am

Re: Driver acts as a phantom joystick/gamepad

Post by Magnvs » Mon Jul 17, 2017 6:13 pm

Updates on this?
The linked blog has been deleted, but I assume what OP did was disable the "Game Pad" from device manager.
I just figured out how to do it yesterday, I don't use any game pad at at all, but certain Unity based games would ignore every other input because of this, so it's probably a default behaviour in the engine. I don't know if disabling this portion will have any impact on the performance of my Enterprise controller, but if it has none, the component ought to be removed.

I will register a bug report, this has been driving me up the wall for the past year.

Eewec
Posts: 2
Joined: Thu Jan 11, 2018 11:45 am

Re: Driver acts as a phantom joystick/gamepad

Post by Eewec » Thu Jan 11, 2018 12:00 pm

Just in case anyone else is having this issue, I finally worked out how to fix it myself as the blog as gone AWOL and everyone else is vague in how to actually fix it.

1) Go to Device Manager
2) Along the top select 'View' -> 'Devices by connection'
3) near the top of the newly organised list should be '3Dconnexion KMJ Emulator'.
Expand that by clicking the '>' arrow to the left
4) select 'HID-compliant game controller'
5) right click that entry and select 'Disable device'
6) Enjoy no longer having the SpaceMouse Enterprise getting in the way of other things.... like gaming in Steam for example.

Post Reply