Space navigator issues

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
craggle
Posts: 5
Joined: Fri Apr 04, 2014 3:46 am

Space navigator issues

Post by craggle » Fri Apr 04, 2014 4:07 am

Hi all

I run a design office using wired Space navigators on Dell Optiplex 980's running Windows 7, 64 bit and they all work fantastically and have for the last 4 years.
We had reason to expand recently though and I purchased a new Dell Precision machine still running Windows 7, 64 bit and have busing myself today installing Catia and other software we use.
I am trying to install one of my Space navigators on it and can not get it to work. It's usually such a simple task as well, Install the software, plug in the navigator and away we go.

This new machine simply does not recognise it as being connected, tried it in other USB sockets, tried other USB devices in those sockets, they all work, Tried plugging it in with the machine on, off, restarting Etc. but nothing happens. Blue light do come on and I have tested the navigator on another PC and it's all fine. I've also tried 4 different driver versions and they meet with the same results.

I once got it working and managed to move a Catia model a few inches on the screen then it failed again, no Windows warning messages, nothing.

Any thoughts, I really can't face using Catia without the Space Navigator working! :(

Craig.

jwick
Moderator
Moderator
Posts: 2644
Joined: Wed Dec 20, 2006 2:25 pm
Location: USA
Contact:

Re: Space navigator issues

Post by jwick » Fri Apr 04, 2014 6:22 am

Call tech support.

UtaSH
Moderator
Moderator
Posts: 3387
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Space navigator issues

Post by UtaSH » Fri Apr 04, 2014 7:11 am

Let them know that a firmware update might help. Depending on which firmware version your device has.You would have to do the firmware update on a machine where the device is recognized without problems.

craggle
Posts: 5
Joined: Fri Apr 04, 2014 3:46 am

Re: Space navigator issues

Post by craggle » Mon Apr 07, 2014 4:45 am

Cheers all

I didn't know you could update firmware but will suggest I give that go when I call the UK support people, I've only just found their number. I can update the firmware on any of the other PC's in teh office as the Space navigators we have are recognised on all of those, just not on the new machine.

At the moment the user is happy without it as he's not yet using Catia but when he goes on the training course I'll have another go at getting it to work.

Craig.

craggle
Posts: 5
Joined: Fri Apr 04, 2014 3:46 am

Re: Space navigator issues

Post by craggle » Mon Jun 09, 2014 5:36 am

Can anyone help me with this as it's still an issue?

I have tried calling the UK support people and mentioned the firmware update but they seemed to be more interested in trying different drivers and saying it was a USB socket problem on the PC and I need to speak to my IT department.
I am the IT department, I have tried all USB sockets on the machine and tried all versions of the software for 64bit Windows.

Can I get the firmware update from anywhere just to try it?

Craig.

Fred
Moderator
Moderator
Posts: 997
Joined: Wed Dec 06, 2006 7:15 am
Location: Rochester, NY
Contact:

Re: Space navigator issues

Post by Fred » Mon Jun 09, 2014 5:51 am

Call The UK office again and direct them to this post.
Tell them Uta asked you contact them for the Firmware update.

craggle
Posts: 5
Joined: Fri Apr 04, 2014 3:46 am

Re: Space navigator issues

Post by craggle » Mon Jun 09, 2014 7:22 am

Thanks Fred

Managed to get the firmware updater program and it now works perfectly in all applications on the new computer. :D

Many thanks for your help

Craig.

Corey
Posts: 3
Joined: Fri Feb 27, 2015 1:46 am

Re: Space navigator issues

Post by Corey » Fri Feb 27, 2015 2:00 am

Hello,

I have the same issue with SpaceNavigators and all 4 new Dell Optiplex 9020s - they are not recognized ("Unknown Device" in Device Manager). The same unrecognised Navigator works on other workstations and laptops without any problems. I've tried reseting, different driver versions, Intel USB drives and everything points to firmware problem. I would be grateful if somebody could send me the update file.

Thanks in advance
Piotr

UtaSH
Moderator
Moderator
Posts: 3387
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Space navigator issues

Post by UtaSH » Fri Feb 27, 2015 7:59 am

Hi Corey,

please contact our First Level Support Team. They can help you with the firmware update tool. You can find the contact details here.

Corey
Posts: 3
Joined: Fri Feb 27, 2015 1:46 am

Re: Space navigator issues

Post by Corey » Sun Mar 01, 2015 1:30 pm

Hi,

I've contacted both regional and international support. I really hope they will respond fast, because 4 newly deployed Optiplex PCs do not work with new SpaceNavigators...

Thanks for response.

Post Reply