SpaceExplorer and Siemens NX 8.5: buttons not working

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

berdir
Posts: 3
Joined: Mon Apr 28, 2014 12:48 pm

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by berdir » Wed Apr 30, 2014 2:30 am

Because of the recent upgrade to NX9.0 I've advised all my colleagues to update the drivers of their 3D mouse.
We all run the latest versions of the driver.

The ugii_env.dat on the server does not contain an environmental variable for 3DConnexion.
However a local file on the system has the following reference:

UGII_3DCONNEXION_LIBRARY=${UGII_BASE_DIR}\UGALLICANCE\vendor\startup\3DxNX.dll

The library is not mentioned anywhere.
what string value should I put the environment variable UGII_3DCONNEXION_LIBRARY to?

berdir
Posts: 3
Joined: Mon Apr 28, 2014 12:48 pm

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by berdir » Wed Apr 30, 2014 2:50 am

I´ve tried to fill in the environmental variabe manually and remove all the references in the ugii_env.dat so that it could not be overwritten at startup.

putting in the string C:\Program Files\Siemens\NX 9.0\UGALLIANCE\vendor\startup\3DxNX.dll does not work.
I've tried
- current control set
- controlset001
- controlset002

I've even tried to tie it to my userprofile but that did not work.

I assume this is not the cause of the problem.

UtaSH
Moderator
Moderator
Posts: 3289
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by UtaSH » Fri May 02, 2014 12:03 am

Hi berdir,

you will find the most helpful information in your NX log file. You will probably find a line that explains which ugii_env.dat file is used. I recommend to copy the line into this file then.

You should as well find a line that tells you to which folder the variable UGII_BASE_DIR is set. Check if you find the files for the plugin 3DxNX there.

If you cannot solve the issue let me know. I will provide you with an email address to which you can then send the NX log file and I will try to find the needed information.

mark33k
Posts: 3
Joined: Wed Jul 30, 2014 2:58 pm

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by mark33k » Wed Jul 30, 2014 3:05 pm

Spacemouse Pro / NX9

I have the same issue described. Customize Buttons is not greyed out in NX but the 1 2 3 4 functions don't work (except for calculator) and the quick view hot-keys on the right of the mouse don't work.

A snippet from my log file is:

UGII_3DCONNEXION_LIBRARY C:\Program Files\Siemens\NX 9.0\UGALLIANCE\vendor\startup\3dxnx.dll
UGII_BASE_DIR C:\Program Files\Siemens\NX 9.0
NX_VERSION=9.0.2.5
=====================

Thanks,
Mark

mark33k
Posts: 3
Joined: Wed Jul 30, 2014 2:58 pm

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by mark33k » Thu Jul 31, 2014 4:19 am

Also, to be more specific. The view orientation button (flip/top/front/right and fit) do not function with the exception to lock rotation. Also the 1/2/3/4 hot-keys do not function. It seems to me that there is some interface issue between the Spacemouse driver and NX, any fix or reinitialize that can be recommend? I have done a clean uninstall/reboot/re-install of 3DxWare64_v10-1-2_r1798.exe with no help to the noted issues.

Mark

mark33k wrote:Spacemouse Pro / NX9

I have the same issue described. Customize Buttons is not greyed out in NX but the 1 2 3 4 functions don't work (except for calculator) and the quick view hot-keys on the right of the mouse don't work.

A snippet from my log file is:

UGII_3DCONNEXION_LIBRARY C:\Program Files\Siemens\NX 9.0\UGALLIANCE\vendor\startup\3dxnx.dll
UGII_BASE_DIR C:\Program Files\Siemens\NX 9.0
NX_VERSION=9.0.2.5
=====================

Thanks,
Mark

UtaSH
Moderator
Moderator
Posts: 3289
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by UtaSH » Fri Aug 01, 2014 8:26 am

I will contact you directly.

UtaSH
Moderator
Moderator
Posts: 3289
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by UtaSH » Tue Aug 12, 2014 5:25 am

Update:

NX was started as administrator and the driver not. The user had admin rights, but the start of both (application and driver) has to be made with 'exactly' the same privileges.

wid321
Posts: 1
Joined: Tue Feb 10, 2015 12:12 am

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by wid321 » Tue Feb 10, 2015 12:19 am

Hi together
We are facing a similar Problem in NX9.0.3.4 on Windows 7. The variable UGII_3DCONNEXION_LIBRARY=${UGII_BASE_DIR}\UGALLIANCE\vendor\startup\3dxnx.dll is correctly set in our customized ugii_env.dat. The problem we are facing is that the programed buttons get lost every other day or the day after.
Has there been any solution to this problem?
Thanks for a replay
--------------------------
Daniel

UtaSH
Moderator
Moderator
Posts: 3289
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by UtaSH » Wed Feb 11, 2015 9:14 am

Hi Daniel,

are you using our latest driver - 3Dxware 10.2.2? The settings are stored in the user's %APPDATA%\3Dconnexion folder. Check if this gets removed for any reason. If you remove it you will lose all settings you have made.

Agville
Posts: 1
Joined: Sat Apr 11, 2015 2:39 pm

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by Agville » Sat Apr 11, 2015 2:45 pm

I am having this same problem. NX9 is working fine. In 7.5 the button mapping is still greyed out. This is what I set in the ugii_env.dat
Attachments
ugii_env.dat.JPG
ugii_env.dat.JPG (76.79 KiB) Viewed 7388 times

UtaSH
Moderator
Moderator
Posts: 3289
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by UtaSH » Tue Apr 14, 2015 5:34 am

Hello Agville,

which driver do you have installed? Our latest driver is 3DxWare 10.2.3. You can download it here.

We need the log files from an NX 9 session (addin loaded) and one from a NX 7.5 session where you have problems with the addin. I will send you a PM with an email address to which you can send the files.

mrtelip
Posts: 1
Joined: Mon Sep 09, 2019 7:50 am

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by mrtelip » Mon Sep 09, 2019 7:57 am

Hi,
I am using Siemens NX11 and Teamcenter. The button assignments work fine in native NX, however they do not function in Teamcenter. I can hold down the buttons and see that they are assigned, but they don't function. I use the 3Dconnexion plugin to NX and Teamcenter to bring up the interface to make the assignments. I am using the SpaceMouse Pro Wireless and have the 3DxWare 10.6.0 installed. Automatic updates are on and software is up to date.

UtaSH
Moderator
Moderator
Posts: 3289
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SpaceExplorer and Siemens NX 8.5: buttons not working

Post by UtaSH » Wed Sep 11, 2019 3:00 am

Hi mrtelip,

I saw that you contacted our Technical Support Team. The issue seem to be solved now. (Reason was that Teamcenter and the driver were running with different privileges. See here.)

Post Reply