SpacePilot Pro & 3Ds Max 2014 - Glitchy Viewport Behaviour

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
GunGriffin
Posts: 8
Joined: Tue Dec 03, 2013 9:30 pm

SpacePilot Pro & 3Ds Max 2014 - Glitchy Viewport Behaviour

Post by GunGriffin » Tue Dec 03, 2013 9:50 pm

Hello everyone,

I usually spend a long amount of time trying to find technical solutions by searching high and low for people who have had similar problems. However this particular issue seems to be eluding me at every turn and I haven't been able to find any help :(. So I am breaking my boundaries and am going to try posting my problem discretely to see if anyone may know anything about this issue.

I've had the SpacePilot Pro for about 3 months now and its a very useful piece of equipment. Except for one incredibly large caveat that's been gaining momentum causing me to finally post on this forum.

To briefly explain: When trying to use the SpacePilot Pro's nub sensor in 3Ds Max while at the same time moving the cursor anywhere around the viewport, it causes a very strange stuttering that is a little hard to explain.

Essentially what happens is the viewport say rotates with the 3D mouse but attempting to move the mouse at the same time causes the viewport to ... switch or flicker all over the place. Makes me very dizzy. Navigating the view port without touching the mouse at all is fine. However any movement whatsoever of the mouse while navigating with the Spacepilot causes the viewport to go bonkers.

I have actually narrowed it down a little in that the viewport does not glitch out when the tool being used is "Select Object". If the mouse is equipped with say: "Rotate", "Move" or "Scale" the above behavior is experienced.
Also, the problem is not experienced at all on a fresh new scene with very few objects on the screen. Even on the busier scenes the problem only becomes apparent after about 10 minutes while everything worked perfectly prior.

At first I almost thought it was because of a lack of system memory, but that doesn't appear to be the case. It is only occurring in very specific instances and the task manager does not reflect any kind of memory overload.
The only thing I could think of is a potential conflict with some kind of view port setting, but since the problem is never apparent early in a scene I don't think that is the case.

If it helps at all I will make a small video clip to help explain what the problems looks like.

My system specification are as follows (If this helps):

3D Connexion SpacePilot Pro
Autodesk 3Ds Max 2014 Version 16.0 SP3

Intel i7 3770K CPU
Asus P8-Z77-Pro Motherboard.
Asus GTX 780 Direct CU II
16 GB 1600Mhz Patriot Extreme Masters RAM
OCZ 750W Modular Power Supply
OCZ Vertex 4 256 GB Solid State Drive
Corsair H80 CPU Liquid Cooler
Corsair Graphite Series 600T Case
Windows 7 Home Premium

Thank you for reading my question and I would appreciate any help on this issue :(. Let me know also if there is any other information I can provide to make solving this issue easier. I really do love the SpacePilot Pro but this little issue really starting to get on my nerves :(.

GunGriffin
Posts: 8
Joined: Tue Dec 03, 2013 9:30 pm

Re: SpacePilot Pro & 3Ds Max 2014 - Glitchy Viewport Behavio

Post by GunGriffin » Tue Dec 03, 2013 10:03 pm

Hello again,

I just made a short video on Youtube to sort of show you the problem.

http://youtu.be/5x3BxqNxnqw

When the glitch occurs it doesn't appear to glitch out as much in the recording, but in practice it actually glitches out much more than that. As the video shows, I click on Select Object and everything's peachy. Move and Rotate cause the viewport to shutter in weird ways when navigating around the scene.

GunGriffin
Posts: 8
Joined: Tue Dec 03, 2013 9:30 pm

Re: SpacePilot Pro & 3Ds Max 2014 - Glitchy Viewport Behavio

Post by GunGriffin » Sat Feb 08, 2014 6:27 am

Still nothing on this one? :( Still having this problem till now.

I've sort found a bit of a solution. Switching the Viewport driver to Legacy OpenGL seems to get rid of the problem for a little while. I think it has to do really heavily with with the Nitrous driver perhaps.

Mr-Brett
Posts: 1
Joined: Tue May 27, 2014 1:06 am

Re: SpacePilot Pro & 3Ds Max 2014 - Glitchy Viewport Behavio

Post by Mr-Brett » Tue May 27, 2014 1:14 am

Hi GunGriffin,

I've also been having this problem with my Space Navigator and 3D max.
I've had the Navigator since 2008 and it's served me well, this issue has only appeared recently (ish). My experiences are exactly the same, it's only when a gizmo is selected and you manipulate multiple input devices at once, also only in heavier scenes.

I started noticing this almost a year ago and every so often I look for a solution but your post is the first time I've seen anyone else mention it.
Although there is a thread on these forums about flickering with the Nitrous driver.

Anyway I have no solution, just wanted to let you know that you're not suffering alone and maybe if more people chime in then 3D Connexion may be encouraged to have a look.

droric
Posts: 6
Joined: Sat Feb 15, 2014 11:35 am

Re: SpacePilot Pro & 3Ds Max 2014 - Glitchy Viewport Behavio

Post by droric » Sun Jul 13, 2014 9:38 am

The 3D Mouse is borderline unusable since more and more bugs keep being introduced but all 3DConnexion seems focused on is the '3dxware 10' garbage. I don't remember the experience being so terrible with the old 'Legacy' drivers. It is extremely frustrating to say the least that none of the 3dx staff members seem to comment on these huge issues. At least provide a workaround for users like providing the legacy driver or whatever must be done to get this to work properly.

droric
Posts: 6
Joined: Sat Feb 15, 2014 11:35 am

Re: SpacePilot Pro & 3Ds Max 2014 - Glitchy Viewport Behavio

Post by droric » Tue Jul 15, 2014 7:22 am

I found a 'solution' to my issue. I have to unplug my Spacepilot Pro when using 3ds max to prevent glitches which seem to be originating from manipulating the camera. As I understand it there is no native navigation support so a temporary camera object is used to navigate but this causes its own issues.

3dan
Posts: 29
Joined: Tue Mar 17, 2009 4:44 am

Re: SpacePilot Pro & 3Ds Max 2014 - Glitchy Viewport Behavio

Post by 3dan » Tue Jul 29, 2014 2:01 pm

I would like to add that I too am experiencing the same problem.

I'm surprised there is no response from 3Dconnexion here :|

Post Reply