To anyone with "Error cannot find procedure" etc

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
cubepusher
Posts: 2
Joined: Sat Sep 15, 2012 6:00 pm

To anyone with "Error cannot find procedure" etc

Post by cubepusher » Sat Sep 15, 2012 6:16 pm

This may sound stupidly obvious but just open you existing usersetup.mel under "program files\autodesk\maya2013\scripts" and add the line:

Code: Select all

//  The usersetup script is executed, when loading Maya

MagellanStartup;
To whatever is already there and everything should work fine, and 3dconnexion if you can update you FAQ to reflect the fact that this error can be resolved by one simple line of code rather than the existing advice of uninstalling all your currectly working and correctly configured plugins for no bloody reason that would be swell. I'm aware this may sound snarky and I don't mean to be but I'm kinda used to having things work out of the box now and don't really de-construct things until I have to, the thing is I already had a problem with this when I first installed on Maya 2012 and if I didn't already know from that experience that this whole thing is dependant on mel scripts to kick in I don't know how I would have already known to look into them.

I sure as hell wouldn't know to look at them from anything in your documentation or FAQ and the advice which is in the FAQ is in the vain of "have you tried turning it on and off again" which call me egotistical but I think anyone smart enough to work with 3D software has a pretty firm foundation in that brand of common sense.

So please could you add that to the FAQ under what's currently there in the event that I forget what I had to do to install this thing properly come Maya 2014 or some other new toy.

Tiago
Posts: 2
Joined: Sat May 16, 2020 7:03 pm

Re: To anyone with "Error cannot find procedure" etc

Post by Tiago » Sat May 16, 2020 7:11 pm

Hey! can you help me? i can't find the "usersetup.mel" it's an emergency

Tiago
Posts: 2
Joined: Sat May 16, 2020 7:03 pm

Re: To anyone with "Error cannot find procedure" etc

Post by Tiago » Sat May 16, 2020 7:29 pm

Hey does that still works with 2018? Also i couldn't find the "usersetup.mel"

DavidV
Moderator
Moderator
Posts: 2
Joined: Mon Feb 24, 2020 2:49 pm

Re: To anyone with "Error cannot find procedure" etc

Post by DavidV » Tue May 19, 2020 6:15 am

Tiago,

The location has changed a little bit but it repetitively the same path for the newer versions.

Open File Explorer.
go to: Documents\maya\<Version>\scripts

You should find it there.

Post Reply