I have a few questions I want to ask

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
Celena
Posts: 1
Joined: Thu Oct 10, 2019 7:29 pm

I have a few questions I want to ask

Post by Celena » Thu Oct 10, 2019 7:30 pm

Altium's latest beta version of Altium Designer 18 (18.0.4) changed the file name of their executable to X2.EXE.
3DxWare doesn't seem to recognize it as Altium Designer, so I'm losing some of the 3DxWare functions for my SpaceMouse Pro that worked when AD was DXP.EXE.

Fit: With X2.EXE, it doesn't work at all.
QuickZoom: With X2.EXE, it offers mouse wheel increments (up/down 5x/25x), which don't work for zooming unless you're holding down the Ctrl key.

I made some macros as work-arounds for the time being.

I looked at my two profiles (AltiumDesigner.xml, X2.EXE.xml), and I'm not sure how to adapt my old profile for use with X2.EXE. Any ideas?

Thanks!

jwick
Moderator
Moderator
Posts: 2539
Joined: Wed Dec 20, 2006 2:25 pm
Location: USA
Contact:

Re: I have a few questions I want to ask

Post by jwick » Fri Oct 11, 2019 1:18 am

Our new cfg file includes both exe names so it should be used with both executables.

But you probably need to delete your two saved user files (%appdata%\3dconnexion\3dxware\cfg\Altium and X2 cfg files) and restart our driver.

You can merge your files manually if it is particularly important to keep your old settings. Or you can send them to me to merge them for you.

Update to 3DxWare 10.6.3 first.

Post Reply