SolidWorks Rotation Center

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
alidayvn
Posts: 2
Joined: Tue Aug 27, 2019 12:34 am

SolidWorks Rotation Center

Post by alidayvn » Thu Aug 29, 2019 2:40 am

When using the mouse to rotate the view in SolidWorks 2009 the center of rotation is automatically the center of the screen when the rotation begins. This is very intuitive and allows one to work on a small section of an assembly without the components floating off into space due to a rotation about the assembly origin.

Is there any way to replicate this behavior with my SpacePilot? The closest I've come is using the "Set Center Point" (SCP) 3Dx command. This works, but it's inefficient and tedious, as evidenced by the workflow steps below.

1) Zoom to a small portion of an assembly
2) Make sure SCP is not active
3) Select face/point that you want to rotate about
4) Activate SCP
5) Manipulate away
6) Deactivate SCP
7) Repeat 1-6 as required

It would be great if there were something similar to SCP, but triggered off of the screen center and puck motion. The most hands-off approach would be to reset the rotation center to the screen center whenever the sensor transitioned from "moving" to "not moving". That way I could make a chain of moves, as required, to get where I need to go and not have to keep hitting a button.

The other option might be a button/command that reset the rotation center to the screen center. So instead of resetting it whenever you stopped moving, it would only reset when the command was activated. Unlike SCP, this wouldn't be a toggle that made you to turn it off or on, but it would require a separate Reset Center command to return to defaults.

What do you think?

UtaSH
Moderator
Moderator
Posts: 3289
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SolidWorks Rotation Center

Post by UtaSH » Fri Aug 30, 2019 7:36 am

Hi alidayvn,

please open the Advanced Settings in the 3Dconnexion Settings while SolidWorks is open. In the left side you see "Rotation Center" . Here please deacvtivate the box "Auto". Does this provide the behaviour you want?

Post Reply