Disable spacemouse for certain applications

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
Posts: 1
Joined: Mon Apr 15, 2019 8:18 am

Disable spacemouse for certain applications

Post by ferelcabeza » Tue Apr 16, 2019 8:38 am

Hello! I'm new in the forum and in the spacemouse environment. I work as an architect and using daily autocad, sketchup and lumion. Working on sketchup and cad it's easy for now, but i read that lumion isn't supported (I know.. sad.. :( ). that isn't the main problem.
the problem it's that when i touch the spacemouse the camera on lumion goes crazy and don't stop rotating. the only way to stop is closing the program and opening again.
my question: there is a way to disable it completely for lumion and use it only on other programs at the same time? thanks

Posts: 8
Joined: Thu Mar 28, 2019 8:29 am

Re: Disable spacemouse for certain applications

Post by nwhisenton » Thu May 02, 2019 6:36 am

Hi Ferelcabeza,

What version of Lumion are you running?

I would recommend that you request for 3D mouse support in Lumion at Act-3D B.V.
Can you please try this workaround that would ignore an application? Let me know if that works for you.

- Remove the Lumion.xml file you have in “…\AppData\Roaming\3Dconnexion\3DxWare\Cfg”
Here's an example of what mine looks like before. This is where you'd replace with the code below:
2019-05-02_11h39_03.png (9.11 KiB) Viewed 4840 times
3DxHome and a few other applications have Cfgs that tell the driver to ignore them:

Code: Select all

- Get our latest version of the driver 10.5.6 available here: https://www.3dconnexion.fr/service/drivers.html
- Place the Lumion.xml in attachment into the “…\AppData\Roaming\3Dconnexion\3DxWare\Cfg”
- Reboot the computer
- Make sure the driver is started
- Start Lumion and do your testing

Thank you,


Post Reply