Maya 2018 : plugin 3dxMaya causing some errors

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
loukana
Posts: 4
Joined: Fri Nov 09, 2012 8:53 am

Maya 2018 : plugin 3dxMaya causing some errors

Post by loukana » Thu Jan 17, 2019 9:20 am

Hello,

I've got some strange errors on Maya 2018 with the 3DxMaya plugin :

1. On Maya startup, even before the UI loads, I get this error :

Code: Select all

Cannot find procedure "import".
Start of trace: (command window: line 2).
import (command window: line 2).
C3Dconnexion (file: C:/ProgramData/Autodesk/ApplicationPlugins/3DxMaya/Contents/scripts/3DxMaya_load.mel, line 2).
It looks like an import command is sent as mel instead of python, and causing this error. I checked the mel scripts for the plugin, and the import command isn't used, so I guess it might come from somewhere inside the .mll.

2. Each time I open Maya, the plugin cause Maya to switch the symmetry to "Object X" instead of "Off", and I must reset it manually once the loading is finished. Saving prefs doesn't work...

3. The plugin auto-loads, even if auto-load isn't checked in Plug-in Manager. The only way to run Maya without 3DxMaya is to uninstall the plugin.

4. If I unload, then reload the plugin, I get a ton of errors in the script editor, as well as the Relationship Editor opening (no idea why...)

Is someone familiar with those problems ? The 3D mouse works correctly in Maya but those bugs are a bit annoying, and I would like to clean them as much as possible.

Thanks in advance !

More infos :
- I use a SpaceNavigator
- 3DxMaya version 5.2.6
- userSetup.mel is empty of any commands related to 3DxMaya

Janoshx
Posts: 33
Joined: Wed Jul 13, 2016 4:16 am

Re: Maya 2018 : plugin 3dxMaya causing some errors

Post by Janoshx » Mon Jan 21, 2019 12:15 am

Hi

I have also noticed that on Maya 2018 the symmetry is on by default for some reason. For me it doesn't happen every time when maya starts but almost. I didn't realize that the cause is 3d connexion plugin but now it is obvious. I uninstalled the plugin, rebooted machine and maya launches fine. When i reinstalled the latest version 3DxWare64_v10-5-12_r2890.exe and then launched maya the symmetry Object X is turned on.

I have, long time ago, filed a bug about this to Autodesk. They told me that some of the plugin in my machine is causing this to happen and instructed me to add a line maya environment file to force symmetry back to normal on startup.

So this behavior is a bug in 3D connexion maya plugin. Please fix this because it is rather annoying.

Post Reply