3DxWare not loading in 2018!

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

jwick
Moderator
Moderator
Posts: 2680
Joined: Wed Dec 20, 2006 2:25 pm
Location: USA
Contact:

Re: 3DxWare not loading in 2018!

Post by jwick » Thu May 28, 2020 7:26 am

The LEDs are not application-specific (although it is an interesting idea).
If they are enabled, they should always be on, as long as the driver is running.

If the driver is not running, and you start Creo, the driver will get started (and turn on the LEDs).
That would be very unusual. Normally the driver is started when you boot your machine.
Is the 3Dx systray icon there all the time?

You might have a power problem or a conflict with another driver.

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2018!

Post by David.P » Thu May 28, 2020 8:03 am

Thank you Jim, will check that and report back.

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2018!

Post by David.P » Fri May 29, 2020 9:32 am

I'm still seeing the behavior that SpaceNavigator only starts when a model is actually loaded in Creo View.

I now had activated 3DxWare driver logging for a few days. Where is the log file stored, so that I can view it or post it to the forum?

A similar problem came up with another device (Yeti Nano Desktop Microphone) a few days ago. It is no longer recognized on the PC in question (Win10 v1909 build 18363.778), while it continues to work perfectly on a laptop with an older Windows 10 build (v1803 build 17134.1304), just like the SpaceNavigator does.

Therefore I believe that the problem might be due to a recent Windows update?

jwick
Moderator
Moderator
Posts: 2680
Joined: Wed Dec 20, 2006 2:25 pm
Location: USA
Contact:

Re: 3DxWare not loading in 2018!

Post by jwick » Mon Jun 01, 2020 12:55 am

The log file is %localappdata%\3Dconnexion\3DxWare\3DxService.log
You can PM me a dropbox-type location to it.

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2018!

Post by David.P » Thu Jun 04, 2020 1:04 am

Hello Jim,

thank you for your support.

I still see the SpaceNavigator (most of the time) only lighting up and starting after I open an assembly in Creo View, or after I start Google SketchUp 2018 Pro, for example.

Only sometimes, SpaceNavigator would start by itself at boot time already.

When I manually start "3Dconnexion Home" -> "Properties", or "Start 3DxWare", nothing happens, and there is no 3Dx tray icon
(unless I start a CAD program, in which case the tray icon appears).

I've PM'ed you and provided the driver log files for your reference.

Thank you
David

jwick
Moderator
Moderator
Posts: 2680
Joined: Wed Dec 20, 2006 2:25 pm
Location: USA
Contact:

Re: 3DxWare not loading in 2018!

Post by jwick » Thu Jun 04, 2020 1:45 am

Hi David,

Thanks for sending those two log files.
The log file appears to say the driver is stalling (stuck), or crashes without any notice, when it tries to access some files in your file system.
In this case (morning before Creo View), can you check if the driver is still running (taskmgr: look for 3DxService.exe).

I see the same user is used to launch Creo View as used in the morning. I assume Creo View is causing the driver to start (that's the defined behavior).
So it appears to start by Creo View, but not manually.

How do you start Creo View? Through a shortcut? Does that shortcut add privileges (run as admin)?

Does it also start if you run our jet demo (Program Files/3Dconnexion/3DxWare/3DxWincore/jet.exe)?

Could you please run our diagnostic tool? When the driver is running, hold down the shift key and right click the 3Dx systray icon->Run Diagnostics.
When it is done, it will open a directory with a large zip file in it. Please PM a link to that file to me.

Thanks.
Jim

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2018!

Post by David.P » Thu Jun 04, 2020 1:51 am

Thank you very much Jim for the fast action.

I will carry out all the steps you described, and report back.

David

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2018!

Post by David.P » Mon Jun 08, 2020 8:16 am

Hello Jim,

I've PM'ed you again and provided the Run Diagnostics files.

You wrote:
> In this case (morning before Creo View), can you check if the driver is still running (taskmgr: look for 3DxService.exe).

3DxService.exe was not running before starting Creo View. After doing so, the following SpaceNavigator related processes were running:
https://i.imgur.com/g46IXMv.png

> How do you start Creo View? Through a shortcut? Does that shortcut add privileges (run as admin)?

I start Creo View either through a shortcut, or by double-clicking on a Creo file like *.pvz.
It doesn't run with special privileges as far as I know.

> Does it also start if you run our jet demo (Program Files/3Dconnexion/3DxWare/3DxWincore/jet.exe)?
Yes the SpaceNavigator starts also this way.

Thank you
David

jwick
Moderator
Moderator
Posts: 2680
Joined: Wed Dec 20, 2006 2:25 pm
Location: USA
Contact:

Re: 3DxWare not loading in 2018!

Post by jwick » Wed Jun 10, 2020 1:03 am

Hi David,

I didn't get the PM. I'll PM my email address to you. You can send the link to that.

Jim

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2018!

Post by David.P » Wed Jun 10, 2020 1:21 am

Sorry Jim, about the missing PM -- I had hit "reply" and it had sent the reply to myself for some reason :o

I have sent the PM again and made sure you're the recipient.

Thank you
David

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2018!

Post by David.P » Wed Jun 10, 2020 1:51 am

OK, after SpaceNavigator wouldn't even start when opening a Creo View assembly this morning, I tried and simply started 3DxService.exe as Admin.

This instantly started SpaceNavigator up!

Post Reply