Jerky graphics with Space pilot PRO on Solidworks

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

takedownca
Posts: 65
Joined: Thu Mar 29, 2007 3:49 pm

Re: Jerky graphics with Space pilot PRO on Solidworks

Post by takedownca » Thu Apr 11, 2019 8:24 am

Update: installing a newer nVidia driver seemed to do the trick.

Lindenrb
Posts: 1
Joined: Tue Apr 16, 2019 9:17 pm

Re: Jerky graphics with Space pilot PRO on Solidworks

Post by Lindenrb » Tue Apr 16, 2019 10:11 pm

n0f8r wrote:
Sun Feb 17, 2019 2:39 pm
I'm fairly sure now that in my case it's a wireless reception issue.

I have the Spacemouse pro wireless, I think the receiver moved slightly or something. It was less than 4 feet from the spacemouse, but I moved it closer anyway and control has been smooth for hours now.
1+ For this. My space mouse wireless sits on the left side of my desk while my desktop is under the desk on the right side. The lag gets out of control and the mouse becomes unusable sometimes where it sits on the left, but if I move it over to the right its perfectly fine. The interference might be compounded by the fact that I'm surrounded by engineers all using the same space mouse.
Looks like I'll be swapping the sides for my computer and my draws to reduce the distance

zazz
Posts: 67
Joined: Sat Sep 27, 2014 10:50 pm

Re: Jerky graphics with Space pilot PRO on Solidworks

Post by zazz » Mon Nov 18, 2019 12:31 am

Do you have same problem as me?

Note that right-clicking on the icons the issue disappears. I will try the driver 10.4.3 suggested here earlier.

https://streamable.com/eich4

zazz
Posts: 67
Joined: Sat Sep 27, 2014 10:50 pm

Re: Jerky graphics with Space pilot PRO on Solidworks

Post by zazz » Mon Nov 18, 2019 1:14 am

No, the 10.4.3 driver did not change anything

zazz
Posts: 67
Joined: Sat Sep 27, 2014 10:50 pm

Re: Jerky graphics with Space pilot PRO on Solidworks

Post by zazz » Tue Nov 19, 2019 11:29 pm

I have tried with 4 different mice and with no mouse at all. with no noticeable differences.

Changing the mouse frequency does not affect the Spacemouse Pro's performance as long as the mouse is not moving. But it does affect the middle mouse rotation drastically. 1000-250HZ rotates the model nicely and GPU-load is between 80-100%, but at 125HZ, GPU-load drops down to around 10-30% and model is not rotating smoothly anymore, similar to when rotating with the Spacemouse Pro. Can it be that the Spacemouse Pro gets a limited bandwidth of some reason?

It seems to me that this is a limitation/bug in Solidworks, which 3Dconnexion seems to be powerless to do anything about. Same as the LONG lasting issue SpaceMouse Pro moves erratically in Solidworks https://www.3dconnexion.com/forum/viewt ... =25&t=9466 that still persists but has become slightly better, or it feels so at least, as i have dedicated a mouse button as "center to fit" and i'm pressing it all the time nowadays which resolves the issue for a while.

Post Reply