<DONE> SpaceNavigator Driver - Mouse Joystick Keyboard

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Locked
pi3573
Posts: 45
Joined: Mon Jun 18, 2007 11:06 pm

code

Post by pi3573 » Thu Mar 06, 2008 12:55 am

the source is up for all to use guys ......its on page 17

votan
Posts: 9
Joined: Mon Jan 14, 2008 3:07 pm

Post by votan » Thu Mar 06, 2008 4:18 pm

Well, yes.. we thought you would post your current progress, so we can work on the current state of the driver.... ;)

wep
Posts: 2
Joined: Fri Mar 14, 2008 4:25 am
Contact:

Post by wep » Fri Mar 14, 2008 4:29 am

3DCONNEXION please develop a x64 Vista-Driver like this one. A joystickdriver with simply mapping of the axes and the buttons would satisfy me and maybe many others.

moebiussurfing
Posts: 3
Joined: Sun Mar 16, 2008 6:09 am

no way to installa de RBC9 driver

Post by moebiussurfing » Sun Mar 16, 2008 6:27 am

Im in Windows XP sp2 and i have my new SpaceNavigator. I followed all this pages of posts, mainly, but without succes. My system cant update the driver. No gamepad reconized, and still with the "no space navigator found" message. I read other ppl with same problem and they solved. I cant. I tryed to manually install with rigth click above the .inf file but nothing changes. I must deinstall the 3dconnection installer? I tryed thisd also.. Thanks for the help

moebiussurfing
Posts: 3
Joined: Sun Mar 16, 2008 6:09 am

Post by moebiussurfing » Sun Mar 16, 2008 7:02 am

i solved. but dunno how. thanks anyway for this amazing driver

QuinoBLN
Posts: 2
Joined: Fri Mar 21, 2008 10:24 am
Location: Berlin

Any news about Spacepilot?

Post by QuinoBLN » Fri Mar 21, 2008 10:40 am

Hi *!
has anybody any news about RBC9 driver and the Spacepilot?

After much reading and trying, I could only reproduce the behaviour described by some posters with the Fadetoblack debug version. (The driver unloads itself when I touch any control, otherwise it freezes, and DebugView produces similar output to what described in some posts ago).

Platform: XP 32 Prof, 2x Intel Xeon

Any ideas? Thank you all in advance!
Quino

Lappen
Posts: 3
Joined: Fri Mar 21, 2008 12:26 pm

Post by Lappen » Fri Mar 21, 2008 12:46 pm

Hi all!
I have got a problem with my Installation. I do everything like it is written in the first post. When i try to update the driver in my device-manager the "hardware update wizard" is updating and updating... as long as do not touch my space-pilot. If i press any button on it or touch the "ball" the "hardware update wizard" is telling me: "cannot start this hardware" and the lights of my space-pilot are turning off. In my device manager a yellow "!" is written on the space-pilot. I have tried it a few times and finally i set up my pc new. I have just installed my motherboard-drivers, my graphic-drivers and after a few tries my w-lan drivers to check the forum again. If someone had the same problem or can help me otherwise, i would be glad to read from u
:)
I made a few screenshots from my Problem. U can find it under http://rapidshare.com/files/101308718/R ... m.rar.html


My System:
"SpacePilot"
"Windows XP32bit Prof SP3"

Greetz, Lappen!

Lappen
Posts: 3
Joined: Fri Mar 21, 2008 12:26 pm

Post by Lappen » Fri Mar 21, 2008 1:19 pm

Now i read every page of this topic and i see that I am not the only one with this Problem. Am I right that i will not be able to get it to work? Because i tried it a few hours and set up my pc new. If there is no chance I would like to know^^
(But after set up my pc new it works faster and my desktop is so empty ;) )

Greetz, Lappen!

Ives
Posts: 1
Joined: Wed Mar 26, 2008 5:37 am

Post by Ives » Wed Mar 26, 2008 5:40 am

I can't install the driver (it doesn't show up in the Hardware Update Wizard, only the HID standard one shows up). When I try to manually install from the INF i got from /windows/inf, I get an error

Image

I'm running Win XP SP2, but I did install the latest version of the SpaceNav software. I think that's the problem.

Any suggestions?

pi3573
Posts: 45
Joined: Mon Jun 18, 2007 11:06 pm

driver

Post by pi3573 » Wed Mar 26, 2008 3:21 pm

space nav you should be able to get it going with no prob catch me on msn or send me an email and ill help you.are you sure you did the PID part right?

LostSailor
Posts: 1
Joined: Thu Apr 17, 2008 11:42 am

SpaceNavigator for Notebooks?

Post by LostSailor » Thu Apr 17, 2008 11:50 am

I read back four or five pages and did not see anything about the SpaceNavigator for Notebooks. Hope I didn't miss anything -

At any rate, I cannot seem to be able to get the RBC9 driver to recognize my brand new SNfN - one clue here, the HID ID is different from the one listed in the documentation. Device Manager shows:

USB\VID_046D&PID_C628&REV_0406
USB\VID_046D&PID_C628

where C628 exists in place of C626 in the docs.

When I try to "Update driver", the RBC driver is not found as associated with the device.

Vista32, and the SNfN works otherwise using the native driver in Google Earth.

Any ideas?

Jack
Posts: 1
Joined: Mon Apr 21, 2008 3:36 pm

Post by Jack » Mon Apr 21, 2008 3:45 pm

Hi!

I have installed this wonderful driver, but I can't make it work. It recognizes my SpaceNavigator and when I open the app to configure it, the values on all axis are displayed when I move the knob.

I made some layouts and when I change between apps the layout actually changes.

But configured the movements like Joystick X, Y and Z axis, and any app respond to the movements (except the default empty layout that that uses 3dxSrv.exe) on google earth...

Mostly I want to use it for Excel, IE and firefox besides Google Earth...

What could be wrong? Are any configuration tips? Tnx!

yuriythebest
Posts: 12
Joined: Fri Mar 28, 2008 3:39 pm
Contact:

Post by yuriythebest » Tue Apr 22, 2008 12:01 pm

please develop a windows XP 64 bit version. Not interested in vista, Xp 64 pliz...

JohannesL71
Posts: 6
Joined: Thu Apr 24, 2008 1:40 am
Location: Umeå, Sweden

Stupid question ?

Post by JohannesL71 » Mon Apr 28, 2008 4:46 am

Will the RBC9 driver work in windows XP ?

:oops:

/J

Chef
Posts: 2
Joined: Wed Nov 28, 2007 8:26 pm
Location: TAIWAN

Re: Stupid question ?

Post by Chef » Thu May 01, 2008 9:25 pm

JohannesL71 wrote:Will the RBC9 driver work in windows XP ?
Yes, it works perfectly in Windows XP.

Locked