USB-Space-Mouse bzw. Space Explorer wird nicht mehr erkannt

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

jz
Posts: 7
Joined: Mon Sep 10, 2007 12:57 am

USB-Space-Mouse bzw. Space Explorer wird nicht mehr erkannt

Post by jz » Mon Sep 10, 2007 1:13 am

:?:
Hallo zusammen,

ich habe seit kurzem das Problem, dass USB-Space-Geräte (nachdem sie tagelang reibungslos funktioniert haben) nach dem Booten nicht mehr von Windows XP SP2 erkannt werden. D.h. erst nachedem das Gerät an einen anderen USB-Port gesteckt wird, wird es von Windows wieder als "neues" Gerät erkannt, installiert und dann kann auch der Treiber wieder erfolgreich gestartet werden. Das Problem kann ich bisher noch nicht duplizieren.

Wer hat schon so einen Problem gehabt und eine dauerhafte Lösung gefunden?

Vielen Dank im Voraus.

Jörg

agoenczi
User
User
Posts: 668
Joined: Mon Dec 04, 2006 6:17 am
Location: EU

USB-Space-Mouse bzw. Space Explorer wird nicht mehr erkannt

Post by agoenczi » Mon Sep 10, 2007 4:58 am

Hallo jz,

hast Du mehrere USB-Geräte an Deinem Rechner angeschlossen?

Ist das Gerät was Du verwendest ein SpaceMouse, oder ein SpaceExplorer?

Was passiert, wenn Du das Gerät an einem anderen USB-Port anschließt? Kannst Du das Gerät verwenden aber nach dem Neustart wird wieder nicht erkannt?
agoenczi

jz
Posts: 7
Joined: Mon Sep 10, 2007 12:57 am

Post by jz » Mon Sep 10, 2007 5:17 am

Hallo agoenczi,

die Geräte sind natürlich an verschiedenen Rechnern angeschlossen und das Problem trat sowohl bei einer USB-Space-Mouse-Plus als auch an mehreren Space-Explorern auf.

Wenn ich die Space-Mouse an einem anderen Port anschließe wird sie erkannt und kann auch nach einem Neustart wieder benutzt werden.

Diese Problem tritt also spontan auf (auch erst in der letzten Zeit) und kann auf einem identisch aufgebauten Arbeitsplatz nicht "nachgestellt werden.

Gruß

Jörg

agoenczi
User
User
Posts: 668
Joined: Mon Dec 04, 2006 6:17 am
Location: EU

USB-Space-Mouse bzw. Space Explorer wird nicht mehr erkannt

Post by agoenczi » Mon Sep 10, 2007 5:23 am

Hallo jz,

wurde in der letzten Zeit eine Änderung auf den Rechnern gemacht, wie z. B. Virensignatur-Aktualisierung?

Werden die Geräte nach einer manuellen Neustart auch nicht mehr erkannt?
agoenczi

jz
Posts: 7
Joined: Mon Sep 10, 2007 12:57 am

Post by jz » Mon Sep 10, 2007 5:31 am

Hallo agoenczi,

am Virenscanner kann es meiner Meinung nach nicht liegen, das von den getroffenen Rechnern mehrere im Netzwerk sind und alle vom gleichen Virenscanner zentral mit Updates versorgt werden, d.h. ich dürfte nicht nur einen "Ausfall" sondern ich müßte 15mal das gleiche Problem haben.

Wenn ich den Rechner nur neu starte ohne eine Änderung an der USB-Port-Belegung zu machen, wird die Space-Mouse nicht erkannt, d.h. der Treiber wird nicht oder nicht erfolgreich (es kommt keine Fehlermeldung) gestartet. z.B. bleibt beim SpaceExplorer das blaue Licht aus.

Jörg

agoenczi
User
User
Posts: 668
Joined: Mon Dec 04, 2006 6:17 am
Location: EU

Post by agoenczi » Mon Sep 10, 2007 5:44 am

Hallo jz,

kannst Du testen was passiert, wenn Du das Gerät an einem anderen Rechner betreibst?

Wie viele Geräte (mit Typangabe, bitte) sind überhaupt betroffen?
agoenczi

jz
Posts: 7
Joined: Mon Sep 10, 2007 12:57 am

Post by jz » Mon Sep 10, 2007 6:15 am

Hallo agoenczi,

das Gerät würde an einem anderen Rechner wahrscheinlich sofort funktionieren, das es nach dem USB-Port-Wechsel ja auch an dem "Problem-Rechner" sofort und danach auch schon wieder längere Zeit funktioniert.

Wir haben ca. 90 Rechner mit Space-... im Einsatz. 20 Rechner sind seit kurzem mit Space-Explorer ausgestattet, 20 Rechner mit "Space-Mouse-Classic" und 20 Rechner haben die "Space Mouse USB Plus". Die verschiedenen Geräte wurden im Laufe der letzten 8 Jahre angeschafft und haben eigentlich immer problemlos funktioniert. Die seriellen Geräte sind bisher noch nicht mit diesem Fehler aufgefallen.

Jörg

agoenczi
User
User
Posts: 668
Joined: Mon Dec 04, 2006 6:17 am
Location: EU

USB-Space-Mouse bzw. Space Explorer wird nicht mehr erkannt

Post by agoenczi » Tue Sep 11, 2007 5:18 am

Hallo jz,

sind alle 20 Rechner mit SpaceExplorer betroffen?

Verwendet man auf den betroffenen Rechnern die gleiche Anwendungen? Welche Anwendungen?
agoenczi

jz
Posts: 7
Joined: Mon Sep 10, 2007 12:57 am

Post by jz » Tue Sep 11, 2007 5:25 am

Hallo agoenczi,

bisher waren 3 der Rechner mit SpaceExplorer ausgerüsteten Rechner betroffen. Alle Rechner sind per Softwareversorgung identisch installiert worden. Die Anwendung für den SpaceExplorer ist Unigraphics, wobei das PlugIn nicht installiert wurde.
Viele Grüße

Jörg

agoenczi
User
User
Posts: 668
Joined: Mon Dec 04, 2006 6:17 am
Location: EU

USB-Space-Mouse bzw. Space Explorer wird nicht mehr erkannt

Post by agoenczi » Tue Sep 11, 2007 6:18 am

Hallo jz,

ich würde Dich bitten um einen Test durchzuführen.

Wenn ein Gerät nicht erkannt wird, verbinde bitte das Gerät an einen anderen USB-Port und starte den Rechner erneut. Wird das Gerät diesmal an dem anderen USB-Port erkannt? Ist wieder eine Trennung und Wiederherstellung der Verbindung mit einem anderen USB-Port notwendig das Gerät wieder funktionsfähig zu "machen"?

Sende mir, bitte, die Seriennummern der betroffenen Geräte in einem PM.

Danke!
agoenczi

jz
Posts: 7
Joined: Mon Sep 10, 2007 12:57 am

Post by jz » Tue Sep 11, 2007 6:26 am

Hallo agoenczi,

die beschriebene Vorgehensweise deckt sich zu 100% mit meiner Erfahrung. Ich musste den Rechner herunterfahren, den SpaceExplorer an einen anderen USB-Port stecken und den Rechner dann wieder Hochfahren. Dann hat WinXP die "Neue Hardware" erkannt und der SpaceExplorer war seither wieder ohne Probleme zu benutzen.
Alle anderen Versuche den SpaceExplorer zum Laufen zu bringen (z.B. Neustart des Treibers und Reparieren der Software) brachten den SpaceExplorer nicht zum Laufen.

PM folgt morgen.
Viele Grüße

Jörg

agoenczi
User
User
Posts: 668
Joined: Mon Dec 04, 2006 6:17 am
Location: EU

USB-Space-Mouse bzw. Space Explorer wird nicht mehr erkannt

Post by agoenczi » Tue Sep 11, 2007 7:16 am

Hallo jz

vielen Dank für den Test.
agoenczi

Meister Lampe
Posts: 9
Joined: Thu Aug 16, 2007 2:32 am

Exakt gleiches Problem mit Space Navigator

Post by Meister Lampe » Wed Sep 19, 2007 8:01 am

Ich habe genau das gleiche Problem mit einem Space Navigator.

Gibt es da schon eine Lösung?

Bin sehr unglücklich, habe Treiber für Connexion in unsere Software eingebunden, kann die aber nicht freigeben, so lange diese Problem bestehen. Jetzt liegen hier 2 Space Navigatoren rum und sind wertlos. Zurückgeben will ich sie aber nicht, weil ich überzeugt bin, dass die Hardware OK ist.

Grüße
Philipp

agoenczi
User
User
Posts: 668
Joined: Mon Dec 04, 2006 6:17 am
Location: EU

Post by agoenczi » Wed Sep 19, 2007 8:04 am

Hallo Meister Lampe,

welche Anwendung hast Du?

Erkennt Windows nicht die Geräte?
agoenczi

Meister Lampe
Posts: 9
Joined: Thu Aug 16, 2007 2:32 am

Problembeschreibung

Post by Meister Lampe » Wed Sep 19, 2007 8:18 am

Das Problem ist scheinbar das gleiche wie oben beschrieben.

Die Treiber funktionieren, bis man Windows neu bootet.

Nach dem Reboot fordert 3dxsvr.exe 100% CPU load und es funktioniert nicht mehr. Will sagen auch die Demoapplikationen wie "Chicken Demo" reagieren nicht auf die 3D-Maus (kommt aber auch keine Fehlermeldung).

Irgendwie muss man Windows ohne 3dConnexion neu booten und den Space Navigator an einen anderen Port neu dran hängen und warten bis Windows die das USB-Gerät wieder registriert hat. So kriegt man das Teil irgendwie wieder an den Start. Wie genau, unklar.

Ziel ist, den Space Navigator in eine eigene Anwendung zu integrieren. Das funktioniert auch schon wunderbar. Ihr könnt sogar gerne meine C++-Klasse für Visual Studio 2005 haben. Damit wird die Einbindung in C++-Programme wirklich einfach.

Nur dass es ausgerechnet auf dem Entwicklungssystem diese Probleme gibt.

Release Version 3.4.2
Driver Version 6.4.4
Firmware Version: 3.18
Device Type: Space Navigator

Philipp

Post Reply