Rotation is slow in Pro/ENGINEER W3

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
1234kire
Posts: 2
Joined: Tue Jun 05, 2007 2:18 am

Rotation is slow in Pro/ENGINEER W3

Post by 1234kire » Tue Jun 05, 2007 2:34 am

Rotation is slow in Pro/ENGINEER W3.
I am a new user to a Space Traveler, In Pro/E Wildfire 3, having the whole object on the screen, the rotation is OK, but when I zoom in on a detail, the rotation is very slow. I tried to speed up the settings, but that have no effect. Using 3DxSoftware_v3-3-6 driver. Any sugestion is welcome.

agoenczi
User
User
Posts: 668
Joined: Mon Dec 04, 2006 6:17 am
Location: EU

Rotation is slow in Pro/ENGINEER W3

Post by agoenczi » Tue Jun 05, 2007 8:21 am

Hi 1234kire

Could you specify the configuration of your system? I mean operating system with the number of the service pack, 32 or 64 bit, memory, graphic card, other connected USB devices and any other details which you consider that would be relevant for your case.
agoenczi

ngomes
Moderator
Moderator
Posts: 1982
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Post by ngomes » Tue Jun 05, 2007 11:20 am

Hi 1234kire,

Is the "dynamic highlight" feature turn on? When you zoom in, make sure the application does not try to highlight individual feature.

When Pro/E highlights a part, it draws a wireframe that is very computational intensive (not 3D accelerated).
Nuno Gomes

1234kire
Posts: 2
Joined: Tue Jun 05, 2007 2:18 am

Post by 1234kire » Tue Jun 05, 2007 11:59 pm

I am using a Dell Precision M90, XP, 32 bit, SP 2, 2 GB memory, Nvidia Quadro FX 1500M, It should be updated with the newest avialable drivers,
I have a default Dell Mouse, 2 button and 1 wheel, pluged in USB
I tried in W3, v. M030 and M070, W2, vM220.
I have tried to turn off the Dynamic Highligth, but still slow rotating.

takedownca
Posts: 65
Joined: Thu Mar 29, 2007 3:49 pm

Post by takedownca » Wed Jun 20, 2007 9:26 am

Check out your config.pro and make sure you don't have the following option:

spin_rate_zoom_sensitive yes

This setting lowers the spin setting the more you zoom in. I usually find it useful, but if you zoom in to very small features it will slow down the spin rate considerably.

Clausen
Posts: 12
Joined: Sun Jun 17, 2007 3:37 pm
Location: Melbourne, Australia

Post by Clausen » Wed Jun 20, 2007 5:27 pm

Hi there,

I'm also having the same problem. I have the ProE config option turned off, but it is still zoom sensitive. Any other thoughts? I'm using WF2 and I dont have 3dxproE installed because it doesnt work wtih 64bit WF2.

Regs

Paul

Clausen
Posts: 12
Joined: Sun Jun 17, 2007 3:37 pm
Location: Melbourne, Australia

Post by Clausen » Tue Aug 07, 2007 9:53 pm

Bump

agoenczi
User
User
Posts: 668
Joined: Mon Dec 04, 2006 6:17 am
Location: EU

Post by agoenczi » Wed Aug 08, 2007 1:19 am

Hi clausen

The WF2 problem on 64 bit systems is known. If you don't install the 3DxPROENGINEER you can navigate with the device as the navigation is implemented in Pro/E. You have only to install the driver. If you want some key mappings you can to that using mapkeys and the button mapping editor available in the driver GUI (3Dconnexion Control Panel).

The only solution would be to upgrade to WF3 (or WF4 if this will be released).
agoenczi

Clausen
Posts: 12
Joined: Sun Jun 17, 2007 3:37 pm
Location: Melbourne, Australia

Post by Clausen » Tue Aug 28, 2007 6:20 pm

Hi agoenczi,

That is exactly how I am using my spacepilot, and it works fine, however I would love to be able to get rid of the zoom sensitivity.

I do have the config.pro option for zoon sensitivity turned off but it still happens. I guess it is most likley a problem within ProE and not in the 3dfx software,

Regards,

Paul Clausen

agoenczi
User
User
Posts: 668
Joined: Mon Dec 04, 2006 6:17 am
Location: EU

Rotation is slow in Pro/ENGINEER W3

Post by agoenczi » Mon Sep 03, 2007 1:38 am

Hi clausen,

Sorry for the delay.

The navigation in Pro/E is a PTC implementation. I would like to ask you to contact PTC with this issue as 3Dconnexion has no access to the source code of the applications owned by PTC.
agoenczi

you're FIRED!
Posts: 1
Joined: Tue Nov 18, 2008 3:15 pm

Post by you're FIRED! » Tue Nov 18, 2008 3:22 pm

Bullsquash.

I'm using ProE Wildfire 3 with a SpaceExplorer (usb). I have the same roll/spin/tilt rate change with zoom level.

I tried looking into the "config.pro" setting change; I didn't even have that line of code IN my config file. In my opinion, if I have to selectively install/not-install portions of the 3DConnexion drivers in order for the zoom to function without decreasing the roll/spin/tilt rates, then the deficiency lies within the 3DConnexion software, not ProE. As it’s been a year since this question was last updated, does anyone have any new (useful) information? I’m surprised no one has suggested restarting my computer yet…

Post Reply