AutoCAD 2007

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

chrisman
Posts: 9
Joined: Thu Dec 14, 2006 10:27 pm
Location: Chicago, USA
Contact:

AutoCAD 2007

Post by chrisman » Sat Dec 16, 2006 10:46 pm

Hello,

I have problem using SpaceTraveler with AutoCAD 2007.

I use Free mode for navigation because this is the only mode that rotates arround a pivot point, but the the rotation directions are total mess - reverse checkbox does nothing for most of directions, it just rotates the oposit way and does not want to change.
Spin, Zoom and Pan Up/Down works onlly reversed

Help please!

and also I noticed that with the new driver I don't have any support for 2D applications. f.e. the old driver alows to scroll the browser web pages, also works in Photoshop, Illustraotr, InDesign... now with the new driver it does nothing. Is that normal ?
----------------------
Live while you live!

Ken Denton
Moderator
Moderator
Posts: 49
Joined: Mon Dec 04, 2006 2:39 pm
Location: Rochester, MI.
Contact:

Post by Ken Denton » Mon Dec 18, 2006 6:11 am

chrisman,
3DxSoftware 3.0 and higher allows many user preference settings. It sounds like you just need to find the correct combination for your desired movement. :D You may need to change the zoom direction on the "device configuration" page as well as reverse the axis to achieve your desired movement.

As for the 2D applications...You must install separate plug-ins from our archive page. If you previously had them installed, you will need to re-install the respective plug-ins. (i.e. 3DxOffice, etc...)
Ken Denton
3Dconnexion, Inc. A Logitech Company

Woldman
Posts: 16
Joined: Wed Jan 03, 2007 5:35 am

Post by Woldman » Wed Jan 03, 2007 7:13 am

Hello,

I can completely confirm the problem as described by Chrisman. AutoCAD 2007 seems to be unable to work with reversed axis. There is no change noticeable when you change any setting but the left / right direction. All others will remain un-reversed. This problem is related to the driver I think. Because when you click reverse it checks all the boxes behind the individual axis, but when you click reverse again, it removes on two checks (the red ones)

One other problem with AutoCAD seems to be the fact that the toolbar is repositioned every time you restart the program. Probably an Autodesk problem, but maybe it is related to how or when the driver loads when AutoCAD 2007 starts.

Next to this I also noticed a 'similar' problem in Google Earth. It seems impossible to select all the panning motions and only the spin rotational option. It works to start with, but when you switch back and forth between Google Earth and another app, the spinning axis is deactivated again. This setting is useful if one wants to move over the earth without changing the angle to the surface, but being able to manipulate the north angle.

Other than this the product works excellent, maybe only one thing, Sketchup performance seems much slower in heavy models when using the 3D controller in relation of for instance middle mouse rotation. Maybe some extra integration between Sketchup and 3dxware...

I hope I explained my four slight problems, and that in some next release they can be solved. Maybe the Vista Driver release, because I can't wait to lay my hands on the controller on my Vista system. I heard something about a beta testing. This would be something for me, as I'm quite picky as you can see in the remarks I made.

Greetings,

Bas Woldman
Using SpaceNavigator

Toaster55
Posts: 10
Joined: Thu Jan 25, 2007 11:52 pm
Location: Massachusetts

Same problem

Post by Toaster55 » Thu Jan 25, 2007 11:53 pm

I am having the exact same problem just as described above. In google earth, all the configuration options work, but in Autocad 2007, not so much. I am really dissapointed, as I purchased this device solely for Autocad.

Is there any way to get this to work properly?

ngomes
Moderator
Moderator
Posts: 1949
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Post by ngomes » Fri Jan 26, 2007 2:53 am

Hi all,
It seems that you may be using an old configuration file in 3DxWare. We suggest that you first upgrade to the latest available release (version 3.0 as of today). You may also use release 3.1 which is currently in beta.
Then, with AutoCAD in focus, open the 3DxWare panel and select the default AutoCAD configuration.
Do post here what you find. If the problem persists, we will continue the investigation.
Nuno Gomes

Toaster55
Posts: 10
Joined: Thu Jan 25, 2007 11:52 pm
Location: Massachusetts

Post by Toaster55 » Fri Jan 26, 2007 8:51 am

Yeah, I've tried the latest drivers, including the beta driver. I am still getting the same result. Like I said before, it works fine with other Applications, this seems to be an AutoCAD problem. The only setting that works is the Zoom Direction. THe speed settings for each individual axis work, it just will NOT reverse any of them at all. This for me makes this device just about worthless!

I did notice though, that anytime you change a setting, you see it in the command line area of AutoCAD. For example, when I change the Zoom direction, which works, I see in the Autocad Command line. When I try to reverse the axis on any of them, I don't see it in the command line.

Are there command line entries we can do as a temporary workaround?

ngomes
Moderator
Moderator
Posts: 1949
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Post by ngomes » Fri Jan 26, 2007 12:58 pm

Hi Toaster55,
We're trying to reproduce what you have reported. Up to now, all our scenarios are checking all right. Just bear with us for a while.

Toaster55
Posts: 10
Joined: Thu Jan 25, 2007 11:52 pm
Location: Massachusetts

Post by Toaster55 » Fri Jan 26, 2007 11:14 pm

Is there anything you suggest that I can do to workaround this problem? Like I said, I intended to use this device solely for AutoCAD, since I cannot configure it properly, I now have a really pretty paperweight! There must be something that I can do?

Do you guys need more detail about my setup so that you may better be able to reproduce the problem?

Woldman
Posts: 16
Joined: Wed Jan 03, 2007 5:35 am

Back on the Problem

Post by Woldman » Sat Jan 27, 2007 3:40 pm

I've been away for a while, but I'm glad to see others have the same problem also.

Reversing Axis in AutoCAD is simply only working for the 'red' two axis (as in red in the images in the driver) All the others just don't react to the reversed commands in the driver. Sometimes the checkboxes remain checked and sometimes they're unchecked when you come back to the driver. Only the red ones always remain and will work.

I've reproduced the problem myself on three different systems, all on clean installs of Windows, with all recent drivers including the 3.11. It's really simple to reproduce as it allways occurs when you use AutoCAD 2007.

I really hope you can incorporate a sollution in the final 3.1 driver, as its really needed for workflow in objects larger then certain scale, as you want to be able to reverse all axis, anf rotate yourself instead of the object. Ever tried to work this way on a urban plan, it's not natural.

Looking forward to an answer,

B | Woldman

Woldman
Posts: 16
Joined: Wed Jan 03, 2007 5:35 am

Post by Woldman » Sat Jan 27, 2007 3:52 pm

Also I'd like to confirm that the problem with Google Earth is still present here.

It is not possible to sellect both pan, zoom and spin axis and not the tilt and roll axis. This has nothing to do with reversing the axis, as they are already correct in google Earth. (in my opinion, just like I want to use them in AutoCAD)

All works when you set it the first time, but when you re-enter Google Earth, you have to set it again, as the spin axis is desellected again.

I hope this also can be resolved in the next driver release. (not as important as the AutoCAD problem though)

B | Woldman

mbonk
Moderator
Moderator
Posts: 156
Joined: Mon Dec 04, 2006 4:06 am

Re: Back on the Problem

Post by mbonk » Tue Jan 30, 2007 4:08 am

Woldman wrote: I really hope you can incorporate a sollution in the final 3.1 driver, as its really needed for workflow in objects larger then certain scale, as you want to be able to reverse all axis, anf rotate yourself instead of the object. Ever tried to work this way on a urban plan, it's not natural.
Instead of trying to reverse the axes in 3dxware have you tried the fly or walk navigation modes - the feet/dart icons on the 3dconnexion toolbar? These ought to put you into a first person mode. Do they do what you want?

Niels Maas
Posts: 7
Joined: Fri Feb 02, 2007 1:18 am

Post by Niels Maas » Wed Feb 07, 2007 7:59 am

I'm experiencing kind of the same problem in Mechanical Desktop (AutoCad 2007).

In "free mode" I can pan and zoom, but can't rotate. And I can't find a way to get it work. The only way that it's functioning is after I've activated the "3D-orbit" manually (in AutoCad) and then use my Spacetraveler, but that's not the way.

Suggestions?

Greetings Niels

mbonk
Moderator
Moderator
Posts: 156
Joined: Mon Dec 04, 2006 4:06 am

Post by mbonk » Thu Feb 08, 2007 2:24 am

Niels Maas wrote: In "free mode" I can pan and zoom, but can't rotate.
Are you using a 2D wireframe? The device does not rotate in a 2D view. Try a 3D wireframe: I believe the orbit tool switches to a 3D wireframe when activated.

Markus

Niels Maas
Posts: 7
Joined: Fri Feb 02, 2007 1:18 am

Post by Niels Maas » Thu Feb 08, 2007 9:25 am

Mechanical Desktop works in a 3D model inveronment and thats the place where the orbit is not functioning...

Toaster55
Posts: 10
Joined: Thu Jan 25, 2007 11:52 pm
Location: Massachusetts

Post by Toaster55 » Thu Feb 08, 2007 9:27 am

I am still having problems with the snap markers shifting from the image in Autocad 2007 as well...........

I also need to reset all the reverse axes check boxes every time I restart the application........

Any progress there?

Post Reply