How to lock horizon when orbiting in Blender

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

Post Reply
PDBreske
Posts: 1
Joined: Thu Mar 12, 2020 8:59 am

How to lock horizon when orbiting in Blender

Post by PDBreske » Sun Mar 15, 2020 11:43 am

I know this has been covered in another thread (that's how I found this forum through a search), but I wanted to create a new topic for anyone who may be having issues with the crazy bank and roll issues in Blender when using a 3Dconnexion mouse.

Nothing you can do in the 3Dconnexion preference pane will correct these issues, and from what I've found, a lot of people new to Blender and/or a 3D mouse have trouble maintaining a level horizon when navigating with one of these devices.

The Blender navigation preferences show what appears to be all you need to control the movement of your scene with a 3D mouse, but, apparently, these settings are generic and independent of whatever device you may be using. (Screen captured from Blender 2.82 for macOS.) Orbit Method: Turntable should maintain the horizon level at all times, and it does ... as long as you navigate with a traditional mouse or trackpad.

Image

As soon as you switch to a 3D mouse, however, your horizon goes crazy, especially if you have the sensitivity and/or speed turned way up. And this happens no matter which option you are using for the Orbit Method in Blender preferences.

However, if you press the Left button on your 3D mouse (models other than the SpaceMouse Compact may be different, but I can't test those), you will get a device-specific contextual menu that offers separate controls for the input device. In this case, you can specify the "turntable" option for orbiting and this will maintain a level horizon. (Well, it will maintain the horizon at whatever level you start from when the option is selected; if you are already rolled left or right, the app will maintain the degree of roll until you deselect "turntable" and correct the roll, then re-enable "turntable." For this reason, I fixed the roll on a fresh scene and then used the Defaults > Save Startup File option to make sure I get these options from the start of every new session.)

Image

I hope this helps someone. I'm new to Blender and to using a Spacemouse device, so I was really frustrated with the lack of control until I figured this out.

Post Reply