Conflict 3dxware 10.4.4 with Logitech Mouse driver!

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

Post Reply
nxym
Posts: 2
Joined: Tue Jun 07, 2011 3:12 pm

Conflict 3dxware 10.4.4 with Logitech Mouse driver!

Post by nxym » Thu Jun 08, 2017 4:50 am

I have a conflict with logitech mouse driver and 3dxware 10.4.4 and so on . When my Mac starts the spacepilot pro move the pointer mouse and my mouse M705 working with the mac's driver (not the logitech one). In system preferences neither the spacepilot preferenses nor the logitech mouse preferenses see them connected. Only if i retouch both (unplug and plug again ) then both working again. I try all the previous driver versions and none off them works. From 10.4.0 and earlier preferences not working at all. I have oS X 10.11.6 El Capitan

Anyone help?

Thanks

jpiiv
Posts: 1
Joined: Mon Jul 03, 2017 5:08 pm

Re: Conflict 3dxware 10.4.4 with Logitech Mouse driver!

Post by jpiiv » Mon Jul 03, 2017 5:21 pm

We seemed to be having the same issue. We "forgot" the logitech device and the 3D wireless mouse started working then we re-paired the logitech devices and they both worked. My best guess is it was a conflict in which order they were installed. Perhaps it worked because the 3D mouse driver was installed first whereas before it was the logitech device first and 3D mouse second... doesn't make a ton of sense honestly but it worked for us.

Thanks for your post, it triggered the idea to reverse the driver install order.

Post Reply