Error message in SketchUp (3DxWare v1.5.1)

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

Post Reply
jasonh1234
Posts: 7
Joined: Mon May 19, 2008 5:11 pm
Location: Vancouver, BC Canada

Error message in SketchUp (3DxWare v1.5.1)

Post by jasonh1234 » Mon Sep 01, 2008 11:56 pm

SketchUp 6 (v6.0.514)
3Dxware v1.5.1
Firmware v3.18

The error:

Error Loading File 3DxSketchUp.rb
dlopen(/Library/Application Support/Google SketchUp 6/SketchUp/Plugins/3DxSketchUp.bundle.plugin/Contents/MacOS/3DxSketchUp.bundle, 9): Library not loaded: @executable_path/../Frameworks/Ruby.framework/Versions/A/Ruby
Referenced from: /Library/Application Support/Google SketchUp 6/SketchUp/Plugins/3DxSketchUp.bundle.plugin/Contents/MacOS/3DxSketchUp.bundle
Reason: Incompatible library version: 3DxSketchUp.bundle requires version 1.8.0 or later, but Ruby provides version 1.0.0 - /Library/Application Support/Google SketchUp 6/SketchUp/Plugins/3DxSketchUp.bundle.plugin/Contents/MacOS/3DxSketchUp.bundle

flomotan
Moderator
Moderator
Posts: 287
Joined: Mon Jan 08, 2007 3:37 pm

Post by flomotan » Wed Sep 03, 2008 9:53 am

It appears that the installation of Ruby on your Mac is non-standard. For OS X, the version of Ruby that ships with the operating system are:

OS X version ------ Ruby version
10.4.11 ------ 1.8.2
10.5.4 ----- 1.8.6

There might have been some other application that installed a non-standard version of Ruby on your machine?

jasonh1234
Posts: 7
Joined: Mon May 19, 2008 5:11 pm
Location: Vancouver, BC Canada

Post by jasonh1234 » Wed Sep 03, 2008 2:58 pm

flomotan wrote: There might have been some other application that installed a non-standard version of Ruby on your machine?
I believe you're right. Thx.

Post Reply