Onshape and Space Pilot

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

Post Reply
behnt
Posts: 6
Joined: Mon May 04, 2015 3:18 pm

Onshape and Space Pilot

Post by behnt » Wed Jun 01, 2016 8:27 am

Hey all. I have done a basic search and to be honest some threads did the TL;DR to me... So like any self respecting needy guy I am posting a question that I hope has been answered already.

For the life of me I cannot get my SpacePilot to pan left and right in onshape... Driving me mental. Here is what I have done so far:

I have a Mac, 3D connexion Spacepilot Pro

-Tried resetting the 3Dconnexion settings
-played with all the buttons on the pilot
-tried remapping the axii in the settings dialog
-tried different browsers safari and chrome
-uninstalled the drivers (including going in and removing the user/library/prefrences/ folder
-reinstalled
-made a new profile configuration and think I hit every button and toggle in the settings to see if it changed anything
-made sure my drivers are up to date.
-tried the device on my PC and it works flawlessly

Please for the love of all that is holy help me fix this so I can turf my P.C.

behnt
Posts: 6
Joined: Mon May 04, 2015 3:18 pm

Re: Onshape and Space Pilot

Post by behnt » Wed Jun 01, 2016 11:24 am

HA! For those having this issue you need to:
uninstall the drivers via Applications/3dConnexion
get into the /user (your username)/Library/Preferences/ and remove all the com. files in relation to 3Dconnexion
In my case the ccom.3dconnexion.3DMouseHome.plist was what I am pretty sure was the offending file.

Reinstalled and Voila! now to shelve my PC and Saladworks in hopes of never touching it again.

Post Reply