Could not load 3Dconnexion preference pane

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

Post Reply
pmcenroe
Posts: 3
Joined: Tue Nov 24, 2015 3:03 pm

Could not load 3Dconnexion preference pane

Post by pmcenroe » Tue Nov 24, 2015 3:11 pm

I've just installed the latest drivers using 3DxWareMac_v10-2-4_r2077 on my Mac running El Capitan 10.11.1 (15B42)

When I try to configure my Space Navigator using the preferences under System Preferences I get the subject error. I can use my Space Navigator in Sketchup 15.3.329 but I can't make any adjustments.

Any help is appreciated.

UtaSH
Moderator
Moderator
Posts: 3251
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Could not load 3Dconnexion preference pane

Post by UtaSH » Wed Nov 25, 2015 8:57 am

Hi pmcenroe,

can you give more details about the error? What does it say?

Please verify if uninstalling the driver solves the issue. Run the Uninstaller from the driver package (Applications/Utilities/Uninstall 3Dconnexion Driver.app). Then install it again.

Let us know what you find out. Thanks.

pmcenroe
Posts: 3
Joined: Tue Nov 24, 2015 3:03 pm

Re: Could not load 3Dconnexion preference pane

Post by pmcenroe » Thu Nov 26, 2015 10:22 am

Hi,

The error is: Preferences Error Could not load 3Dconnexion preference pane.

I have uninstalled and reinstalled the driver using the Uninstaller but it did not solve the problem.

Thanks!

evisse
Posts: 4
Joined: Wed May 25, 2011 2:32 am
Location: SWEDEN

Re: Could not load 3Dconnexion preference pane

Post by evisse » Fri Feb 26, 2016 9:46 am

Hi,

I have the exact same problem with the latest drivers & el capitan. Have reinstalled several times, but does not help....

Solution, anyone???

UtaSH
Moderator
Moderator
Posts: 3251
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Could not load 3Dconnexion preference pane

Post by UtaSH » Mon Feb 29, 2016 6:28 am

Hi evisse,

have you first uninstalled it with the Uninstaller from the driver?

Try the following:
  • Open the Console. You can search it with the Spotlight or directly go to /Applications/Utilities.
  • Then try again to open the 3Dconnexion preferences.
  • Watch if there are new messages on the Console. Post them here if yes.
Another thing to try:
  • Open the Disk Utility.
  • Go to "First Aid".
  • Do a "Verify Disk Permission" and if this brings errors do a "Repair disk permissions".
Let me know what you find out. Thanks.

duncanquick
Posts: 1
Joined: Tue Apr 05, 2016 5:26 pm

Re: Could not load 3Dconnexion preference pane

Post by duncanquick » Tue Apr 05, 2016 5:32 pm

I'm using El Capitan 10.11.3, the 10-3-1-r2250 installs ok but the wireless doesn't work on my SpaceMouse Pro Wireless. I hard USB cabled it and it is fully working in OnShape under Chrome at least. The 3DMouseHome app just crashes, with the error: 6/04/2016 10:30:13.165 AM launchservicesd[83]: SecTaskLoadEntitlements failed error=22
The System Preferences pane 3Dconnexion app does work and allows setting up the mouse, so I expect the 3DMouseHome is just a hangover from porting from Windows and will be deleted in the next release. The same mouse on the same Mac Mini running Windows 7 under Bootcamp works fine, wirelessly.

renemedel
Posts: 1
Joined: Fri Jul 01, 2016 3:40 am

Re: Could not load 3Dconnexion preference pane

Post by renemedel » Fri Jul 01, 2016 4:02 am

Hello,

I also have problems with my SpaceMouse Enterprise Kit.
CAD Mouse is working fine, but SpaceMouse is on, but not working.

I checked the Console, but only got a Wacom message:
01/07/16 12:56:45,840 WacomTabletDriver[266]: handleNotification:HelpBookRegistrationDidChange

3D Connexion Preference Pane shows only CAD Mouse, no SM

I tried uninstalling drivers (3DxWareMac_v10-3-1_r2250.dmg), reboot, then install again and reboot. But nothing changed.


How could I fix this?

Thanks

UtaSH
Moderator
Moderator
Posts: 3251
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Could not load 3Dconnexion preference pane

Post by UtaSH » Mon Jul 04, 2016 7:13 am

Hi renemedel,

I am sorry, but the driver for the SpaceMouse Enterprise on Mac is not (yet) released. It should be available very soon. Please bear with us for some time. Thanks.

Post Reply