Axes configuration not working!

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

Post Reply
Kodama
Posts: 3
Joined: Tue Mar 10, 2020 2:15 am

Axes configuration not working!

Post by Kodama » Tue Mar 10, 2020 2:25 am

In the Axes preference menu I have tried to adjust the "axes' configuration, both for 'Any Application' and for 'Rhinoceros'.
Even after restarting and trying multiple times nothing seems to change about the behavior of the Spacemouse.

I tried to disable 'roll left' and 'roll right' with no effect either. Also when changing the 'overall speed' it seems to have no effect whatsoever regardless what application is being used.

Any help would be highly appreciated!
Thanks.

Kodama
Posts: 3
Joined: Tue Mar 10, 2020 2:15 am

Re: Axes configuration not working!

Post by Kodama » Tue Mar 10, 2020 4:31 am

Updating the problem:

I figured out that if I make changes to the axes in 'System Preferences' '3dConexion' window I need to both close the window and restart Rhinoceros before the changes take effect.
So this is one part of the problem that is fixed.

HOWEVER

After many attempts and fiddling around with settings for over an hour I have failed to make it work how I like.
Simply put I would like to have the Spacemouse behave in Rhino just as it does when you open the '3dConexion Viewer'. You know the one with the jet engine showing where you can play around with the space mouse to see how it works.

It would be greatly beneficial if someone could share their settings with me for Rhino that make the Spacemouse behave as described.
I also remember this used to be much easier in the past since I was able to do so years ago. However with the new version of the driver and software. (I migrated to a new computer) all of this seems quite difficult to achieve.

Sebastian_art
Posts: 5
Joined: Wed Mar 25, 2020 8:05 am

Re: Axes configuration not working!

Post by Sebastian_art » Wed Mar 25, 2020 8:17 am

Holding down "shift" button while moving the mouse usually binds the cursor to a specific axis of movement. This does not happen with the joystick. This problem can be overcome if you enable the option "Dominant" (main) in the 3Dconnexion parameters, which restricts the movement along the axes. And vice versa.
If I understand your problem correctly.

Post Reply