3DConnexion Drivers for MAC OS Catalina?

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

ginpamorca
Posts: 1
Joined: Sat Nov 09, 2019 7:42 am

Re: 3DConnexion Drivers for MAC OS Catalina?

Post by ginpamorca » Sat Nov 09, 2019 8:22 am

Hi All

I have tried absolutely everything suggested on this thread and I still can not get my Space Navigator to be recognised by the 3dconnexion system preference app. My previously working device is now no longer recognised by the software. It is perfectly visible by the Mac through system report connected to the USB. I have installed reinstalled down graded upgraded everything suggested and this new version of the driver is still not working on my Late 2014 iMac 27" which I have never had trouble with before this upgrade to 10.15.1. Any further help would be so much appreciated.

I have followed all steps listed above. Installing everything I just don't know what else to do.

Please help

Regards

Paul

Gromit
Posts: 2
Joined: Sun Nov 10, 2019 6:35 am

Re: 3DConnexion Drivers for MAC OS Catalina?

Post by Gromit » Sun Nov 10, 2019 9:02 am

Hello Uta,
thank you for the instruction. Unfortunately, my SpaceMouse is not detected (but its working with W10). The LED does not light up, wenn I finally (after the last reboot) plug in the SpaceMouse and in its control pane the mouse remains greyed out. The system control for security / input monitoring shows 3DconnexionHome as marked. There, I added the Trainer and 3DxNLServer. Finally I've tried to deactivate the trackpad, but no change. Is there anything else to activate?
Thank you very much.

pupinko
Posts: 1
Joined: Mon Nov 11, 2019 1:25 am

Re: 3DConnexion Drivers for MAC OS Catalina?

Post by pupinko » Mon Nov 11, 2019 1:43 am

Hi all,

new driver. GREAT, but not for me.

For some reason the space navigator worked this morning by sudden with Catalina and Sketchup, without expecting this. Anyway I decided to install the newest drivers today. RESULT it is not working anymore, except the usual default mouse behavior, when drivers are outdated.

I followed the deinstall and reinstall suggestion, but nothing changed .... ? :(

Gromit
Posts: 2
Joined: Sun Nov 10, 2019 6:35 am

Re: 3DConnexion Drivers for MAC OS Catalina?

Post by Gromit » Mon Nov 11, 2019 1:13 pm

Dear Uta,

thank you for the instruction, which I have followed. Unfortunately, my Spacemouse does not work in Catalina. I deinstalled the antivirus software and tried the installation again. No success. Is there anything else to do, e.g. safety controls in iMacs system control pane?

Thanks for any help.

dingr3dcnx
Posts: 2
Joined: Mon Nov 11, 2019 5:33 pm

Re: 3DConnexion Drivers for MAC OS Catalina?

Post by dingr3dcnx » Mon Nov 11, 2019 5:48 pm

Updated to version 10.6.4 on my iMac running Catalina after deleting the old 10.6.3 as recommended in the installation notes. SpaceNavigator still does not work.

The Pref Pane shows "No Device Found". Operating the SpaceNavigator does cause the cursor to move. But since the driver does not recognize the device, it does not work as intended.

It has been months waiting for this to work so that I can use it with Fusion 360. But I have adapted to just using keyboard commands in the meantime. So I am unlikely to ever buy any more of these 3DConnexion products because of the lack of support. The SpaceNavigator does make a handsome-looking paperweight, though, with its brushed nickel and black finish. Nice and weighty. :roll:

UtaSH
Moderator
Moderator
Posts: 3498
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: 3DConnexion Drivers for MAC OS Catalina?

Post by UtaSH » Wed Nov 13, 2019 2:58 am

Hi all,

I apologize that you encounter problems with your 3Dconnexion device on macOS 10.15. I recommend that you contact our Technical Support Team. They will do an individual troubleshooting with you to find out what is going wrong on your machine.

dingr3dcnx
Posts: 2
Joined: Mon Nov 11, 2019 5:33 pm

Re: 3DConnexion Drivers for MAC OS Catalina?

Post by dingr3dcnx » Wed Nov 13, 2019 8:53 am

Summary: SpaceNavigator now works under macOS Catalina.

I contacted the Technical Support Team via the link and they got back to me within the hour.

The steps suggested by the Team were:

1. Uninstall the current driver. Go to Finder >> Applications >> 3Dconnexion >> Uninstall.
2. Reboot
3. Install the driver. Make sure to Accept all the prompts.
4. Reboot
5. Click the Apple Icon
6. System Preferences
7. Security and Privacy
8. Under the General tab, click "Allow" for "3Dconnexion S.A.M." This should be below "Allow apps downloaded from:" You can also refer to the link here for images: https://www.3dconnexion.com/nc/service/ ... ojave.html

After a final reboot following Step 8, the SpaceNavigator was recognized and works like it did pre-Catalina.

marcel_911
Posts: 3
Joined: Sun Jul 28, 2019 1:23 pm

Re: 3DConnexion Drivers for MAC OS Catalina?

Post by marcel_911 » Mon Dec 02, 2019 2:58 pm

dingr3dcnx wrote:
Wed Nov 13, 2019 8:53 am

8. Under the General tab, click "Allow" for "3Dconnexion S.A.M." This should be below "Allow apps downloaded from:"

After a final reboot following Step 8, the SpaceNavigator was recognized and works like it did pre-Catalina.
This was the bit that made it work for me.

I was disappointed that the teapot demo was jerky but I gave Fusion 360 a go and it's as smooth as butter.

I am happy now :)

JetForMe
Posts: 6
Joined: Wed Mar 27, 2019 12:36 am

Re: 3DConnexion Drivers for MAC OS Catalina?

Post by JetForMe » Sun Jul 05, 2020 2:47 am

My SpaceMouse Pro was working (finally) on Catalina. Then I got a new MacBook Pro and it stopped, even though I migrated from the old one.

So I downloaded the installer and ran it, then Allowed "3Dconnexion S.A.M.," then restarted again (why does this need a restart at all?), and it still doesn't work. In the Prefs pane, under Tools, it says "No Device Found," but it's definitely connected (shows up in USB Prober).

None of the 3DConnexion kexts are loaded. I expressly loaded /Library/Extensions/3Dconnexion.kext, but it made no difference. There are two embedded kexts but loading those does not result in them showing up in kextfind -loaded.

This is pretty frustrating.

JetForMe
Posts: 6
Joined: Wed Mar 27, 2019 12:36 am

Re: 3DConnexion Drivers for MAC OS Catalina?

Post by JetForMe » Sun Jul 05, 2020 2:50 am

Oh, I take it back. After that last set of kextload calls that didn't seem to do anything, and unplugging and re-plugging AGAIN, it now shows up in the Prefs Pane. I had to quit & relaunch Fusion 360 for it to work there, but now it's working. Dunno if it'll survive a restart. But this was more difficult than it should have been.

Post Reply