A odd thing with the driver

Questions and answers about 3Dconnexion devices on UNIX and Linux.

Moderator: Moderators

Post Reply
Absum
Posts: 53
Joined: Tue Apr 24, 2007 4:00 am
Location: Sweden
Contact:

A odd thing with the driver

Post by Absum » Mon Apr 30, 2007 6:39 pm

I've noticed a odd thing when using my SpaceNav i Ubuntu 7.04, first of all, when ever i shutdown the driver connection via the sdk i get a window in my face saying i should save the current settings for this application, at the beginning i did that and set it to autosave until i noticed that whenever it save the settings it stopped sending events to my window.

Oh and the motif windows are ugly :S cant you guys make a ncurse based interface or just plain commandline instead?

crobl
Moderator
Moderator
Posts: 131
Joined: Mon Feb 26, 2007 8:34 am
Location: Freiham, Germany

Post by crobl » Thu May 03, 2007 8:36 am

Hi Absum,

you get the "Save dialog" everytime:
1. The configuration is modified and your application uses "MagellanClose()" or you change focus to another application.
2. Yor your application registers at the driver, no configuration exists and your application uses the "MagellanClose()" function to "unregister" from the driver or you change focus to another application.

Note: "change focus to another application" means, that there either exists a configuration for this application or this application registers at the driver.


Regarding your other issue:
... set it to autosave until i noticed that whenever it save the settings it stopped sending events to my window.
Please uncheck "autosave" and look what the "Save dialog" say the configuration is saved for? Is this the correct window name (your applications window)?


Concerning the "ugly Motif windows".. NCurses? :shock:
No, honestly: Our driver is meant to support graphics application. Therefore it doesn't make sense to do a terminal application.
Maybe in a future version we will possibly provide a modern GUI for
the driver.


Regards

Christian
3Dconnexion

Absum
Posts: 53
Joined: Tue Apr 24, 2007 4:00 am
Location: Sweden
Contact:

Post by Absum » Fri May 04, 2007 5:10 am

But even if i save the changes manually and the save-dialog saves with the right application name it still stops sending events.

3d pepper
Posts: 2
Joined: Thu Aug 23, 2007 7:48 am
Location: Germany

Post by 3d pepper » Thu Aug 23, 2007 8:22 am

Hi Absum,

this is my first post in this forum and got the same problem too.
For me the trouble comes if i start the 3d connexion driver on another desktop
than blender ( i do this to have a cleaner workspace).

so my workaround is :

start ubuntu , start the driver ,start blender (or the 3d app.) make one move
with the space pilot in your app. than all works fine and you can push the
driver window to another desktop.

Post Reply