problem with SuSE

Questions and answers about 3Dconnexion devices on UNIX and Linux.

Moderator: Moderators

Post Reply
aguzz
Posts: 2
Joined: Wed Jul 04, 2007 12:00 pm

problem with SuSE

Post by aguzz » Mon Jul 09, 2007 11:52 am

Hi,
I am trying to get a usb Space Navigator PE to work on my two linux box with this driver 3dxware-linux-v1-2-7.tgz.
The first is a i386 Suse 9.1, and the second is a amd x86_64 Suse 9.3.
The device run perfectly under windows XP.
my first system is :
linux:~ # uname -a
Linux linux 2.6.4-52-smp #1 SMP Wed Apr 7 02:11:20 UTC 2004 i686 i686 i386 GNU/Linux
the output of /tmp/3DxWare.log is
3DxWareUNIX V1.2.7 DI 2994 log file
Process ID: 2652
Time: 2007-07-05 22:02:46
Runlevel-Info: run-level 5 Jul 5 22:02 last=S

-----------------------------------

[2007-07-05 22:02:46] 3dxsrv.c,647: displayname = $DISPLAY set to :0
[2007-07-05 22:02:47]
[2007-07-05 22:02:47] 3dxsrv.c :: startupInittab(), authGetUser(), failed to get user
[2007-07-05 22:02:47] Error: 3dxsrv.c :: startupInittab(), authGetUser(), failed to get user
[2007-07-05 22:02:48]
Also my second system
linux:~ # uname -a
Linux linux 2.6.11.4-20a-default #1 Wed Mar 23 21:52:37 UTC 2005 x86_64 x86_64 x86_64 GNU/Linux
show the same problem.
Can anyone help me ?
Thank you in advice

UtaSH
Moderator
Moderator
Posts: 3498
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

SpaceNavigator and SuSE 9.x

Post by UtaSH » Tue Jul 10, 2007 3:26 am

Hi aguzz,

unfortunately you will not be able to use the SpaceNavigator on your first system with kernel 2.6.4. :( The minimum requirement for our USB devices is kernel 2.6.8. This noted in the InstallationInstructions.

But the second system is recent enough. You just need the driver that has the fix for the problem "failed to get user". Please send me you email addreass in a private message and I can send you a beta version of this driver.

Uta Ludwig
3Dconnexion

Post Reply