Space Navigator installing problem

Questions and answers about 3Dconnexion devices on UNIX and Linux.

Moderator: Moderators

Post Reply
Stan1
Posts: 9
Joined: Tue Apr 21, 2015 1:25 pm

Space Navigator installing problem

Post by Stan1 » Tue Apr 21, 2015 1:47 pm

Hi there,
So, installing last driver 1.8.0, everything fine. Next, after

Code: Select all

/home/stan/3dxconnection/etc/3DxWare/daemon/3dxsrv -d usb
it says -

Code: Select all

[2015-04-22 02:14:39] Error: Can't find any configuration files! Please reinstall you configurations in /etc/3DxWare properly!
Segmentation fault 
Ok, changing permission on all 3DxWare files and dirs to rwxrwxrwx but nothing happens. Still got the same message.

so this is log file:

Code: Select all

3DxWareUNIX V1.8.0 ID 10505 log file
Process ID: 3793
 Time: 2015-04-22 02:14:29
Machineinfo 1: Systemname=Linux, Nodename=localhost, Release=3.18.1-pclos1
Machineinfo 2: Version=#1 SMP Wed Dec 17 00:55:07 CST 2014, Machine=x86_64
Runlevel-Info:          уровень выполнения 5 2015-04-21 13:16                   предыдущий=S

-----------------------------------

[2015-04-22 02:14:29] uddev.c, 1060: UdDevInit() 0xa15010
[2015-04-22 02:14:29] 3dxsrv.c,806: displayname = :0.0
[2015-04-22 02:14:29] auth.c :: authGetUser(), FOUND: user = stan, id = :0, line = tty8, pid =    32568, host = :0, type = 7
[2015-04-22 02:14:29] auth.c :: authGetUser(), FOUND: user home = "/home/stan"
[2015-04-22 02:14:29] 3dxsrv.c :: startupCommandLine(), authGetUser(), user=stan
[2015-04-22 02:14:29] UdDev: Opening USB device on USB port /dev/bus/usb/003/002
[2015-04-22 02:14:29] UdDev: Opening SpaceNavigator on USB port /dev/bus/usb/003/002
[2015-04-22 02:14:29] snav_usb.c :: UdDevRezero(): Rezeroing the device
[2015-04-22 02:14:29] snav_usb.c :: UdDevSetDeadband(): Setting deadband to 26
[2015-04-22 02:14:29] 3dxsrv.c,831: UdDevOpen() was successful [SpaceNavigator]
PClinuxOS 2014.12
Kernel 3.18.1-pclos1
xcfe

What should I do?

Stan1
Posts: 9
Joined: Tue Apr 21, 2015 1:25 pm

Re: Space Navigator installing problem

Post by Stan1 » Tue Apr 28, 2015 4:57 am

so, there is no tech support anymore, isn't it?

Tehrasha
Posts: 186
Joined: Thu Apr 22, 2010 3:55 pm
Location: Iowa
Contact:

Re: Space Navigator installing problem

Post by Tehrasha » Tue Apr 28, 2015 11:01 am

Are you launching the driver as root?
Spacemice -- Input devices for a 3D world.

Stan1
Posts: 9
Joined: Tue Apr 21, 2015 1:25 pm

Re: Space Navigator installing problem

Post by Stan1 » Tue Apr 28, 2015 1:21 pm

sure

Stan1
Posts: 9
Joined: Tue Apr 21, 2015 1:25 pm

Re: Space Navigator installing problem

Post by Stan1 » Tue Apr 28, 2015 11:22 pm

have updated kernel to 3.19.5
same result

UtaSH
Moderator
Moderator
Posts: 3251
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Space Navigator installing problem

Post by UtaSH » Mon May 04, 2015 7:45 am

Hi Stan1,

sorry, but the path for the driver cannot be changed. You have to install it in /etc/3DxWare. (Or use at least softlinks to that path.)

Stan1
Posts: 9
Joined: Tue Apr 21, 2015 1:25 pm

Re: Space Navigator installing problem

Post by Stan1 » Mon May 04, 2015 11:37 pm

Thanks,that wasn't obvious )
Now driver works, demo cube is moving\rotating fine, I can see configurator (but I didn't get how to start it, command or something), but it doesn't work in blender, zero reaction.
Should I change some kind of blender settings? Under windows it works without any changes

Stan1
Posts: 9
Joined: Tue Apr 21, 2015 1:25 pm

Re: Space Navigator installing problem

Post by Stan1 » Tue May 05, 2015 11:07 pm

Seems there is an one reply per two weeks on this support forum)
ok, let's wait)
meanwhile I have got that driver panel starts automatically, but is it ok that you can't close demo cube window, kill process only?
blender 2.74 still doesn't know that I use a space navigator and I still wonder why...

Tehrasha
Posts: 186
Joined: Thu Apr 22, 2010 3:55 pm
Location: Iowa
Contact:

Re: Space Navigator installing problem

Post by Tehrasha » Wed May 06, 2015 12:21 am

Stan1 wrote:meanwhile I have got that driver panel starts automatically, but is it ok that you can't close demo cube window, kill process only?
Pressing escape does not exit the cube demo?

I have never had 3DxWare on Linux work with Blender. The old xDriver works with the older serial devices.
For linux Blender, I use the freeware driver spacenavd http://spacenav.sourceforge.net/
Spacemice -- Input devices for a 3D world.

Stan1
Posts: 9
Joined: Tue Apr 21, 2015 1:25 pm

Re: Space Navigator installing problem

Post by Stan1 » Wed May 06, 2015 12:32 am

Tehrasha wrote:
Stan1 wrote:meanwhile I have got that driver panel starts automatically, but is it ok that you can't close demo cube window, kill process only?
Pressing escape does not exit the cube demo?

I have never had 3DxWare on Linux work with Blender. The old xDriver works with the older serial devices.
For linux Blender, I use the freeware driver spacenavd http://spacenav.sourceforge.net/
Lol, it does, I ve tried to close it with window close button)
Thanks for that freeware driver, hope it is more simple in use than the original one.

Stan1
Posts: 9
Joined: Tue Apr 21, 2015 1:25 pm

Re: Space Navigator installing problem

Post by Stan1 » Sat May 30, 2015 3:21 am

So official driver does not work in Blender at all, does it?
I have checked it in Ubuntu 15.04 with same result. That demos work perfectly but Blender does not see device at all.
Is there a way to make it work in Blender or the only solution is to use free driver?
freedriver works with Blender but has not got so many settings to set up

Post Reply