Search found 129 matches

by crobl
Mon Dec 18, 2017 4:44 am
Forum: Developer's Forum for macOS
Topic: Filter by RegisterConnexionClient ID?
Replies: 1
Views: 14378

Re: Filter by RegisterConnexionClient ID?

Hello mcc, you're correct, RegisterConnexionClient() returns a unique ID/handle for the connection to 3DxWareMac. It's also correct to use this handle to "filter" for the incoming events, to lower the processing needs for incoming events. Unfortunately you didn't provide any code, so I can only gues...
by crobl
Mon Dec 18, 2017 4:26 am
Forum: Developer's Forum for macOS
Topic: Cross platform development
Replies: 1
Views: 12794

Re: Cross platform development

Hello mcc, I understand, that you're interested in a uniform way of development, but when you support different platforms and OSes you generally/usually need to deal with their different APIs. Best practice in terms of support for multiple platforms is to abstracting at a certain (useful) level and ...
by crobl
Mon Apr 03, 2017 6:50 am
Forum: Developer's Forum for macOS
Topic: API switch LED off?
Replies: 5
Views: 26027

Re: API switch LED off?

Hi The BaronHimself, for the Wireless devices (SpaceMouse Wireless and SpaceMouse Pro Wireless) behaviour of the blue LED is a bit different when compared to our wired devices: 1. When connected via USB cable, the blue LED can be switched on/off via the checkbox "Enable LEDs" from the "Tool" tab in ...
by crobl
Tue Mar 28, 2017 7:34 am
Forum: Developer's Forum for macOS
Topic: Changing Prefs has no (almost) effect
Replies: 2
Views: 16136

Re: Changing Prefs has no (almost) effect

Hello hjbflyer, if by "calibrating the sensitivty of the device" you want to generate a custom speed or kind of "equalise" the speed to a certain level within your application (or as your attachment suggests: for all Java applications), the answer unfortunately is: Yes, you're wrong. :wink: The spee...
by crobl
Tue Mar 28, 2017 6:15 am
Forum: Developer's Forum for macOS
Topic: API switch LED off?
Replies: 5
Views: 26027

Re: API switch LED off?

Hello hjbflyer, thank you for your question! I've had a look into this and we've found a bug in the driver! It seems that until now no one was interested in using this API call/functionality. We're fixing the issue and it'll be available in the next release, but at the moment I cannot give you a dat...
by crobl
Mon Mar 27, 2017 3:03 am
Forum: Developer's Forum for macOS
Topic: Space Mouse Enterprise Buttons
Replies: 3
Views: 18322

Re: Space Mouse Enterprise Buttons

Hi hjbflyer, you're almost correct: It's not SetConnexionClientMask() - just call SetConnexionClientButtonMask(clientID, kConnexionMaskAllButtons); This will do the job! The button numbers can be calculated from the mask buttons, there is no "1" (label on the device) -> "whatever value received" tab...
by crobl
Mon Mar 27, 2017 2:41 am
Forum: Developer's Forum for macOS
Topic: Application Commands
Replies: 2
Views: 14771

Re: Application Commands

Hi nbays1975, we've currently not explained kConnexionCmdAppSpecific in our SDK as it's still a bit circumstantial at the moment to make use of "Application Commands". The changes that are necessary (in the development process on your side) may mess up your driver's installation if not done correctl...
by crobl
Wed Jul 02, 2014 7:09 am
Forum: Developer's Forum for macOS
Topic: Button mapping in preferences not used
Replies: 3
Views: 24531

Re: Button mapping in preferences not used

Hello Heine,

thats great to hear, that your issue is solved.

If you have any question, please feel free to ask!

Regards,

Christian
by crobl
Thu Jun 26, 2014 7:17 am
Forum: Developer's Forum for macOS
Topic: Button mapping in preferences not used
Replies: 3
Views: 24531

Re: Button mapping in preferences not used

Hello Heine, please, try to change the mask parameter of RegisterConnexionClient() to kConnexionMaskAxis only. This should do the job. Note: Do not call SetConnexionClientButtonMask() after that. If you call RegisterConnexionClient() with a button mask or call SetConnexionClientButtonMask() it tells...
by crobl
Tue Jan 28, 2014 1:15 am
Forum: MacOS Discussion Forum
Topic: OSX Maya 2013 64bit w/ SpaceNavigator
Replies: 3
Views: 7157

Re: OSX Maya 2013 64bit w/ SpaceNavigator

Hi andrewjarvis, 3DxMayaResources is actually not a plugin for Maya. It is a resource bundle supporting 3DxMaya. There is no need to load 3DxMayaResources via the Plugin Window, nor will it work (as you experienced). 3DxMaya on the other hand can be loaded and actually should be automatically loaded...
by crobl
Fri Oct 25, 2013 8:42 am
Forum: MacOS Discussion Forum
Topic: SpaceNavigator gets mouse control in OS X 10.9 Mavericks
Replies: 2
Views: 7580

Re: SpaceNavigator gets mouse control in OS X 10.9 Mavericks

Hi Keith, if you want to just have the KEXT to be installed. you need to first install the complete 3DxWareMac and remove all unwanted files manually afterwards. Please note, that our latest driver will work on OS X 10.9 Mavericks, but you will get a warning dialog after the kext has been loaded, th...
by crobl
Tue Oct 22, 2013 6:55 am
Forum: MacOS Discussion Forum
Topic: No fn modifer key option when creating application profile?
Replies: 4
Views: 7158

Re: No fn modifer key option when creating application profi

Hi kult, as Therasha already wrote, the fn key is handled in firmware and never exposed to the OS in any way so there is no way to emulate it. To my knowledge there is no support for the fn key in any API that I know of (unless Apple recently changed the implementation). Looking at possible workarou...
by crobl
Wed Nov 21, 2012 7:39 am
Forum: MacOS Discussion Forum
Topic: SpaceExplorer Not Working in Sketchup Using Mountain Lion 10
Replies: 17
Views: 27968

Re: SpaceExplorer Not Working in Sketchup Using Mountain Lio

Hello everybody, I just wanted to give a little update on this issue, not leaving you in a information void. We may have found the bug; at least a strong suspicion. If anyone here likes to verify: (For those of you that already added SketchUp according to my hint given earlier in this thread, please...
by crobl
Tue Oct 02, 2012 7:23 am
Forum: MacOS Discussion Forum
Topic: SpaceExplorer Not Working in Sketchup Using Mountain Lion 10
Replies: 17
Views: 27968

Re: SpaceExplorer Not Working in Sketchup Using Mountain Lio

Hi txparticleman, nice to hear! Although I didn't expect the workaround not to survive a reboot. Here in our Lab its stable, meaning I could reboot as often as I like (OS X 10.8.2) and SketchUp is still works. We'll keep on working on this issue anyway and I'll keep you updated when there's a fix av...
by crobl
Mon Oct 01, 2012 3:23 am
Forum: MacOS Discussion Forum
Topic: SpaceExplorer Not Working in Sketchup Using Mountain Lion 10
Replies: 17
Views: 27968

Re: SpaceExplorer Not Working in Sketchup Using Mountain Lio

Hi txparticleman, thank you for your additional info on this / your issues. Regarding GoogleEarth 6.2 it may be necessary to enable the 3D Mouse. In Google Earth open the "Preferences" menu, "Navigation" tab and check "Enable controller" (maybe you'll need to restart GE after this). If this should n...