Got problems with Blender? Read here.

Questions and answers about the SpaceNavigator 3D Mouse on Mac OS X

Moderator: Moderators

Re: Got problems with Blender? Read here.

Postby laptopleon » Sun Jun 19, 2016 7:54 am

Since I wanted to pick up 3D drawing again, leaning towards Blender, I bought a Spacenavigator. Specially when I set up the preferences the way that feels natural, the demo software works like a charm. The bigger the disappointment when you try to use it with Blender.

Tehrasha wrote:Blender does not recognize 3dconnexion settings for sensitivity and buttons, and requires you to assign their values and function within Blender's preferences. This may sound like horrible implementation, but it allows Blender to use ALL usb model of spacemouse (at least under windows), even if they are considered obsolete and unsupported by 3dconnexion.


Still, this would be a very workable solution. In reality though, Blender reacts completely different to the Spacenavigator compared to the 3DConnexion demo viewer.

There is no information whatsoever about 3D mice, Spacenavigator, setting adjustments for 3Dconnexion peripherals, etc in the Blender Manual nor the 3Dconnexion website.

After many hours of messing about the preferences/setting, I have given this up as a way to find a workable fix. It seems to me that in Blender, the 3D-mouse moves the camera that you are looking through, instead of the object you are looking at. Let's call this the camera-oriented approach. This I can at least understand, although it doesn't make sense that you can't set Blender to use the 3D-mouse to use the object-oriented approach.

On Windows, the Spacenavigator seems to work exactly as in the 3Dconnexion Viewer demo software in this video from 2014. It does object-oriented approach movement. Why doesn't it work like that on OS X?
laptopleon
 
Posts: 3
Joined: Wed Jun 15, 2016 3:25 pm

Re: Got problems with Blender? Read here.

Postby Tehrasha » Sun Jun 19, 2016 11:34 am

laptopleon wrote:After many hours of messing about the preferences/setting, I have given this up as a way to find a workable fix. It seems to me that in Blender, the 3D-mouse moves the camera that you are looking through, instead of the object you are looking at. Let's call this the camera-oriented approach. This I can at least understand, although it doesn't make sense that you can't set Blender to use the 3D-mouse to use the object-oriented approach.


Surprisingly, many people use/prefer the camera-oriented mode, but like you, I am not one of them. I find it backwards to how my brain operates, and non-intuitive.

To change to object-oriented, you will need to 'Invert-Axis' some of the axis settings. Which ones need inverted will vary between spacemouse models.
For example, the device I have hooked up at the moment (an old Spacemouse Plus), I need to flip the X and Z axis (both pan and orbit) and set the 'Y/Z Swap Axis' in the 3D Mouse Settings.

There is also the matter of how Blender allows your motions to be acted upon. Some older versions of Blender would only pan by default, and make you press shift to allow rotation.
Changing this to allow free flight of panning and rotation without a modifier key can be set in the Blender User Preferences >> Input >> 3D View >> 3D View (Global) and scrolling down to the settings dealing with NDOF.

See also:: http://spacemice.org/index.php?title=Blender

All of the above should be done on a fresh new project, then the last and most important step is to save these preferences (and Save Startup File') or they will be lost the next time you close and restart Blender.
Also, older projects which were created before you made these changes may cancel out your settings. When loading these projects you must deselect the 'Load UI' option on the Open File dialog.

Caveat:: There is currently a limitation in Blender in which the 'Rotate around Selection' does not function, when you are using free flight. I do not know why this is the case, I have been after the Blender devs for a long time about this.
If you are free flying, the 'center of rotation' is some point near the camera, so that objects swing and rotate as if they are on the end of a stick, rather than on the select object near the center of the screen. If you hold done your CTRL key, the rotation does occur on the selected object, but now you can no longer pan at the same time. This is a limitation within Blender itself, and not the 3dmouse driver.

Hope this helps!
Spacemice -- Input devices for a 3D world.
Tehrasha
 
Posts: 174
Joined: Thu Apr 22, 2010 3:55 pm
Location: Iowa

Re: Got problems with Blender? Read here.

Postby laptopleon » Mon Jun 20, 2016 4:36 pm

Thank you for your reaction. You obviously have a lot experience with these mice and the combination with Blender. Most of the mentioned subjects are still unclear to me though.

First of all, despite your instructions, I haven't succeeded in getting Blender to let the SpaceNavigator handle an object in Object Mode. I tried many 3D mouse setting combinations, checking and unchecking the Orbit, Pan and Zoom options, but nothing changes the View Mode to Object View. It still keeps moving the viewport 'camera' instead of the object itself. For example: Getting to the other side of an object takes forever.

It seems to me that Blender simply doesn't support Object (View) Mode in combination with the SpaceNavigator. Not on the Mac at least. I can't check this though, because I don't have a PC / Linux machine to compare it with. Of course, in Blender you can pick a point with the middle mouse button and orbit around that by keeping it down while moving the mouse, but I can't get that working with the SpaceNavigator.

To reassure we are talking about the same View Object Mode: Meanwhile, I've discovered that SketchUp (I'm using the 2016 version 16.1.1451, for Mac obviously) is per default using the SpaceNavigator in what is (like I had apparently guessed correctly) named Object Mode. You can check what mode is used (and change it) by using the left SpaceNavigator button to invoke a contextual menu.

I mention this because SketchUp in Object Mode is behaving exactly as the 3DConnection demo software and as I would expect how a 3D-mouse would work.

Can you please confirm: 1) You use Mac OS X. 2) Does your SpaceMouse Plus with your settings make Blender behave exactly the same as the Object Mode in SketchUp?
laptopleon
 
Posts: 3
Joined: Wed Jun 15, 2016 3:25 pm

Re: Got problems with Blender? Read here.

Postby laptopleon » Tue Jul 12, 2016 4:16 am

It cost me way too much time to figure out the (im)possibilities of 3D mice on the Mac. There is very little useful information about it to be found online. Therefore, I decided to write an article about 3D mice and Blender for Mac.
laptopleon
 
Posts: 3
Joined: Wed Jun 15, 2016 3:25 pm

Re: Got problems with Blender? Read here.

Postby BlipBertMon » Sun Mar 05, 2017 11:12 am

Works4Me! B. 2.78a + SpaceNav Drivers 10.4.3 + OSX El.Cap 10.11.
NDOF + LMB pops 3D Mouse Settings menu & RMB click zooms to fit objects in 3D View
BlipBertMon
 
Posts: 1
Joined: Sun Mar 05, 2017 11:09 am

Previous

Return to Mac OS X Discussion Forum

Who is online

Users browsing this forum: No registered users and 2 guests